LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 09-09-2005, 11:25 AM   #1
kb_ganesh
Member
 
Registered: Jun 2005
Posts: 42

Rep: Reputation: 15
setting environment variable


i have just installed swfdec-0.3.5 from schleef.org/swfdec/..the README file says that in order for the plugin to be recognised by FF(which is mozilla based), i have to add /usr/local/lib/mozilla/plugins to the MOZ_PLUGIN_PATH environment variable..can someone tell me how i can do this?

thanks..sorry if this is a dumb question..i am still learning in linux
 
Old 09-09-2005, 05:25 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You could add the line:
MOZ_PLUGIN_PATH='/usr/local/lib/mozilla/plugins'
to the /etc/.profile or the $HOME/.profile script.
On some distros, you edit /etc/profile.local instead.
After this line add the line:
export MOZ_PLUGIN_PATH
or if there is a line exporting other variables, add MOZ_PLUGIN_PATH to the end of that line.
 
Old 09-10-2005, 01:08 AM   #3
kb_ganesh
Member
 
Registered: Jun 2005
Posts: 42

Original Poster
Rep: Reputation: 15
i am in ubuntu 5.04..i searched for both the files you mentioned but couldnt find them..the best i found was /etc/profile..which i backed up and then edited to include the line..now, i try restarting FF but still it doesnt open flash files...do i need to install a separate plugin? and i am not able to open flash files outside FF either..they still open in totem(which keeps complaining about codecs)..i dont see swfdec in the other applications list either..??
 
Old 09-10-2005, 02:58 PM   #4
carl.waldbieser
Member
 
Registered: Jun 2005
Location: Pennsylvania
Distribution: Kubuntu
Posts: 197

Rep: Reputation: 32
Quote:
Originally posted by kb_ganesh
i am in ubuntu 5.04..i searched for both the files you mentioned but couldnt find them..the best i found was /etc/profile..which i backed up and then edited to include the line..now, i try restarting FF but still it doesnt open flash files...do i need to install a separate plugin? and i am not able to open flash files outside FF either..they still open in totem(which keeps complaining about codecs)..i dont see swfdec in the other applications list either..??
Create a file in your home directory (~/) named ".bashrc" if id does not already exist. Very likely it does exist already. Add the following to it:
Code:
export MOZ_PLUGIN_PATH=/usr/local/lib/mozilla/plugins
Note that files that start with a period are hidden by default. In the terminal, you can see it with "$ ls -al ~/.bashrc".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
environment variable setting chii-chan Linux - General 5 01-23-2009 08:29 PM
Setting up a environment variable Hiper1 Linux - Newbie 3 03-08-2005 09:43 AM
setting environment variable DISPLAY jpan Debian 4 10-15-2004 07:09 PM
Trouble setting environment variable exitsfunnel Linux - Software 4 10-06-2004 07:49 AM
Setting an environment variable kharris Linux - General 3 10-02-2003 05:38 PM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration