LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-29-2010, 10:57 AM   #1
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Rep: Reputation: 15
Question No Wireless Networks Found After Ubuntu 9.10 Upgrade Using a IBM Wireless-B Card


Hi LQ community,

I Just Upgraded my Laptop from Ubuntu 9.04 to Ubuntu 9.10 and Before I upgraded to 9.10, My Network Was Working Fine, But i've tried installing/upgrading to Ubuntu 9.10 and no such luck.

thanx in advance,

MEPIS1

*Edit* I Upgraded to 10.04 last sunday. it found my network and I now need to figure out how to connect to my network

Last edited by mepis1; 05-05-2010 at 06:48 AM.
 
Old 01-30-2010, 07:38 AM   #2
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,360

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
So that we can better understand your problem, please post the output of the following commands:

Code:
lspci | grep -i net
ifconfig -a
iwconfig
Evo2.
 
Old 01-30-2010, 04:52 PM   #3
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
lspci | grep -i net:
00:03.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 0c)

ifconfig -a:
eth0 Link encap:Ethernet HWaddr 00:02:2d:4a:d5:7d
inet6 addr: fe80::202:2dff:fe4a:d57d/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:2 dropped:2 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2376 (2.3 KB) TX bytes:276 (276.0 B)
Interrupt:3 Base address:0x100

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

iwconfig:
lo no wireless extensions.

eth0 no wireless extensions.
 
Old 01-30-2010, 04:59 PM   #4
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,360

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
The "lspci | grep -i net" seems to have missed the wireless device. Can you please post the full output of lspci?

eg
Code:
lspci
Evo2.
 
Old 01-31-2010, 08:35 AM   #5
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
amilliabilliatrilli910remix@amilliabilliatrilli910remix-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 0c)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)
 
Old 01-31-2010, 08:35 AM   #6
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
amilliabilliatrilli910remix@amilliabilliatrilli910remix-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 0c)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 13)
 
Old 01-31-2010, 09:35 AM   #7
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,360

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
Your machine doesn't seem to have a wireless chip. So, I did some googling... is this a removable PCMCIA device? Was it plugged in to the slot? Does dmesg report anything after you plug it in?

Evo2.
 
Old 01-31-2010, 10:19 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
I think mepis1 is trying to use ethernet, not wireless.
[Edit] No, from the thread title, he wants wireless, but the following might be helpful anyway[/Edit]
Quote:
ifconfig -a:
eth0 Link encap:Ethernet HWaddr 00:02:2d:4a:d5:7d
inet6 addr: fe80::202:2dff:fe4a:d57d/64 Scope:Link
You have an IPV6 address. Most people are not using this yet.

Try disabling ipv6. In 9.10 ipv6 is built into the kernel, so you can't just disable the ipv6 module like you used to be able to do. Also 9.10 uses grub2 so things are a little different:

Add the following line to the file /etc/default/grub
Note there is no "#" at the start of this line. Be careful to get it exactly right.

Code:
GRUB_CMDLINE_LINUX="ipv6.disable=1"
Then sudo update-grub
Reboot.

Any better?

Last edited by tredegar; 01-31-2010 at 11:10 AM.
 
Old 01-31-2010, 09:21 PM   #9
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally Posted by evo2 View Post
Your machine doesn't seem to have a wireless chip. So, I did some googling... is this a removable PCMCIA device? Was it plugged in to the slot? Does dmesg report anything after you plug it in?

Evo2.
Yes It is a PCMCIA card. But I Don't know if dmesg reports anything.
 
Old 02-01-2010, 03:30 AM   #10
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Install the package pcmciautils

Then try this command: lspcmcia
 
Old 02-01-2010, 11:14 AM   #11
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tredegar View Post
Install the package pcmciautils

Then try this command: lspcmcia
umm tredegar.

Is pcmiautils a local package
 
Old 02-01-2010, 11:23 AM   #12
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
pcmciautils is on my kubuntu DVD
 
Old 02-01-2010, 12:56 PM   #13
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
Is pcmiautils a local package
minrich says it's on his CD, so it's probably on yours.

Anyway, in post #3 it looks like your ethernet cable is connected to something and has an IP address. It might work a bit better if you disabled ipv6 [see above] so then you could at least get connected, fetch the updates (which might of itself help), and any further utilities you need to diagnose and fix your wireless problem.

Please confirm that you have checked that your PCMCIA card is properly plugged in, and the "Disable" switch (if any) is not set.

Does the PCMCIA card work in another computer?

For some diagnostic information, try this:
Boot without the card being plugged in.
Plug it in when you get to your desktop.
Look at the last few lines of the file /var/log/messages
Does it say anything that looks as if it could be relevant ?
 
Old 02-01-2010, 05:26 PM   #14
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tredegar View Post
minrich says it's on his CD, so it's probably on yours.

Anyway, in post #3 it looks like your ethernet cable is connected to something and has an IP address. It might work a bit better if you disabled ipv6 [see above] so then you could at least get connected, fetch the updates (which might of itself help), and any further utilities you need to diagnose and fix your wireless problem.

Please confirm that you have checked that your PCMCIA card is properly plugged in, and the "Disable" switch (if any) is not set.

Does the PCMCIA card work in another computer?

For some diagnostic information, try this:
Boot without the card being plugged in.
Plug it in when you get to your desktop.
Look at the last few lines of the file /var/log/messages
Does it say anything that looks as if it could be relevant ?
ok i'll check.
 
Old 02-01-2010, 08:49 PM   #15
mepis1
LQ Newbie
 
Registered: Dec 2009
Distribution: Mepis 8 & Ubuntu Latest
Posts: 25

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by tredegar View Post
I think mepis1 is trying to use ethernet, not wireless.
[Edit] No, from the thread title, he wants wireless, but the following might be helpful anyway[/Edit]

You have an IPV6 address. Most people are not using this yet.

Try disabling ipv6. In 9.10 ipv6 is built into the kernel, so you can't just disable the ipv6 module like you used to be able to do. Also 9.10 uses grub2 so things are a little different:

Add the following line to the file /etc/default/grub
Note there is no "#" at the start of this line. Be careful to get it exactly right.

Code:
GRUB_CMDLINE_LINUX="ipv6.disable=1"
Then sudo update-grub
Reboot.

Any better?
Hey tredegar

I tried it....GRUB loads faster but no beans.
 
  


Reply

Tags
linksys, ubuntu910


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IBM X31 with Ubuntu 7.04 Feisty fawn - wireless, CF card don't work yet ovis Linux - Laptop and Netbook 4 02-06-2008 12:09 PM
wireless card does not see any networks CrinkElite Linux - Newbie 9 11-19-2007 06:34 PM
Upgrade to Ubuntu Gusty - Wireless card no longer detected! ljs662_removed Ubuntu 1 10-04-2007 04:11 AM
Wireless card cannot find networks - FC6 OstermanA Linux - Wireless Networking 1 03-30-2007 05:59 AM
Wireless Networks Not Found HexJunkie Linux - Wireless Networking 2 10-19-2006 12:51 AM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration