Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 03-04-2010, 05:26 AM   #1
LQ Newbie
Registered: Mar 2010
Posts: 2

Rep: Reputation: 0
Question NAM is not working


I have installed Ns-2.33 on ubuntu 9.1 ,Ns 2 has been installed successfully but i think NAM is not working.when i run a script(.tcl) then i get following error message....

nemi@nemi-desktop:~/Desktop$ nam:
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
bind Li..."

Plesse help me to sort out this problem


Old 03-05-2010, 10:10 AM   #2
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2015, Slack14.1 DebJessie, + 50+ other Linux OS, for test only.
Posts: 15,617

Rep: Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990Reputation: 2990
Nam error : [code omitted because of length]

1) Possible reason: Compiling ns-allinone-2.3x with a wrong version of tcl.
Solution : apt-get remove tcl*
( tcl8.4 can be reinstalled after the ns2 / nam build.)
EDIT : Please see post # 4 ... and
...............About the patch 'tk-8.4-lastevent.patch'

2) May be use ns-allinone-2.34 instead.

More info : LQ Search → "Tag Name" = ns2
.. and ..

Last edited by knudfl; 04-19-2010 at 01:54 AM.
Old 03-05-2010, 11:14 PM   #3
LQ Newbie
Registered: Mar 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks friend .
I removed NS-2 2.33 and then i installed 2.34 sucessfully and it is working well.
Old 03-19-2010, 07:58 AM   #4
LQ Newbie
Registered: Mar 2010
Posts: 3

Rep: Reputation: 1
ya i had the same problem. if you do not want to reinstall, do this:

Download the tk-8.4-lastevent.patch from ,

place it in ur tk8.4.18 directory and go to the same directory and execute,

patch -p0 < ./tk-8.4-lastevent.patch

now reinstall tk. if it still does not work , reinstall the whole thing.

though this solution was for fedora, it worked for my ubuntu also.
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in running nam-1.11 of ns-allinone-2.29 rishabhk Linux - Newbie 5 03-17-2011 05:31 AM
nam error in ns-2.29 due to mannsim kuberninad Linux - Newbie 7 02-12-2010 07:02 AM
nam:couldn't connect to display ":0.0 swift_a2002 Linux - Software 2 08-28-2009 01:26 AM
nam network animator farazhasan110 Linux - Software 1 11-28-2008 12:49 PM
To view the NAM file in network simulator kausikrish Programming 0 10-06-2007 01:09 AM

All times are GMT -5. The time now is 07:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration