LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-02-2006, 07:03 AM   #1
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,674
Blog Entries: 9

Rep: Reputation: 45
Konqueror as "superuser" (Root) ?


how is this done ??

Why? well I often have to receive documents in formats like .doc - either on floppies or via email. I often end up having to rename them (because windows using imbeciles have no understanding of "best practice" when allocating file names and use the default of the first line/title of the doc as the filename etc). I then often have to change the properties so that any of my users can modify them.

Also, it's very much easier to move them from one user to another via drag and drop. I also then have to change ownership of the .doc to the user that I want to move them too, because it seems that Kontact/KDE automatically allocates ownership to the user account that opened the floppy or downloaded the attachment/email.

Could someone advise me please ??

regards

John
 
Old 07-02-2006, 08:25 AM   #2
AlasdairA
LQ Newbie
 
Registered: Apr 2006
Distribution: Ubuntu 6.06
Posts: 11

Rep: Reputation: 0
Type 'gksudo Konqueror' into a terminal to use Konqueror as root, that should work but if it doesn't try using kdesu instead of gksudo (not sure which one is used in KDE). You may find this wiki page helpful:

Last edited by AlasdairA; 07-02-2006 at 08:26 AM.
 
Old 07-02-2006, 11:39 AM   #3
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,674
Blog Entries: 9

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by AlasdairA
Type 'gksudo Konqueror' into a terminal to use Konqueror as root, that should work but if it doesn't try using kdesu instead of gksudo (not sure which one is used in KDE). You may find this wiki page helpful:
Thanks for that AlasdairA, it's sort of helped i.e. I managed to get the stuff done that I wanted.

Unfortunately it doesn't feel that I'm in complete control. It's as if someone in the (K)Ubuntu developers world has decided that I shouldn't be able to do all root stuff in the "normal" way. I'd much prefer to be able to dump sudo completely (Ha! that might mean that Kubuntu goes as well - if necessary - a re-install of gentoo is looking more, and more desirable).

It's the first time I've come up against things like this (in about four and a half years) i.e. because it's about using sudo from the initital user account, I get curious prompts/errors about permissions or write access when having to do something with files that I haven't originated. Plus it's a bit of a pain not having the luxury of just being able to open konqueror as root (with password of course) to manage these files.

Oh well, back to the grindstone!

regards

John
 
Old 07-02-2006, 01:05 PM   #4
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
If you create a launcher or keyboard shortcut for
Code:
kdesu konqueror
you can browse as root from within your user account.

If you want to browse as root in the terminal, just type
Code:
sudo -s
and you'll be root.

There's absolutely no reason to activate your root account in Ubuntu or Kubuntu.
 
Old 07-02-2006, 04:07 PM   #5
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,674
Blog Entries: 9

Original Poster
Rep: Reputation: 45
No, of course you are correct aysiu, but I have many problems when it comes to downloading files or trying to open them from a floppy for my partner (she can get by with a word processor and browser but thats all).

For example, I tried to open two floppies, both with a single directory, but about 8 or 10 files in each directory. Now I don't really need the floppys' directory structure, but to get at the files, I had to mess with both the permissions, groups and ownership. Then I was just getting more error responses about write permission to my partners user account even when trying to move the files with sudo. The original author of the files didn't help, because they'd just used the default "first line of text" i.e. the title of the documents as the file name.

This meant that I kept hitting a brick wall of "document not found" whenever there was a space or a few punctuation marks.

Which meant that because it doesn't seem to be a kubuntu default setting to unmount the floppy (though it does seem to auto mount them) so I couldn't work out how I should be getting to the second floppy files. I eventually got my neighbour to read the floppies and email the files to me singly, so that I could individually modify the names (remove capitalisation, punctuation and spaces), change the permissions, owners and groups.

I was still left with the problem of moving the files to her user account documents folder. Sudo just wasn't "cutting the mustard". I did eventually find the command to open konqueror as root and only then, did it seem that I could drag and drop them.

I'm sure that it's just a case of some additional config of my system, plus understanding more of the capability of sudo. Unfortunately, in the 4 and a half years of trying to learn linux, this is the first occassion of using sudo (of course I've heard it mentioned). Plus I'm yet to be completely convinced that it is, in fact, as safe as the conventional root and user methods of linux management.

It's all incredibly frustrating - hence I'm finding that the continued existance of kubuntu on my system is becoming increasingly tenuous.

The only distro that I've never had problems with, in a management sense, is Gentoo. Yes of course, it can be a bit of a bugger to install, but the management is a dream. As straight forward, if not more so, than anything debian based (despite the comments from many members of my LUG who are "debian monsters").

So I'm finding that due to the frustration and my lack of patience, that I suspect I'll end up with a Gentoo install in the next fortnight - I am trying hard to resist, but these relatively minor annoyances seem to be increasing.

regards

John
 
Old 07-02-2006, 05:04 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I hope that this solution will work for Kubuntu ( I am using SuSE ).

You can add another home icon to the tool bar. Then right click on it and select "Configure Home Button". Click on the "Applications" tab and click on the "Advanced Options" button. Now select the "Run as different users" check box and enter "root" as the different user.

Move this icon so that it is visually separated from your regular icons. Now, when you want a root file browser, you can click on this icon, enter root's password and the Konqueror file browser will start.

---

From the earlier part of your first post, you said that you change the .doc extention. Changing the extention of a file does not convert the type of file.

---

In the shell, you can deal with spaces in filenames by escaping the space character.
cp file\ name\ with\ spaces ~/Documents/

Another way is to enclose the filename in quotes:
cp 'file name with spaces' ~/Documents/

Also, if you have entered enough characters so the filename is unique identified, you can press the TAB key to use autocompletion.
cp file[TABKEY]
Pressing TAB will expand it to
cp file\ name\ with\ spaces

Last edited by jschiwal; 07-02-2006 at 05:10 PM.
 
Old 07-08-2006, 03:22 AM   #7
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
You can enable yourself to login to KDE as root. This is probably not recommended and I wouldn't use it to browse the web or anything, just to get done what you need to.
1. $ sudo -i
2. # passwd
3. enter a password for root and confirm
4. # nano /etc/kde3/kdm/kdmrc
5. change the line that says "AllowRootLogins=false" to "AllowRootLogins=true"
6. ctrl-x to exit nano, remember to save
7. now you may start a new KDE session as root
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 05:08 PM
RH9 Permissions and the "superuser" frank320 Red Hat 7 03-07-2006 06:29 PM
Postgresql error FATAL: user "root" does not exist" cgetty Ubuntu 4 06-21-2005 03:11 PM
[Redhat] make "admin" account same privledges as "root" Bi0haZarD Linux - Networking 20 01-12-2005 11:47 AM
Tiny Sofa 2.0 - I thought "halt", "reboot" were only root command ?? sorcerer Linux - Distributions 1 08-21-2004 04:28 PM


All times are GMT -5. The time now is 01:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration