LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 12-26-2012, 11:03 AM   #1
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
How to disable Twinview in Ubuntu's nvidia drivers.


Hi.

I need Your help. Could You help me?

I have problem with TwinView with nVidia drivers on Ubuntu 12.04. I user 310.19 but this problem occurs on all nvidia drivers - exept nouveau.

It is related to recognizing more than one screen, and that is not right - i have only one.

It looks like on attached picture. When i boot to ubuntu destkop nvidia sees two screens and my picture is stretched to both of them. Some screen goes for "fake crt" (i don't have crt), and rest goes for my LCD flat screen (HP).

Is there a way to completly disable TwinView, prevent it from working, from detecting more than one screen when, in fact, i have only one?

I think that option in Xorg.conf "TwinView" "off" doesen't help:

Code:
firekage@deusex:~$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.19  (buildmeister@swio-display-x86-rhel47-11)  Thu Nov  8 00:25:56 PST 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 310.19  (buildmeister@swio-display-x86-rhel47-11)  Thu Nov  8 00:26:06 PST 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "unix/:7100"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP w2228h"
    HorizSync       24.0 - 83.0
    VertRefresh     48.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0; nvidia-auto-select +0+0; nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option "TwinView" "off"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1680x1050 +0+0; nvidia-auto-select +0+0; nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

firekage@deusex:~$
Maybe it is related to "metamodes" and the rest after it?


When i boot up, and when nvidia detects more than one screen, i have ti "fight" in order to disable it but after reboot the same thing happens. If im lucky, than i'm able to run terminal, and in it I run nvidia-settings (but it often runs in "crt fake screen" and i can't set up it because it is on far left "fake screen").


I added second picture - it shows how the screen is deformed when ubuntu/nvidia detects second screen, which i dont have!

http://img835.imageshack.us/img835/1...anieobrazu.png
Attached Images
File Type: jpg ubuntu_dwa_obrazy.jpg (172.1 KB, 10 views)

Last edited by firekage; 12-26-2012 at 11:30 AM.
 
Old 12-27-2012, 11:20 AM   #2
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Up.
 
Old 12-29-2012, 03:54 AM   #3
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Up.
 
Old 12-29-2012, 06:03 AM   #4
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Guys, over the world are more than 16.000.000 of Ubuntu users, i don't believe that no one knows how to solve it.
 
Old 04-03-2013, 12:02 PM   #5
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
My problem was solved. It was not the nvidia-drivers at fault but something from ubuntu:

http://www.linuxquestions.org/questi...on-4175455637/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable PaX for Nvidia Drivers dman777 Linux - Software 4 01-15-2011 02:30 AM
Help me reinstall Nvidia drivers and get TwinView working? Fedora 6 ttnunam Linux - Software 6 11-09-2006 07:39 PM
RH WS3 Update 6 NVIDIA drivers TwinView problems honda_ricer Red Hat 2 11-16-2005 07:37 AM
How do i disable X server to install the newest Nvidia drivers? linuxbullet Linux - Hardware 4 02-04-2004 11:16 PM
Nvidia with twinview cyberlot Linux - General 0 01-24-2003 04:41 PM


All times are GMT -5. The time now is 08:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration