LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-04-2008, 10:53 AM   #1
Ordinary12
Member
 
Registered: Feb 2007
Posts: 140

Rep: Reputation: 15
Gutsy Boot-up Time Slow.


Hello Linux Gurus:

I have an observation followed by a question about the new Gutsy operating system by Ubuntu. I was using Ubuntu 7.04 on my desktop and laptop but I decided to wipe the drives and upgrade to 7.10 once the automated update feature ruined my old setup...someone should really put some notes out on the internet on how to perform an upgrade with out the video drivers going static on you. Any way....I did a fresh installation of the new new Gutsy OS and now I'm getting a black screen while the system boots-up. It seems like a long time for the system to come up on my desktop system and even longer on the laptop. The laptop is old so I know I can't ask too much of it when it comes to speed but I'm curious if anyone has noticed this and if there is any advice on how to speed up the load time. Any help is appreciated.
 
Old 02-04-2008, 11:32 AM   #2
Cichlid
Member
 
Registered: Jan 2002
Location: Montreal
Distribution: Ubuntu 8.10
Posts: 178

Rep: Reputation: 30
Funny, I upgraded from 7.04 to 7.10 via the online network update. Everything worked fine on my HP R3000 laptop. If anything, when I have a long boot time is when fsck runs its' check after every 30 boots. But all is displayed onscreen.

I believe you could set in one of the many config file to display the splash screen of not, It may also be true for the whole boot sequence?

Good luck
 
Old 02-04-2008, 11:44 AM   #3
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Yeah, when Grub menu comes up, select your kernel (if it's not selected already), press 'e' to edit the section, hilight the line that starts with word 'kernel' and press 'e' again to edit it, then replace the word 'splash' with 'nosplash' or if it doesn't exist, write it there between the options. Press Enter to apply changes and 'b' to boot. Now the graphical bootup should be gone and you should see boot messages instead - if this worked, after the machine booted you can make the changes permanent by editing Grub's menu.lst as root:
Code:
sudo gedit /boot/grub/menu.lst
locating the same kernel line you edited from within Grub, and replacing 'splash' with 'nosplash' there. Save and exit, and you're done.

If there is something making the boot slower, it should be displayed now in the boot messages. If something doesn't look all right, start searching about it in here..

Upgrading trough the package manager is not recommended (by me), but it's supposed to work - at least for the Ubuntu packages. If you have non-Ubuntu packages installed, they might fail. Safest to do it with X closed, with apt-get and some manual editing of the source lists..you can do it from X too, but if the graphics card fights back after reboot, you need to edit /etc/X11/xorg.conf, possibly replace the used driver (Driver line in the section "Device" where your gfx card is mentioned) with "vesa" which is a generic driver, try to start X again, and if it starts, re-run Restricted Drivers Manager (if you've got one of those gfx cards - namely ATI or nVidia - whose drivers you installed from here) or manually reinstall your graphics card drivers.

Note that if X doesn't start after upgrade, don't right away reinstall, but rather hit CTRL+ALT+F1 and see if you can login in text console. If you can, you're set
 
Old 02-07-2008, 09:17 AM   #4
Ordinary12
Member
 
Registered: Feb 2007
Posts: 140

Original Poster
Rep: Reputation: 15
This worked for me. Thanks everyone. If you have any other suggestions on speeding up boot time I'm always eager to learn.
 
Old 02-08-2008, 06:53 AM   #5
al13ncr33d
LQ Newbie
 
Registered: Jan 2008
Location: West Sumatra, Indonesia
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
cool!
that worked for me too. it also boost my boot time.
now i know i have problem with one of my pci device, but that' ok.
thank you!
 
Old 02-08-2008, 07:07 AM   #6
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,465
Blog Entries: 3

Rep: Reputation: 183Reputation: 183
I think this is a problem when you allow a program to upgrade your system when you have know control over what is being done to it. Blind faith. and apt-get seems to be a faithful thing.
 
Old 02-08-2008, 02:14 PM   #7
Ordinary12
Member
 
Registered: Feb 2007
Posts: 140

Original Poster
Rep: Reputation: 15
Is there a way to pause the boot sequence so I can write down any loading problems I find?
 
Old 02-09-2008, 07:12 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,465
Blog Entries: 3

Rep: Reputation: 183Reputation: 183
I guess Ubuntu 710 is a little fat takes awhile to boot sudo dmesg. if your is set up to connect to the internet at boot, then it will take longer especially if you do not have a connection . help files they do not lie.
 
Old 02-09-2008, 05:06 PM   #9
landonab
LQ Newbie
 
Registered: Jan 2008
Location: Decatur, IL
Distribution: Ubuntu - 7.10
Posts: 6

Rep: Reputation: 0
Make sure your usplash settings are correct also...

Code:
sudo gedit /etc/usplash.conf
xres=1024
yres=768

If they are wrong, change them then run

Code:
sudo update-usplash-theme usplash-theme-ubuntu
My Gutsy (and others) have had problems with this and it will cause boot to take up to a minute. You know it's an issue if you do not have the Ubuntu logo during boot and only a black screen.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very slow boot time with F8 koady Fedora 2 11-20-2007 06:27 AM
slow firefox gutsy alf_frommars Ubuntu 5 11-03-2007 03:36 AM
Gutsy 7.10 stuck during dual-boot install SPC_Hall Ubuntu 2 09-30-2007 07:56 PM
Very slow boot time after hard drive problems. Mountain Man Ubuntu 4 07-01-2007 04:56 PM
LXer: Ubuntu 7.10 (Gutsy Gibbon) Release Dates and Mark Shuttleworth About Gutsy LXer Syndicated Linux News 0 04-12-2007 04:31 PM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration