LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-01-2007, 01:10 PM   #1
Interdictor
Member
 
Registered: Jul 2006
Location: Runcorn, England
Distribution: Ubuntu 6.06 & 6.1, Mandriva 2007, Knoppix
Posts: 72

Rep: Reputation: 15
GLXGEARS problem on Ubuntu, with NVidia GLX-Legacy drivers installed


If I run "glxgears", I get this error message:-

Code:
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
Can anybody suggest what I need to do to solve this.

I'm running Ubuntu Edgy, with what Ubuntu picks up as NV15BR [GeForce2 Ultra, Bladerunner] graphics. Its a clean Ubuntu install, with the NVidia GLX-Legacy driver installed through synaptic.


If I run glxinfo and a couple other commands from suggestion in other threads, this is the responses I get:-

Code:
:~/Desktop$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Code:
sudo lspci -v | grep -i vga
00:04.4 Non-VGA unclassified device: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
01:05.0 VGA compatible controller: nVidia Corporation NV15BR [GeForce2 Ultra, Bladerunner] (rev a4) (prog-if 00 [VGA])

Is my problem anything to do with th Non-VGA unclassified device: VIA Technologies? I don't get anything similar on any of my other Linux machines.


Code:
 cat /etc/X11/xorg.conf|grep Driver
    Driver         "kbd"
    Driver         "mouse"
    Driver         "wacom"
    Driver         "wacom"
    Driver         "wacom"
    Driver         "nvidia"
And my xorg.conf is this:-
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@rothera)  Thu Jan  5 15:32:31 UTC 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
#    Load           "dri"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "gb"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "NUR1905"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV15BR [GeForce2 Ultra, Bladerunner]"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV15BR [GeForce2 Ultra, Bladerunner]"
    Monitor        "NUR1905"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

#Section "DRI"
#        Mode      0666
#EndSection


Thanks in advance for any help.
 
Old 01-02-2007, 03:10 AM   #2
streeturchine
LQ Newbie
 
Registered: Dec 2006
Location: australia
Distribution: ubuntu,dapper 6.06,edgy 6.10,breezy 5.10
Posts: 16

Rep: Reputation: 0
Try Envy, it should solve your problem:


http://albertomilone.com/nvidia_scripts1.html
 
Old 01-02-2007, 05:38 PM   #3
Interdictor
Member
 
Registered: Jul 2006
Location: Runcorn, England
Distribution: Ubuntu 6.06 & 6.1, Mandriva 2007, Knoppix
Posts: 72

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by streeturchine
Try Envy, it should solve your problem:
Thanks streeturchine, that solved the problem.

Glxgears works fine now, as do all of the OpenGL screensavers
 
Old 01-09-2007, 12:44 PM   #4
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
Hi, I'm very late, as always, just to add a different perspective to solve the problem, now that is useless isn't?
Adding a section in the /etc/X11/xorg.conf file will make the legacy nvidia drivers work, the next one:
Code:
Section "Extensions"
Option "Composite" "Disable"
EndSection
If you are one of those who likes to know why, then visit http://download.nvidia.com/XFree86/L...ppendix-s.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers jollyjoice Linux - Hardware 7 06-07-2006 09:02 AM
Problem installing Nvidia glx drivers YellowFin Ubuntu 2 01-28-2006 03:47 PM
slow FPS in glxgears with nVidia drivers installed jojotx0 Linux - Software 1 11-29-2005 03:58 PM
nvidia+GLX+glxgears gukkura Linux - Software 7 11-12-2005 06:38 AM
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 02:42 PM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration