LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2007, 01:56 PM   #16
mduf
LQ Newbie
 
Registered: Jan 2007
Location: Canada
Distribution: Ubuntu, Fedora
Posts: 2

Rep: Reputation: 0

I got same error while booting an ubuntu 6.10 machine that worked fine before.

I used the ubuntu live CD to start it. (sorry for those who can't)
and by using:
sudo fdisk -l

I found that mysteriously the name of the hard drive had change.
Before it was hdb and now it is hda

So I mounted the hard drive and corrected the /boot/grub/menu.lst file
I changed
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb1 ro quiet splash

for

kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro quiet splash

and I did the same for the rescue mode
I reboot the machine and it worked fine again

So if that problem occur after an update or something, it may be good to investigate that option (Like DrewL, may be your trouble is similar)

For those who have this problem with the live CD I'm sorry it's probably different
so I wish you good luck
 
Old 02-06-2007, 11:14 PM   #17
cafetero
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I have the same problem with connecting a new hard drive, could you go into step by step of how you mounted the hard drive and changed the name because when I ran sudo fdisk -l my hard drives names were changed.
Thank you
 
Old 02-07-2007, 06:36 AM   #18
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
So I mounted the hard drive and corrected the /boot/grub/menu.lst file
I changed
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb1 ro quiet splash

for

kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hda1 ro quiet splash
You have to modify /boot/grub/menu.lst.
For this, you will need to
boot with a livecd (knoppix is a good try)
mount your disk that contains the file /boot/grub/menu.lst that needs to be changed
edit (a->b or opposite?) and save
reboot on the harddrive.
 
Old 02-07-2007, 09:17 AM   #19
mduf
LQ Newbie
 
Registered: Jan 2007
Location: Canada
Distribution: Ubuntu, Fedora
Posts: 2

Rep: Reputation: 0
Cafetero to mount your disk use the mount command

To have more info use
man mount

to mount your disk it look like this

sudo mount -t ext3 /dev/hda1 /mnt

-t ext3 -> its the files system. By default with ubuntu edgy it's ext3

/dev/hda1 -> replace it by the name of your linux partition (you saw it with fdisk -l)

/mnt -> where it will be mounted

When it's done look in the directory /mnt an all your file of your linux directory will be there.

so if you want to modify /boot/grub/menu.lst

it will be in /mnt/boot/grub/menu.lst

and use gedit or your favorite text editor to modify your menu.lst as I say in my previous post

and it should work




by the way when you add a new drive on an IDE bus make sure you have a master and a slave. It is set by using jumpers at the rear of your drive. You probably receive a note with your new hard drive that tells how.

in Linux hda is the master and hdb is the slave on the primary IDE bus, for the secondary master is hdc and slave is hdd.

In my case the problem was with the hard drive, the jumpers were correctly set to master but it was identifies as hdb. One day it begins switch between hda and hdb at every boot. Removing a jumper who was suppose to be in a storage position seems to have solve the problem. Now the hard drive is correctly call hda. I just hope it will stay that way.
 
Old 02-10-2007, 07:53 PM   #20
nhorlock
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I know what my probem was......

I have had this and fixed it. You mileage may vary of course especailly as my error was very specific.

I was building a persisten USB stick image of Xubunut 6.10.

Everything looked fine (though as it turned out I had ignored/missed a critical error). When I went to boot, it would get so far and then fail with the above error that everyone else has had.

As has been observed, this is unlikely to have anything to do with busybox or with ttys.

The first place to look once you get to the command prompt is at the log file. There may be no /var/log at this point in time so look in the casper.log file in the root filesystem type "more /casper.log" in my case there were a whle bunch of compaints about /dev/hdc (which can be ignored) followed by the key error a line that announced that the filesystem.squashfs file could not be loaded. If you have this then your installation media are probably corrupt.

In my case a CD that I had been using had somehow developed an error and the squashfs file (on the CD this is in /casper/filesystem.squashfs) which should have been 508M would not copy properly.

I resolved this by kicking myself as hard as I could, swearing a bit and then mounting the original iso file and using that to build my USB stick instead. Alternatively you could simply burn another CD from the original ISO.

I think the CD has a check CD option on the boot menu, try this and see what happens.

I don't know how many of you this will help but you could do a lot worse than to take a few minutes to verify your install media.

hope this helps

regards

Neil
 
Old 02-10-2007, 10:05 PM   #21
inspiron_Droid
Member
 
Registered: Dec 2006
Distribution: Debian (Wheeze)
Posts: 391

Rep: Reputation: Disabled
I have been using ubuntu off and on sinse 5.04 Horay hedgeHog and haven't had any problems with my two year old asrock motherboard.
 
Old 02-21-2007, 04:42 PM   #22
roque86
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I have the same problem. In my case, i figure this out editing the file menu.lst (/boot/grub/menu.lst).

May be i had a different problem with only the same debug message, but i could see that this file was corrupted (in my case because a windows installation and grub-install command), and when i edited it the system boot up normally again.

My menu.lst file wants to boot up in (hd0,2) and /dev/hdc3, but the correct for was (hd0,1) /dev/hdc2

Note that the grub report errors in this situation, but if we have (hd0,1) /dev/hdc3 it will boot up with error (booting swap partition? rsrsrs, i don't know)
 
Old 03-15-2007, 07:07 AM   #23
Skippertom
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Check CD-ROM

Same error message due to an unsupported CD-Rom drive! I tried hard to get Xubuntu 6.10 on a P3-machine. As I used a CDRom-drive for installation reasons only, I took one, that was possibly older than me ;-) Next try of installig an older version of Ubuntu failed, due to lack of CDROM-support. So I changed it and was able to install both distibutions without any problem!
 
Old 03-22-2007, 04:08 PM   #24
Yoda3114
Member
 
Registered: Mar 2007
Location: Baltimore, MD
Distribution: Kubuntu Precise
Posts: 91

Rep: Reputation: 15
Problems installing or even booting Kubuntu edgy

Alright I've been tearing my hair out for days trying to get Vector or Xubuntu or Kubuntu installed (or even booted so I can test drive). However I keep coming up with these funky errors that seem to be so generic. Mainly it seems like it's a hardware issue. Did some searching but found jack squat. I too get the tty error busybox job control error thingamabob. So, heres my specs;

Intel core 2 duo E6300
Intel stock mobo
1 GB RAM
Dual double layer multi DVD drives
250 GB SATA ll
integrated X3000 graphics

Pretty standard. I also (before all of this) disconnected my secondary optical drive so it wouldn't interfere.
Please someone help!!!

I didn't upgrade or have any peripherals connected. The machine is about five months old and so many people are getting the same error for different reasons. I've tried various forums, reading tons of post and papers but nothing seems out of the ordinary with my machine. Very basic like I said before and someone needs to let the dev's know about this. Sorry for ranting but this is very frustrating.

Last edited by Yoda3114; 03-22-2007 at 05:51 PM.
 
Old 03-22-2007, 11:43 PM   #25
Yoda3114
Member
 
Registered: Mar 2007
Location: Baltimore, MD
Distribution: Kubuntu Precise
Posts: 91

Rep: Reputation: 15
making progress (?)

well I posted my hardware specs but.... Anyways it seems like I got a little further but I still get stuck with the same error. "Tty blah blah blah". This time before everything comes to a grinding halt it actually begins detecting my hardware. A miracle. Then blam santa claus hits a brick wall before he gets to 34th street with something about an intel e1000 network (driver I think). I have a desktop with intel mobo cpus and a 82562v networking device. Don't know why this is coming up but once again, any help is greatly appreciated by us lowly newbs.
 
Old 03-23-2007, 05:52 AM   #26
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Lightbulb

As I said months ago (my post from December) and you said yesterday, this "can't access tty" error doesn't mean anything by itself so probably nobody will help you in this thread.

Any problem during bootup will lead to this warning.

My advice: This thread should not be used anymore.
Open a new thread in ubuntu detailing your Ubuntu version, how you installed it, HW specs again and the PREVIOUS ERRORS (if any), not this tty thingy.

I have no knowledge about your hardware and ubuntu, I can't help you.. sorry , but try to repost on another thread. If nobody can help you, Try on ubuntu forums directly.
 
Old 03-28-2007, 06:46 PM   #27
zaac23
LQ Newbie
 
Registered: Jan 2006
Location: new england
Distribution: ubuntu
Posts: 2

Rep: Reputation: 0
Iran 6.10 for3 mounts before the problem showed up. I can't figure any reason unless a system update had a problem.
 
Old 04-22-2007, 02:09 AM   #28
blowers
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
Angry Same problem

I am also having the same problem.

However, I was able to run Ubuntu 6.10 from the CD on my old Dell P4, but when I try to run either Ubuntu 6.10 or 7.04 from the CD on my new machine, I get the same error message that you other people are getting.

/bin/sh: can't access tty; job control turned off (Initramfs)

The old machine was a 1.3Ghz Pentium 4 with one hard disk.

The new machine is running from a Intel DG965WH motherboard, Intel Core Duo E6600 with 2 GB of DDR2 800 RAM and two Seagate 250GB 7200 rpm SATAII hard drives with 16MB cache. The drives are set up as a RAID1 volume.

The optical drive that I am trying to run the CD from is the same drive from my old Dell machine, so I know that there is no problem with the DVD drive.

Last edited by blowers; 04-22-2007 at 02:11 AM.
 
Old 04-22-2007, 02:20 AM   #29
blowers
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
Ran the drive check, wasn't the problem

Quote:
Originally Posted by nhorlock
I have had this and fixed it. You mileage may vary of course especailly as my error was very specific.

I was building a persisten USB stick image of Xubunut 6.10.

Everything looked fine (though as it turned out I had ignored/missed a critical error). When I went to boot, it would get so far and then fail with the above error that everyone else has had.

As has been observed, this is unlikely to have anything to do with busybox or with ttys.

The first place to look once you get to the command prompt is at the log file. There may be no /var/log at this point in time so look in the casper.log file in the root filesystem type "more /casper.log" in my case there were a whle bunch of compaints about /dev/hdc (which can be ignored) followed by the key error a line that announced that the filesystem.squashfs file could not be loaded. If you have this then your installation media are probably corrupt.

In my case a CD that I had been using had somehow developed an error and the squashfs file (on the CD this is in /casper/filesystem.squashfs) which should have been 508M would not copy properly.

I resolved this by kicking myself as hard as I could, swearing a bit and then mounting the original iso file and using that to build my USB stick instead. Alternatively you could simply burn another CD from the original ISO.

I think the CD has a check CD option on the boot menu, try this and see what happens.

I don't know how many of you this will help but you could do a lot worse than to take a few minutes to verify your install media.

hope this helps

regards

Neil
I ran the media check, but it found no errors.
 
Old 04-25-2007, 03:43 PM   #30
Chapita
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: Disabled
I had Ubuntu 6.10 unitl yesterday, I was waiting for the new one for nothing.
I didn't change anything in my hardware and no one seems to know how to fix that.
Besides, I have a P4, 768Mhz RAM, two HDD; Linux is installed in the second partition of the slave, in the same place that I had the older version.
Regards and good luck, apparently we will need it...
 
  


Reply

Tags
boot, cant, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Query solutin for tty job control turned off. I'mabadger Linux - Newbie 5 03-04-2006 05:37 PM
sh: can't access tty; job control turned off. shadowsa Suse/Novell 2 11-21-2005 11:13 AM
control job turned off greythorne Suse/Novell 0 08-14-2005 02:58 AM
can't access tty; job control turned off johnnybezak Linux - General 4 02-21-2004 10:49 PM
sh: can't access tty, job control turned off tgardner Linux - Software 1 06-07-2003 12:39 AM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration