LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-05-2006, 04:15 AM   #1
Pepe93
LQ Newbie
 
Registered: Feb 2006
Distribution: Suse 10.0
Posts: 2

Rep: Reputation: 0
Question Problem with compiling and installing SIM


Hi to all in the board,

I (Newbie) wanted to "update"/install the latest version of SIM, as the version which came with the packet has some bugs.

Thus, I followed the instructions on:
sim-im.berlios.de/wiki/Download

during the compilation I received a lot of warning messages:

Quote:
/usr/lib/qt3/include/private/qucom_p.h:69: warning: 'struct QUBuffer' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:77: warning: 'struct QUType' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:104: warning: 'struct QUType_Null' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:287: warning: 'struct QUType_enum' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:307: warning: 'struct QUType_ptr' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:326: warning: 'struct QUType_iface' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:345: warning: 'struct QUType_idisp' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:364: warning: 'struct QUType_bool' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:383: warning: 'struct QUType_int' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:403: warning: 'struct QUType_double' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:423: warning: 'struct QUType_charstar' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:444: warning: 'struct QUType_QString' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucomextra_p.h:65: warning: 'struct QUType_QVariant' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucomextra_p.h:87: warning: 'struct QUType_varptr' has virtual functions but non-virtual destructor
/bin/sh ../../libtool --tag=CXX --mode=link g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -fno-strict-aliasing -L/usr/X11R6/lib -L/usr/lib/qt3/lib -L/opt/kde3/lib -o zodiak.la -rpath /usr/local/network/sim/lib/sim -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -avoid-version -L../../sim/.libs -L/usr/lib/qt3/lib -R /opt/kde3/lib -R /usr/lib/qt3/lib -R /usr/X11R6/lib -L/usr/X11R6/lib -L/usr/lib/qt3/lib -L/opt/kde3/lib zodiak.lo ../../sim/libsim.la -lkdecore -lkdeui -lkio -lqt-mt -lz -lpng -lz -lm -lXext -lX11 -lSM -lICE -lpthread
rm -fr .libs/zodiak.la .libs/zodiak.lai .libs/zodiak.so
But seems to finish completely.

Then the installation process stops here:
Quote:
.
.
(cd /usr/local/network/sim/lib && rm -f libsim.so && ln -s libsim.so.0.0.0 libsim.so)
/usr/bin/install -c -p .libs/libsim.lai /usr/local/network/sim/lib/libsim.la
PATH="$PATH:/sbin" ldconfig -n /usr/local/network/sim/lib
----------------------------------------------------------------------
Libraries have been installed in:
/usr/local/network/sim/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
test -z "NONE/bin" || mkdir -p -- "NONE/bin"
/bin/sh ../libtool --mode=install /usr/bin/install -c -p 'sim' 'NONE/bin/sim'
libtool: install: `NONE/bin' must be an absolute directory name
Try `libtool --help --mode=install' for more information.
make[3]: *** [install-binPROGRAMS] Fehler 1
make[3]: Leaving directory `/home/pepe/sim/sim'
make[2]: *** [install-am] Fehler 2
make[2]: Leaving directory `/home/pepe/sim/sim'
make[1]: *** [install-recursive] Fehler 1
make[1]: Leaving directory `/home/pepe/sim/sim'
make: *** [install-recursive] Fehler 1
I don't know if this is related in any way with the warning messages from compilation.

If anyone could give me some hints on this, I would appreciate this a lot!

Cheers,
Pepe
 
Old 02-06-2006, 02:26 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Have you tried to run ./configure with a prefix? It looks to me like the installation path has not been set properly (NONE).
 
Old 02-07-2006, 04:56 AM   #3
Pepe93
LQ Newbie
 
Registered: Feb 2006
Distribution: Suse 10.0
Posts: 2

Original Poster
Rep: Reputation: 0
Hey abisko00,

yes, I already tried this option, but it neither worked.

I tried this with the Rev.275. Now I could succesfully install Rev.105. Anyway I am still wondering that with the newest Rev. it wont work. (I also tried some Revs between 275 and 105).

Thanks!
Pepe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing flight sim silverjump Linux - Games 5 01-23-2005 03:25 AM
Newbie having problem installing .tgz and compiling? fleeced Linux - Software 6 08-13-2004 04:14 PM
problem compiling kernel for installing alcatel driver fawkes.phoenix Linux - Software 2 07-01-2004 01:46 PM
sim-0.9.2 installation problem kdm Linux - Software 0 02-04-2004 03:19 AM
sim for 9.1? Vincent Slackware 5 11-02-2003 02:29 PM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration