LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2005, 09:11 PM   #1
perl21
LQ Newbie
 
Registered: Mar 2005
Location: Las Vegas NV
Distribution: Suse 9.2
Posts: 23

Rep: Reputation: 15
Passive/Active mode in Konqueror & .netrc


Hi Everyone,

I asked this same question in the Linux General, sorry for the re-post but I didn't see this more appropriate place for my question until now.

I hope someone has figured out how to get around the passive/active mode problem with konqueror by now.

Someone said in a forum they added some commands to a .netrc file but I can't get konqueror to read them.

Konqueror says this in their faq:

Starting with version 2.2 beta1 konuqeror does indeed support automatic logins as specified in the ".netrc" file. However, there is no graphical front end to enable this feature ; so you have to do it manually using the following procedure:

--------------------------------------------------------------
1. Create $KDEHOME/share/config/kio_ftprc if it does not already exist.
Note that $KDEHOME referes to your personal kde config directory (usually ~/.kde).
2. Add the following entry to kio_ftprc: "EnableAutoLogin=true"
3. Issue the following command to update running io-slaves:
dcop konqueror KIO::Scheduler reparseConfiguration() ""

Please note that the support for the "macro" keyword is very limited in the current implementation. In fact, we only honor the "cd" command. Furthermore, eventhough this nominal "macro" support was left ON by default for the 2.2 beta1 release, you will have to be manually enable it in subsequent releases by adding a "EnableAutoLoginMacro=" entry following the same procedure outlined above.
--------------------------------------------------------------

I followed the instructions and it didn't work, I found a file called konquerorrc and added the command to that file too. But nothing takes. I have my .netrc file working with the ftp shell program (lukeftp) just fine.

It even kicked lukeftp out of passive mode with the macdef command

If konqueror would just work off of the .netrc file it should work.

Any ideas out there?

If .netrc doesn't work, then isn't there another way to get konqueror to not use passive mode. I can't connect to my online server running proftpd.

My firewall is OFF, and my proftpd server is accepting passive mode connections. What the heck??

Thanks,
Tony
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD question...active/passive mode lapzlinux Linux - Networking 4 08-06-2011 02:54 AM
FTP: active and passive mode problem with some windows client tda71 Linux - Networking 2 06-14-2005 09:31 AM
Konqueror FTP passive/active problem & .netrc perl21 Linux - General 0 03-17-2005 05:43 PM
Passive mode FTP & Firewall Mikessu *BSD 2 07-23-2004 01:12 AM
How to set anscii mode in FTP using .netrc gendreau Linux - Newbie 1 08-08-2003 01:05 PM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration