LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-17-2005, 05:43 PM   #1
perl21
LQ Newbie
 
Registered: Mar 2005
Location: Las Vegas NV
Distribution: Suse 9.2
Posts: 23

Rep: Reputation: 15
Konqueror FTP passive/active problem & .netrc


Hi Everyone,

I hope someone has figured out how to get around the passive/active mode problem with konqueror by now.

Someone said in a forum they added some commands to a .netrc file but I can't get konqueror to read them.

Konqueror says this in their faq:

Starting with version 2.2 beta1 konuqeror does indeed support automatic logins as specified in the ".netrc" file. However, there is no graphical front end to enable this feature ; so you have to do it manually using the following procedure:

--------------------------------------------------------------
1. Create $KDEHOME/share/config/kio_ftprc if it does not already exist.
Note that $KDEHOME referes to your personal kde config directory (usually ~/.kde).
2. Add the following entry to kio_ftprc: "EnableAutoLogin=true"
3. Issue the following command to update running io-slaves:
dcop konqueror KIO::Scheduler reparseConfiguration() ""

Please note that the support for the "macro" keyword is very limited in the current implementation. In fact, we only honor the "cd" command. Furthermore, eventhough this nominal "macro" support was left ON by default for the 2.2 beta1 release, you will have to be manually enable it in subsequent releases by adding a "EnableAutoLoginMacro=" entry following the same procedure outlined above.
--------------------------------------------------------------

I followed the instructions and it didn't work, I found a file called konquerorrc and added the command to that file too. But nothing takes. I have my .netrc file working with the ftp shell program (lukeftp) just fine.

It even kicked lukeftp out of passive mode with the macdef command

If konqueror would just work off of the .netrc file it should work.

Any ideas out there?

Thanks,
Tony
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Active FTP and Konqueror, KBear, Mozilla et all... SAB Linux - Networking 2 10-26-2005 08:38 PM
FTP: active and passive mode problem with some windows client tda71 Linux - Networking 2 06-14-2005 09:31 AM
Active ftp, konqueror Hamsjael Linux - Networking 4 06-10-2005 11:01 AM
Passive/Active mode in Konqueror & .netrc perl21 Suse/Novell 0 03-18-2005 09:11 PM
Active and Passive FTP sancho5 Linux - Networking 3 11-24-2001 10:48 PM


All times are GMT -5. The time now is 09:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration