LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 06-13-2008, 04:59 PM   #1
slacard
Member
 
Registered: Sep 2003
Location: Upstate NY
Distribution: OS X, Zenwalk. Sabayon x64, Debian 4.0 x64
Posts: 93

Rep: Reputation: 15
Open Suse11 RC wifi/ndiswrapper problem


I'm using the live cd (64bit) and ndiswrapper is a default package.
I was able to install the appropriate windows driver for my card
(an Atheros AR5007EG) The suse hardware info and network manager sees the card as AR24X but it is a AR5007EG per HP Pavilion dv6707us.
Doing ndiswrapper -l shows the driver is installed but when I unplug my ethernet the network settings -YaST doesn't find a connection and also lists the card as unconfigured.
Is there a reliable way to enable this card and get it working with 64 bit Suse?
 
Old 06-13-2008, 05:51 PM   #2
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
I don't have any experience with 64bit systems but is the Windows driver 64bit?

You will need to unload the default ath5k module before using the ndiswrapper module.
 
Old 06-13-2008, 06:35 PM   #3
slacard
Member
 
Registered: Sep 2003
Location: Upstate NY
Distribution: OS X, Zenwalk. Sabayon x64, Debian 4.0 x64
Posts: 93

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pilotgi View Post
I don't have any experience with 64bit systems but is the Windows driver 64bit?

You will need to unload the default ath5k module before using the ndiswrapper module.
Thanks for the response I did unload the ath5k module, but I get this from network settings:

AR242x 802.11abg Wireless PCI Express Adapter (not connected)
BusID : 0000:03:00.0
Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

And the ndiswrapper related output of dmesg is as follows:

ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
ndiswrapper (link_pe_images:576): fixing KI_USER_SHARED_DATA address in the driver
ndiswrapper: driver net5211 (,06/21/2007,5.3.0.56) loaded
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LK4E] -> GSI 19 (level, low) -> IRQ 19
ndiswrapper (ZwClose:2227): closing handle 0x0 not implemented
PCI: Setting latency timer of device 0000:03:00.0 to 64
ndiswrapper (NdisWriteErrorLogEntry:191): log: C0001389, count: 4, return_address: ffffffff8858636e
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x5d02e000
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x28
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x35d000
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x35d000
ndiswrapper (mp_init:216): couldn't initialize device: C000009A
ndiswrapper (pnp_start_device:439): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (mp_halt:259): device ffff810040cd9700 is not initialized - not halting
ndiswrapper: device eth%d removed
ACPI: PCI interrupt for device 0000:03:00.0 disabled
ndiswrapper: probe of 0000:03:00.0 failed with error -22
usbcore: registered new interface driver ndiswrapper
eth0: no link during initialization.
ADDRCONF(NETDEV_UP): eth0: link is not ready
eth0: no link during initialization.
ADDRCONF(NETDEV_UP): eth0: link is not ready
eth0: link up.
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present

I am loading the 64 bit windows driver with ndiswrapper. I can get it working on 64 bit ubuntu 7.10 but so many other things are not working with ubuntu on this laptop (resume from suspend, cpu fan speed, power management) that I wanted to try open suse. I'd like to get it to be able to use linux but if not I'll sell it since I'm not very interested in running windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi and ndiswrapper issues NoahT1BM Linux - Software 2 05-09-2008 12:24 PM
10.2 64 Broadcom WiFi with ndiswrapper MrAexo Suse/Novell 31 02-09-2008 12:02 PM
Wifi configured with ndiswrapper now what? DeadPenguin Linux - Wireless Networking 8 04-20-2005 09:52 AM
getting wifi to work with ndiswrapper zchoyt Linux - Wireless Networking 13 09-24-2004 05:57 PM
wifi interface with ndiswrapper robinang Linux - Wireless Networking 2 09-13-2004 11:46 PM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration