LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 10-20-2010, 07:58 AM   #1
scruggsdl
LQ Newbie
 
Registered: Jun 2010
Location: Classified
Distribution: CentOS, RHEL, Fedora, Solaris
Posts: 16

Rep: Reputation: 0
INIT: Command is respawning too rapidly


Good morning,

The last two weeks I have been dealing with an issue on my jobs' SunFire V100 server that has Solaris 9. Our ssh-server-config was messed up during changes to new certs being allowed to be used. The server was rebooted before I realized there was a problem with this configuration. Now I cannot ssh into my server and when attempting to hypertermial into the LOM console in the back of the SunFire V100, after a successful boot up to INIT 3 with the "system ready" text appearing, the following comes up making me unable to get to a login prompt...

INIT: Command is respawning too rapidly. Check for possible errors.
id: co"/usr/lib/saf/ttymon -g -h -p "'uname -n' console login:" -T Sun -d
/dev/console -l console -m ldterm, ttcompat
 
Old 10-20-2010, 09:10 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Try booting in single user mode.
 
Old 10-20-2010, 09:18 AM   #3
scruggsdl
LQ Newbie
 
Registered: Jun 2010
Location: Classified
Distribution: CentOS, RHEL, Fedora, Solaris
Posts: 16

Original Poster
Rep: Reputation: 0
Rebooting in Single User Mode

Quote:
Originally Posted by jlliagre View Post
Try booting in single user mode.
Yes, I have attempted this. When I get in single user mode I run into several problems starting from having to fsck a majority of the disks and fight with mounting and umounting, etc. However once this is in the clear and I go to edit the SSH config file, the text becomes garbled and I cannot truly locate where my cursor is because as I type, the text mushes and turns into text from several lines further down. I was thinking of looking up a way to run a search and replace to the problem line on the file and correcting it without actually seeing it.
 
Old 10-20-2010, 10:17 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
Originally Posted by scruggsdl View Post
However once this is in the clear and I go to edit the SSH config file, the text becomes garbled and I cannot truly locate where my cursor is because as I type, the text mushes and turns into text from several lines further down.
Looks like you an incorrect TERM setting.
 
Old 10-21-2010, 07:10 AM   #5
scruggsdl
LQ Newbie
 
Registered: Jun 2010
Location: Classified
Distribution: CentOS, RHEL, Fedora, Solaris
Posts: 16

Original Poster
Rep: Reputation: 0
TERM Setting?

Quote:
Originally Posted by jlliagre View Post
Looks like you an incorrect TERM setting.
I've seen a few of these mentioned when digging around for answers, though I don't know a whole lot about it. I'm going to go check this out, if you have a link to something about useful, I'd much appreciate it. Thanks for that info!
 
Old 10-21-2010, 10:40 AM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Well, no real need for a link or documentation. You are running a terminal emulator (hyperterminal) that presumably is emulating some standard model, likely a vt100.

On the other hand, the OS might be setting your TERM variable to something incompatible, like "sun" or whatever.

You just need to set the TERM variable correctly before running vi, eg:

Code:
echo $TERM
TERM=vt100
vi /etc/ssh/sshd_config
 
  


Reply

Tags
console, hyperterminal, login, solaris, unix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
init: no more processes left and respawning too fast disabled grainfive Linux - Newbie 5 05-27-2009 03:39 AM
init id 'x' respawning too fast:disabled for 5 mins r_ramya06 Fedora 3 06-17-2008 09:52 PM
init: initdefault: respawning too fast sankari_s Linux - Newbie 2 12-26-2007 09:06 AM
INIT: id 'x' respawning too fast: disabled for 5 minutes unitcoed Linux - Newbie 1 07-06-2003 07:35 PM
init id 1 respawning too fast : disable for 5 minutes nogor Linux - General 1 06-10-2003 08:56 AM


All times are GMT -5. The time now is 05:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration