LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-27-2012, 01:39 PM   #1
xj25vm
Member
 
Registered: Jun 2008
Posts: 262

Rep: Reputation: 17
Xorg listening on TCP by default


I've just run netstat on my Slack machine and I see:

Code:
#netstat -tupa
Active Internet connections (servers and established)
Proto Recv-Q Send-Q   Local Address   Foreign Address  State     PID/Program name  
...
tcp        0      0   *:x11             *:*            LISTEN      2298/X
...
Since everything else seems pretty nice and tight on a default Slack install, and since, googling around it seems the "-nolisten" argument can be used with X to stop it from listening for TCP connection - I'm a bit puzzled as to why the Slackware default install doesn't use "-nolisten".

Anybody knows?

Thanks
 
Old 11-27-2012, 06:03 PM   #2
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
it's not harmful http://security.fnal.gov/cookbook/Xnolisten.html

Last edited by beder; 11-27-2012 at 06:05 PM.
 
Old 11-27-2012, 07:17 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,392

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
The slackware philosophy is to not make assumptions. Configuration choices such as these are generally left to the user/admin.

Rather than add "-nolisten tcp" I prefer to stick the port behind some iptables rules.
 
Old 11-27-2012, 11:58 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,439

Rep: Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851
Yes, netstat lists port 6000 as listening, but connections from remote computers are disabled by default in Slackware.
From /etc/X11/xdm/xdm-config
Code:
DisplayManager.requestPort: 0
/etc/kde/kdm/kdmrc
Code:
ServerArgsLocal=-nolisten tcp
If you want to lock it down, then see here. http://docs.slackware.com/howtos:sec...basic_security

If you want to enable remote connections, then see here. http://alien.slackbook.org/blog/runn...on-ms-windows/
 
Old 11-28-2012, 03:02 AM   #5
xj25vm
Member
 
Registered: Jun 2008
Posts: 262

Original Poster
Rep: Reputation: 17
Thanks for all the replies
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Default services listening on tcp ports narz Slackware 6 11-28-2012 03:05 AM
Script listening on TCP port pcmilhouse Linux - Networking 2 10-24-2006 12:15 PM
TCP Port not listening Craig Cox Linux - Security 1 10-10-2006 11:08 AM
tcp listening port help pbaxter Linux - Networking 4 07-11-2006 03:38 PM
MySQL on Debian 3.0: TCP listening Hko Linux - Software 3 09-04-2002 02:28 PM


All times are GMT -5. The time now is 07:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration