LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-09-2005, 07:55 AM   #1
pitt30
Member
 
Registered: Jan 2004
Posts: 53

Rep: Reputation: 16
xmodmap help


before i start working on the keyboard, i am trying to get my mouse working correctly. if i manually type xmodmap -e "pointer = 1 2 3 6 7 4 5" my mouse works as it should. i tried putting this command in .Xmodmap bot on my home directory as well as in the .Xmodmap in /usr/X11R6/lib/X11/xinit/. (both at different times of course, and with the command, pointer = 1 2 3 6 7 4 5, both with and without -e). i also tried the full command xmodmap -e "pointer = 1 2 3 6 7 4 5" in rc.local with no success as well. i also tried the command in xinitrc with no results.
i searched the forum and tried all the recommendations without success. can someone please help me here so i can move on and get frustration from my keyboard.

thanks
 
Old 01-09-2005, 10:43 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,385

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
it should go in ~/.xsession
 
Old 01-09-2005, 10:59 AM   #3
tazdevil77
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware 10.1 with 2.6.11
Posts: 9

Rep: Reputation: 0
mmmh, i have ".Xmodmap" file in my home and in /usr/X11/lib/X11/xinit.
"pointer = 1 2 3 6 7 4 5"

dont know which is the right one. but it works.

rico

@acid_kewpie
i dont have a "~/.xsession" file
 
Old 01-09-2005, 11:01 AM   #4
pitt30
Member
 
Registered: Jan 2004
Posts: 53

Original Poster
Rep: Reputation: 16
i don't have an .xsession file. just and .xsession-error and .xsession-error.bak files

what does an .xsession file have in it so i can make one

and thanks, all the posts i have read never stated anything about this file

taz,
maybe its a permission thing. what are your permissions set at. this is killing me

thanks

Last edited by pitt30; 01-09-2005 at 11:04 AM.
 
Old 01-09-2005, 11:08 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,385

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
it need having nothing in it at all, it is just one of the possible files that is sourced when X loads. there are loads of alternatives, i just try to stick to as few as possible.
 
Old 01-09-2005, 11:27 AM   #6
tazdevil77
LQ Newbie
 
Registered: Mar 2004
Distribution: slackware 10.1 with 2.6.11
Posts: 9

Rep: Reputation: 0
in /usr/X11/lib/X11/xinit = 0644
in home = 0644

rico
 
Old 01-09-2005, 11:38 AM   #7
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
If you are using 'startx' and not using Gnome (or maybe KDE) then your ~/.xinitrc should include
Code:
usermodmap=$HOME/.Xmodmap
...
if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi
and your ~/.Xmodmap should work. Gnome disregards .Xmodmap for some idiotic reason and graphical logons ignore .xinitrc for another.
 
Old 01-10-2005, 02:15 AM   #8
pitt30
Member
 
Registered: Jan 2004
Posts: 53

Original Poster
Rep: Reputation: 16
ok i tried all the suggestions and still get the same thing. im thinking the Xmodmap is not loading. there is a reference pointing to in in xinitrc but i just dont know anymore of why this isnt working.

im lost,
 
Old 01-10-2005, 07:15 AM   #9
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Hm. Well, tazdevil77 said he had it in quotes and it worked, but I would have suggested removing the quotes. I only have keycodes and no pointer settings but, IIRC, it was very picky about the file syntax and didn't work with quoted lines. Maybe you've already done that, too, but if not, the only thing I can think to try is
Code:
pointer = 1 2 3 6 7 4 5
Might try 'xmodmap -pp' and/or change your .xinitrc to read
Code:
if [ -f $usermodmap ]; then
    xmodmap -verbose $usermodmap > wtf
fi
and do 'less wtf' after starting X just to see what's going on.
 
Old 01-13-2005, 08:45 PM   #10
pitt30
Member
 
Registered: Jan 2004
Posts: 53

Original Poster
Rep: Reputation: 16
solved!

just in case anyone else runs in to this. turns out the file does not like to have commented lines in it. i took out everything but the command, pointer = 1 2 3 6 7 4 5 and now it loads up correctly.

thanks for everyone who tried to help!
 
Old 01-14-2005, 02:48 AM   #11
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Argh. I feel like I should have thought of that. Were you using hashes? Because you can comment the file, but I think you have to use X comments - a bang instead of a shell-style hash. Congrats on getting it going.
 
Old 01-14-2005, 04:54 AM   #12
pitt30
Member
 
Registered: Jan 2004
Posts: 53

Original Poster
Rep: Reputation: 16
yep #'s all over. reread man page and read about the bangs. looked at the file and said gee, im a dumbass.

anyway thanks again
now off to get frustrated with keyboard mapping.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmodmap chrismiceli Linux - Software 2 06-29-2006 03:18 AM
xmodmap snt Linux - Software 0 11-15-2004 08:59 AM
xmodmap ntilde Mandriva 0 07-27-2004 01:28 PM
loading .Xmodmap lrt2003 Linux - Newbie 2 06-13-2004 08:19 AM
modification to .Xmodmap butthead Programming 0 02-01-2002 08:50 AM


All times are GMT -5. The time now is 09:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration