LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2009, 10:04 AM   #1
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Rep: Reputation: 15
Where is tcl / tk ?


I tried to install tkpppoe which required tcl / tk.
I installed tcl but could not find tk .
How to get it ?
 
Old 02-17-2009, 10:20 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,949

Rep: Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930
The tk package is in the slackware/tcl directory of your installation media and on the Slackware mirrors.

I should be installed if you made a full install, which is recommended, if you use Slackware.

But I can't be sure I gave you a relevant information as you do not indicate for which distribution and version you miss it

Last edited by Didier Spaier; 02-17-2009 at 10:22 AM.
 
Old 02-17-2009, 10:25 AM   #3
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
I have installed the full dvd version of slackware 12.2 yet tcl / tk is not there. Downloaded the tar.gz packages and installed it. I had to login as root and invoke tkpppoe yet I could not connect to internet.

Invoking tkppoe from CLI gives this o/p.

root@darkstar:/home/sridhar# tkpppoe
No protocol specified
Application initialization failed: couldn't connect to display ":0.0"
Error in startup script: invalid command name "tk"
while executing
"tk appname TkPPPoE"
(file "/usr/bin/tkpppoe" line 40

Last edited by varaahan; 02-17-2009 at 10:30 AM.
 
Old 02-17-2009, 10:57 AM   #4
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
Quote:
Application initialization failed: couldn't connect to display ":0.0"
If you're trying to run it from a terminal while you're running an X session as a regular user, you may get this.

The command for tcl interpreter is "tclsh" and for Tk applications it is "wish". Do you have these in your path?

Last edited by Ilgar; 02-17-2009 at 11:00 AM.
 
Old 02-17-2009, 11:34 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,949

Rep: Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930
Quote:
Originally Posted by varaahan View Post
I have installed the full dvd version of slackware 12.2 yet tcl / tk is not there.
It should be there. May be a problem with your installation media ?

I suggest you try this, as root (I suppose you mounted your DVD as /media/dvd; change that to fit your DVD's mount point):
Code:
upgradepkg --install-new --reinstall /media/dvd/slackware/tcl/*tgz
This should install or reinstall all tcl/tk related packages.

FYI (I keep a local mirror of the distribution up to date with rsync):
Code:
bash-3.1$ cd /home/ne_pas_sauvegarder/slackware-12.2/slackware/tcl/
bash-3.1$ ls -1 *tgz
expect-5.44.1.11-i486-2.tgz
hfsutils-3.2.6-i486-4.tgz
tcl-8.5.5-i486-1.tgz
tclx-8.4-i486-2.tgz
tix-8.4.3-i486-1.tgz
tk-8.5.5-i486-1.tgz
bash-3.1$
If you do not have one of these packages, you can get it using the Slackware Package Browser.

Last edited by Didier Spaier; 02-17-2009 at 11:42 AM. Reason: Typo in a command
 
Old 02-17-2009, 08:51 PM   #6
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
When I login as root I could invoke tkpppoe and connec to internet. But I could not do so as ordinary user. I have marked "Allow non=root users" option in tkpppoe.
As ordinary user I get the tkpppoe running but it doesn't connect to net.
Checked file permissions for pppoe-start / stop and resolv.conf and they are ok.

root@darkstar:/home/sridhar# ls -l /etc/ppp/resolv.conf
-rwxr-xr-x 1 root root 54 2009-02-18 08:15 /etc/ppp/resolv.conf

root@darkstar:/home/sridhar# ls -l /usr/sbin/pppoe-start
-rwxr-xr-x 1 root root 5599 2009-02-17 22:11 /usr/sbin/pppoe-start

root@darkstar:/home/sridhar# ls -l /usr/sbin/pppoe-stop
-rwxr-xr-x 1 root root 2323 2009-02-17 22:11 /usr/sbin/pppoe-stop

root@darkstar:/home/sridhar# ls -l /usr/bin/tkpppoe
-rwxr-xr-x 1 root root 108493 2009-02-17 21:48 /usr/bin/tkpppoe
 
Old 02-18-2009, 02:43 AM   #7
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
Then you obviously have Tcl/Tk. In the first example that you gave, you're trying to run tkpppoe as root. Please give the terminal output you get as an ordinary user.
 
Old 02-18-2009, 02:46 AM   #8
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
A workaround: Try "ssh -Y root@127.0.0.1" and run your script.
 
Old 02-18-2009, 07:45 AM   #9
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
Whe I ran tkpppoe as normal user I get the dialog box of tkppoe but when I press the start button nothing happens and I could not connect to net.

This problem is with slackware only. I can run this s/w successfully in other distros (Arch , PCLOS, Zenwalk etc. )
 
Old 02-18-2009, 10:11 AM   #10
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 916

Rep: Reputation: 87
Are there any log files? I think we need more debugging info. But it's likely to be some sort of permissions problem.
 
Old 02-20-2009, 05:56 AM   #11
varaahan
Member
 
Registered: Jul 2005
Location: chennai, india
Distribution: Puppy, Arch Linux,Absolute Linux
Posts: 83

Original Poster
Rep: Reputation: 15
I agree. I tried changing to a+x for /etc/ppp , pap-secrets, resolv.conf etc but still the problem persists.

I don't have the log file .
 
Old 02-20-2009, 11:20 AM   #12
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 3,949

Rep: Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930Reputation: 930
chmod a+x only make theses files executable by all. That is not the point.

Check who is authorized to read/write on theses files instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tcl/tk 8.4 to 8.3 nicolas765 Linux - Software 1 03-15-2007 02:37 PM
Cannot find Tcl dll ( Perl's Tcl bridge ) Xyem Linux - Software 2 08-08-2006 09:45 AM
What is tcl.h? divoibs Red Hat 3 09-25-2004 09:37 AM
Tcl/tk wasabi Fedora 0 06-03-2004 09:42 AM
Tcl help anyone? CanadianPenguin Programming 4 12-30-2003 05:42 PM


All times are GMT -5. The time now is 09:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration