LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-04-2008, 06:57 AM   #1
macbeth8
LQ Newbie
 
Registered: Nov 2007
Posts: 15

Rep: Reputation: 0
weird ps/2 mouse behaviour


Hello,
I'm running current Slackware and have some sort of trouble with my ps/2 mouse. I use generic 2.6.24.4-smp kernel and use rc.modules to load psmouse module. The problem is that when kde is loaded, the mouse moves faster than it should and when I click once, it generates double click, so for example if I click on a word in browser or text editor, it is selected or when I click on the top of some window, it always maximizes, etc.
However when I am in KDE and run
modprobe -r psmouse
modprobe psmouse

then suddenly everything is normal and mouse works fine.

The strange behaviour comes back if I switch from X to another console using ctrl+alt+f#num and then back to X with ctrl+alt+f7...

I tried to use "IMPS/2" or "Auto" protocols in xorg.conf,
to comment out proto=imps in rc.modules on the line with /sbin/modprobe psmouse (but it makes no difference)
also tried to put
modprobe -r psmouse
modprobe psmouse
into rc.local, but nothing of these seems to work...

Any ideas appreciated...
 
Old 04-04-2008, 12:11 PM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Have you tried other protos, like ExplorerPS/2 ?
 
Old 04-04-2008, 12:48 PM   #3
macbeth8
LQ Newbie
 
Registered: Nov 2007
Posts: 15

Original Poster
Rep: Reputation: 0
I've tried only proto=imps or without proto option yet. And to be honest, I don't know where to change it... in /etc/rc.d/rc.modules or /etc/modprobe.d/psmouse ? I think both should work...
In rc.modules, it is written that these options should be specified in modprobe.d/psmouse

Is there any simpler way to find out which proto should work? I don't want to restart once for every try of the proto option... when I reinsert the module in KDE, it works with option proto=imps, why doesn't it work when it is inserted during boot?

I forgot to mention before that I have Genius NetScroll optical ps/2 mouse, maybe that helps...

PS: Very good photos
 
Old 04-05-2008, 11:34 AM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Yes change it in /etc/modprobe.d/psmouse:

options psmouse proto=exps


You could try changing it xorg.conf too to see if that works on its own:

Option "Protocol" "ExplorerPS/2"


Glad you like the photos - thanks.
 
  


Reply

Tags
current, mouse, ps2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
weird gzip behaviour? vlkplk Debian 3 02-22-2008 04:26 AM
Weird behaviour when trying to connect to LQ bigjohn LQ Suggestions & Feedback 2 03-11-2006 11:27 AM
9.3 weird behaviour ????? bigjohn Suse/Novell 9 07-06-2005 06:44 AM
[SOLVED] k3b weird behaviour filosophem Linux - Software 3 01-23-2005 05:42 PM
Weird DNS (?) behaviour jalonsom Linux - Networking 1 10-31-2004 07:55 AM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration