Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-01-2004, 08:25 AM   #1
LQ Newbie
Registered: Mar 2003
Distribution: Slackware all the way!
Posts: 19

Rep: Reputation: 0
VMware vmmon building error

I'm trying to install VMware 4 on my Slack 9.1 box, but I can't get the vmmon module compiled When I run
Quote: --compile
and point the script to
it ends with this error:
../linux/driver.c: At top level:
../linux/driver.c:133: warning: initialization from incompatible pointer type
../linux/driver.c: In function `init_module':
../linux/driver.c:246: structure has no member named `prev'
../linux/driver.c:247: structure has no member named `next'
make[2]: *** [driver.o] Error 1
make[2]: Leaving directory `/tmp/vmware-config3/vmmon-only/driver-2.6.1'
make[1]: *** [driver] Error 2
make[1]: Leaving directory `/tmp/vmware-config3/vmmon-only'
make: *** [auto-build] Error 2
make: Leaving directory `/tmp/vmware-config3/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "" and

Execution aborted.
What's going wrong?
Old 02-01-2004, 08:29 AM   #2
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 31
You need to download the 2.6 patch from

IIRC unpack it and run instead of the vmware-install script, then and you should be good to go. More info at

For some reason I could never get the cdrom to read cds under XPPro with VMWare and 2.6, although it worked fine with 2.4 (but I never really tried very hard).
Old 02-01-2004, 08:58 AM   #3
LQ Newbie
Registered: Mar 2003
Distribution: Slackware all the way!
Posts: 19

Original Poster
Rep: Reputation: 0
yep that did the trick, thanx man


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware: trouble with loading of vmmon -- already compilled Adony Linux - Software 6 01-17-2012 11:11 PM
Vmware missing device /dev/vmmon blavish Linux - Software 4 08-01-2010 05:49 AM
Trying to install VMWare Workstation on Suse 9. Needs to compile vmmon modules. PatSpencer SUSE / openSUSE 2 12-18-2004 08:07 PM
VMware module building kernel error ^^ ZoNicONE Linux - Newbie 3 09-09-2003 02:52 PM
slackware 9 and vmware vmmon probs duister Slackware 4 07-31-2003 03:15 PM

All times are GMT -5. The time now is 10:49 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration