LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2009, 07:43 PM   #31
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 217

Rep: Reputation: 34

with the keyboard thing, always is in that way?
editing that file? i had to change it to latam (latin american)
and by the way(already posted) with the upgrades, emerald theme manager freezes.
 
Old 06-12-2009, 09:32 PM   #32
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 495

Rep: Reputation: 81
Quote:
Originally Posted by BobNutfield View Post
I have been trying for days to get direct rendering with the open source radeon driver to no avail. Just did this massive update tonight and PRESTO! Direct rendering on the first reboot!
YES! Now kde4 is looking very sexy...
 
Old 06-13-2009, 04:59 AM   #33
zvzi
Member
 
Registered: Aug 2003
Location: Malaysia
Distribution: slackware
Posts: 71

Rep: Reputation: 17
hmm i'm using the open source radeon drivers for the first time since catalyst 9.3 doesn't work for xorg 7.5...

hey, it seems to be much faster! and it's only going to get better with future kernel support for kms and memory management

anyway, big thanks to the slackware team for the great work
 
Old 06-13-2009, 08:35 AM   #34
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
For those of you who aren't aware, you should be able to get an Xorg setup that "just works" without an /etc/X11/xorg.conf at all. That doesn't apply to those of you who need the binary-only drivers (nvidia or ati), but otherwise, there should be no need for an xorg.conf file.
 
Old 06-13-2009, 08:49 AM   #35
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 45
Quote:
Originally Posted by rworkman View Post
For those of you who aren't aware, you should be able to get an Xorg setup that "just works" without an /etc/X11/xorg.conf at all. That doesn't apply to those of you who need the binary-only drivers (nvidia or ati), but otherwise, there should be no need for an xorg.conf file.
I tried that, but on its own, X decides on a strange screen resolution for me. My monitor says "USER DEFINED" and Xorg.0.log says 1440x1050 or something in that region (I don't have the log anymore). I just ran xorgsetup, removed the inputdevice sections, and added a Modes "1024x768" line.

Also, I have a i810e chipset, and apparently there's no DRI in 24 bit color mode, so I set it to 16 in xorg.conf
 
Old 06-13-2009, 01:40 PM   #36
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Quote:
Originally Posted by rworkman View Post
For those of you who aren't aware, you should be able to get an Xorg setup that "just works" without an /etc/X11/xorg.conf at all. That doesn't apply to those of you who need the binary-only drivers (nvidia or ati), but otherwise, there should be no need for an xorg.conf file.
That certainly seems to be the case. Even though I have an xorg.conf, it appears that the system is just ignoring it. After this huge upgrade, my keyboard defaulted to a US layout, when I have a GB layout. I went back to xorg, confirmed that the keyboard layout was correct, but the system stubbornly stayed in US layout. So, I simply changed it in KDE to the correct layout, and all is OK.

Very minor thing as far as I am concerned. I am absolutely thrilled with the new performance my laptop is getting.

Thanks again.

Bob
 
Old 06-14-2009, 06:10 PM   #37
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by rworkman View Post
For those of you who aren't aware, you should be able to get an Xorg setup that "just works" without an /etc/X11/xorg.conf at all. That doesn't apply to those of you who need the binary-only drivers (nvidia or ati), but otherwise, there should be no need for an xorg.conf file.
I found another instance where neither no xorg.conf file,
nor one generated by "X -configure" will work.

For rxvt-unicode I use the 8x16bold font. It is not loaded
by default with no xorg.conf, or with the one generated by
issuing "X -configure". I had to either use my old xorg.conf
file, or add the correct FontPath for 8x16bold to the one
generated by "X -configure" to get rxvt-unicode to load with
the following options:
Code:
urxvt -geometry 165x80 -fn "8x16bold" -pe tabbed -bg black -fg white
Hope this helps someone else now running X.Org 1.6.1
 
Old 06-14-2009, 06:19 PM   #38
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Quote:
Originally Posted by rworkman View Post
For those of you who aren't aware, you should be able to get an Xorg setup that "just works" without an /etc/X11/xorg.conf at all. That doesn't apply to those of you who need the binary-only drivers (nvidia or ati), but otherwise, there should be no need for an xorg.conf file.
Thanks for this post. So if I don't need binary-only drivers will I need to run xorgconfig or xorgsetup to get x windows set-up in the next stable release?
After a full install of Slackware64 will I just need to run startx to be up and running in x windows?

hitest
 
Old 06-14-2009, 08:35 PM   #39
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Here's a follow-up question: What do I do if I need the binary Nvidia drivers?

Thanks!

-Drew
 
Old 06-14-2009, 08:46 PM   #40
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,462

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Quote:
Here's a follow-up question: What do I do if I need the binary Nvidia drivers?
See post #2
http://www.linuxquestions.org/questi...h-xorg-732575/
 
Old 06-15-2009, 01:13 AM   #41
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by Bruce Hill View Post
I found another instance where neither no xorg.conf file,
nor one generated by "X -configure" will work.

For rxvt-unicode I use the 8x16bold font. It is not loaded
by default with no xorg.conf, or with the one generated by
issuing "X -configure". I had to either use my old xorg.conf
file, or add the correct FontPath for 8x16bold to the one
generated by "X -configure" to get rxvt-unicode to load with
the following options:
Code:
urxvt -geometry 165x80 -fn "8x16bold" -pe tabbed -bg black -fg white
Hope this helps someone else now running X.Org 1.6.1
Where is that font located?
 
Old 06-15-2009, 11:30 AM   #42
djake
LQ Newbie
 
Registered: Nov 2006
Location: Vimmerby, Sweden
Distribution: Slackware, Fedora
Posts: 10

Rep: Reputation: 0
Quote:
Originally Posted by sahko View Post
Modifying hal configuration

Copy the file:

/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi

to

/etc/hal/fdi/policy/10-keymap.fdi

and edit this copy
I did this, and it works. But still have a small problem: I can't get characters combined with diacritics, gets e if I try to do it with the keyboard. The keyboard layout is se, if that's relevant.
 
Old 06-15-2009, 12:45 PM   #43
phunkymunky
Member
 
Registered: Aug 2003
Location: Glasgow, Scotland
Distribution: Slackware 14.0, Debian 7.0
Posts: 60

Rep: Reputation: 22
I have gone through the update,took a while and eveything seems OK aprt from my keyboard mapping getting all screwed up and having to renew Xmodmap using xev!!

The only thing is Firefox now crashes X. It will be open for about 5 or 6 seconds then screen blacks out and kicks me back to the login screen. I have checked all the logs and the only common thing I can see is to do with gconf and kdm but searching all day has got me nowhere. I can't login to KDE either (been trying different environs as I use fluxbox) it gets halfway through loading then boots me out to login screen again.

Below is the edited errors from /var/log/syslog and /var/log/messages


Fron syslog:

Jun 15 13:15:47 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 13:15:48 stargate kdm_greet[12650]: Cannot open default user face
Jun 15 13:21:55 stargate kdm_greet[13722]: Cannot open default user face
Jun 15 13:22:26 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 13:22:28 stargate kdm_greet[13822]: Cannot open default user face
Jun 15 13:22:48 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 13:22:49 stargate kdm_greet[13920]: Cannot open default user face
Jun 15 15:36:38 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 15:36:40 stargate kdm_greet[10437]: Cannot open default user face
Jun 15 18:00:02 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 18:00:05 stargate kdm_greet[11279]: Cannot open default user face

Jun 15 18:20:13 stargate kdm_greet[15437]: Cannot open default user face
Jun 15 18:20:40 stargate kdm[2689]: X server for display :0 terminated unexpectedly
Jun 15 18:20:42 stargate kdm_greet[15538]: Cannot open default user face
Jun 15 18:20:56 stargate kdm_greet[15577]: Cannot open default user face


From messages:

Jun 15 15:36:23 stargate gconfd (phunky-10412): starting (version 2.22.0), pid 10412 user 'phunky'
Jun 15 15:36:23 stargate gconfd (phunky-10412): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 15 15:36:23 stargate gconfd (phunky-10412): Resolved address "xml:readwrite:/home/phunky/.gconf" to a writable configuration source at position 1
Jun 15 15:36:23 stargate gconfd (phunky-10412): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 15 15:36:53 stargate gconfd (phunky-10412): SIGHUP received, reloading all databases
Jun 15 15:36:53 stargate gconfd (phunky-10412): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 15 15:36:53 stargate gconfd (phunky-10412): Resolved address "xml:readwrite:/home/phunky/.gconf" to a writable configuration source at position 1
Jun 15 15:36:53 stargate gconfd (phunky-10412): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 15 15:36:53 stargate gconfd (phunky-10412): GConf server is not in use, shutting down.
Jun 15 15:36:53 stargate gconfd (phunky-10412): Exiting
Jun 15 15:37:00 stargate gconfd (phunky-10513): starting (version 2.22.0), pid 10513 user 'phunky'
Jun 15 15:37:00 stargate gconfd (phunky-10513): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 15 15:37:00 stargate gconfd (phunky-10513): Resolved address "xml:readwrite:/home/phunky/.gconf" to a writable configuration source at position 1
Jun 15 15:37:00 stargate gconfd (phunky-10513): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2

#####cut out irrelevant lines######

Jun 15 18:00:31 stargate gconfd (phunky-10513): GConf server is not in use, shutting down.
Jun 15 18:00:31 stargate gconfd (phunky-10513): Exiting


The only advice I have found was to logout and then login to gnome then logout and back in as normal to fix gconf errors but I don't have gnome.
Any help appreciated cause it is a pain not being able to use firefox.
 
Old 06-15-2009, 02:29 PM   #44
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Rep: Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887Reputation: 887
fyi, I had issues with Intel GMA 4500HD (Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller(rev 07)) and newer x.org.

had to:
- move /etc/X11/xorg.conf
- create a new one with
Code:
X -configure
- edit the new file:
- removed dri (left dri2) from module section
- added in monitor section
Code:
Option "DPMS" "true"
- configured card section like this
Code:
Identifier  "Card0"
Driver      "intel"
Option     "AccelMethod" "UXA"
Option     "DRI" "true"
Option     "BackingStore" "true"
EndSection
I think this should probably work for every intel card, maybe the only change needed with other models is the accelmethod, that can be also EXA (or XAA).
 
Old 06-15-2009, 04:27 PM   #45
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by rworkman View Post
Where is that font located?
Hey, Robby ... see this post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suggestion for slackware current: Updated slrn andrew.46 Slackware 7 11-08-2008 04:39 PM
Xorg server updated,, mouse gone R03L Slackware 29 05-11-2008 03:46 AM
Xorg version current edM Slackware 1 02-29-2008 05:52 PM
Just updated to -current...now when screensaver comes on it locks up! spaceballs Slackware 2 10-23-2007 10:04 AM
XOrg 6.8.1 on Current zba78 Slackware 13 01-18-2005 02:53 AM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration