LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-04-2005, 01:28 AM   #1
Knowledgements
Member
 
Registered: Jul 2005
Posts: 56

Rep: Reputation: 15
switching desktop


hello ,

is there any command to switch desktop fluxbox to kde ??

i've changed /etc/X11/xinit/xinitrc file

but it doesn't work..

it was

# Start the window manager

"fluxbox"

i changed fluxbox to startkde

but when i write startx and hit enter it starts FLUXBOX

is there a command to change window manager!????
 
Old 08-04-2005, 01:52 AM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
You probably need to change your ~/.xinitrc (the home/user/.xinitrc file)
 
Old 08-04-2005, 02:01 AM   #3
Lim45
Member
 
Registered: Apr 2003
Location: Northern England
Distribution: Debian Wheezy 64-bit
Posts: 128

Rep: Reputation: 15
Try "xwmconfig" (minus quotes, of course), select KDE, startx as normal and you should be okay.
 
Old 08-04-2005, 02:09 AM   #4
Knowledgements
Member
 
Registered: Jul 2005
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Harishankar
You probably need to change your ~/.xinitrc (the home/user/.xinitrc file)
there is no folder called .xinitrc ???

but xwmconfig is working
thank you
lim45
 
Old 08-04-2005, 02:11 AM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
.xinitrc is not a folder. It's a file. If it doesn't exist, you can create it.
 
Old 08-04-2005, 02:25 AM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Remember that files that start with a . (dot) are hidden, you can see them with: ls -a
or setting your filemanager properly.
 
Old 08-04-2005, 02:46 AM   #7
Knowledgements
Member
 
Registered: Jul 2005
Posts: 56

Original Poster
Rep: Reputation: 15
yes i know but there is no file or folder called .xinitrc
if i create this what shall i write in it ?? cp /etc/X11/xinit/xinitrc ???
 
Old 08-04-2005, 03:03 AM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Knowledgements, xwmconfig just do it that for you
(try cat ~/.xinitrc after a xwmconfig change, you will see)
 
Old 08-04-2005, 03:28 AM   #9
Knowledgements
Member
 
Registered: Jul 2005
Posts: 56

Original Poster
Rep: Reputation: 15
ok!.. thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 3.3 Bad Monitor Switching on Desktop Switching Inchoate Linux - Software 1 05-25-2005 02:00 PM
switching desktop environments honu Linux - Newbie 1 12-31-2004 03:10 AM
Switching Between Desktop Enviroments.. sxa Linux - General 2 08-18-2004 09:01 PM
Desktop switching Paul_assheton Linux - Software 3 05-21-2003 03:13 AM
Desktop Switching Prob vampire28 Linux - General 2 06-18-2002 03:28 AM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration