LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-28-2011, 10:22 AM   #1
autophil
Member
 
Registered: Jun 2006
Location: Cirencester
Distribution: Slackware-12.2 + Salix-13.37
Posts: 118
Blog Entries: 1

Rep: Reputation: 15
sound card configuration


I have an ATI SB4x0 audio card in my laptop and have been battling to get any sound out of it. Then I saw a solution in the Ubuntu forum. They reckon that it is a fault of ALSA that tries to install the incorrect driver for this card. This guy says that he fixed it [http://ubuntuforums.org/showthread.php?p=5148501]

by adding
options snd-hda-intel model=3stack


to the file
/etc/modprobe.d/alsa-base

Now the problem is: This file does not exist in Slackware (not in Zenwalk anyway). So is there another script that could be modified to solve this?
In /etc/modprobe.d/ there is a sound.conf file but I am a bit nervous to sdit it especially as it says Do not edit this file!
Any sugestions will be very much welcomed. Cheers.
 
Old 06-28-2011, 10:44 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
You can create your own configuration file under /etc/modprobe.d/ and add just that line to it.

Adam
 
Old 06-28-2011, 01:55 PM   #3
autophil
Member
 
Registered: Jun 2006
Location: Cirencester
Distribution: Slackware-12.2 + Salix-13.37
Posts: 118
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Thanks adamk75.
So what I did was I saved a text file in /etc/modprobe.d called alsa-base with that single line in it. Does that sound good?
 
Old 06-28-2011, 02:55 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Yep.
 
1 members found this post helpful.
Old 06-29-2011, 12:47 PM   #5
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current, custom kernel, amd64, Beyond LinuxFromScratch
Posts: 110

Rep: Reputation: Disabled
Might want to rename that file: /etc/modprobe.d/alsa-base.conf

--
Obquote:
"All files underneath the /etc/modprobe.d directory which end with the .conf extension specify those options as required."
-(module-init-tools-3.12, man modprobe.d)
 
Old 06-29-2011, 12:48 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,087

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Ahhh, good catch. Thanks.
 
  


Reply

Tags
ati, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card configuration mst3kman Linux - Hardware 2 01-07-2006 05:45 PM
Sound card configuration MrKevvie Mandriva 1 09-10-2004 11:43 PM
Sound Card Configuration RedHatMN Linux - Newbie 6 06-19-2003 01:12 PM
Sound Card configuration lorio Linux - Hardware 1 09-18-2002 09:36 AM
sound card configuration jibinkg Linux - Software 6 05-16-2002 08:25 AM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration