LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-15-2011, 01:56 AM   #1
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Rep: Reputation: 15
Question Some KDE questsions, 32bit 13.37


Hi. Ive mostly/only been using fluxbox since my slackware install so I havent really gotten used to KDE. I have to questions.

In the attached picture you can see there are two battery monitors at the same time. Seems a bit odd, doesnt it? How do I turn off autostart for one of them, and which one is preferrable to keep?

Second is that there is a big empty square on the desktop, only visible by its borders. Whats up with this?

Thank you.
Attached Images
File Type: jpg kde_wtf.jpg (54.7 KB, 71 views)
 
Old 06-15-2011, 02:42 AM   #2
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
I had the same issue with the rectangle border on my KDE desktop. I noticed it stopped showing up when I disabled desktop effects, so I altered the desktop effects settings until I found the culprit. For me it turned out to be using OpenGL for the compositor. Switching this to XRender caused the rectangle to go away.

In order to do this, open up "System Settings" from the K menu (or run 'systemsettings' from the command line). Select "Desktop Effects" from the "Workspace Appearance and Behavior" section, click the "Advanced" tab, and change "Compositing type" to "XRender". Hit the "Apply" button.

As for the battery monitors, if that one on the left in your screenshot is Guidance Power Manager, you may want to consider removing it from your system. I believe it is no longer maintained, and it is a bit of a pain to deal with. In fact, it has been removed from Slackware.
 
Old 06-15-2011, 03:12 AM   #3
xhack
LQ Newbie
 
Registered: Jun 2011
Distribution: AntiX
Posts: 19

Rep: Reputation: 12
The big square on your screen is the folder view widget and the default one is set to show the contents of ~/Desktop. If you drop directories in there they'll show up on the desktop. You can put .desktop files in there too for app launchers.

Edit: Just to add, if you don't like it you don't have to disable anything to get rid of it. Go to that tab in the top right corner and unlock the desktop widgets. When you hover your mouse over the box you'll see a tab pop out on the side of it. Hit the X and it will remove it.

Last edited by xhack; 06-15-2011 at 03:15 AM.
 
Old 06-15-2011, 03:28 AM   #4
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
The rectangular border is an artifact left over after removing said widget. It has shown up on several of my systems after removing the folder view widget you mention; it is not the widget itself. Either disabling desktop effects or changing the Compositing type to XRender has removed the border in each case I've encountered it.
 
Old 06-15-2011, 04:11 AM   #5
BILLYKANE
Member
 
Registered: Feb 2008
Location: Hefei,Anhui,China
Distribution: Slackware;chakra
Posts: 96

Rep: Reputation: 22
remove this package:
guidance-power-manager-4.4.0-x86_64-1.txz

see http://slackware.mirrors.tds.net/pub.../ChangeLog.txt

kde/guidance-power-manager-4.4.0-x86_64-1.txz: Removed.
This is obsolete, and was probably what was causing the
"X11: maximum number to clients reached" issues.
Thanks to specialized and Eric Hameleers.
 
Old 06-15-2011, 05:03 AM   #6
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by Mike_M View Post
The rectangular border is an artifact left over after removing said widget. It has shown up on several of my systems after removing the folder view widget you mention; it is not the widget itself. Either disabling desktop effects or changing the Compositing type to XRender has removed the border in each case I've encountered it.
I fixed the issue by disabling desktop effects, logging out, logging back in and turning the desktop effects back on.
 
Old 06-15-2011, 03:09 PM   #7
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Originally Posted by mRgOBLIN View Post
I fixed the issue by disabling desktop effects, logging out, logging back in and turning the desktop effects back on.
Are you saying it goes away permanently by doing this? If so, good for you. That has not been the case for me. As long as desktop effects are enabled, and OpenGL is selected for Compositing type, the rectangular outline will eventually reappear. It doesn't show up each time I start X; perhaps about half the time.
 
Old 06-16-2011, 02:03 AM   #8
Grisnak
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Slackware 13.37 on lappy, ubuntu on server.
Posts: 130

Original Poster
Rep: Reputation: 15
Thank you for the answers!
I removed the guidance power manager.

It was not possible to remove the widget as described above. But! When I Changed to XRender, the square disappeared. Thank you! Would never have thought of that myself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 13 32bit and then Linux Mint 32bit and then Ubuntu 10.04 32bit ciao303 Linux - Newbie 3 08-09-2010 11:03 PM
32bit lincoln.runwal Linux - Newbie 2 12-10-2008 07:10 AM
32bit lincoln.runwal Linux - Newbie 2 12-10-2008 03:43 AM
32bit or 64? joewee Suse/Novell 2 09-04-2007 01:35 PM
32bit on 64bit paralysis Linux From Scratch 2 06-02-2005 03:19 PM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration