LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-09-2004, 02:26 PM   #1
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Rep: Reputation: 15
slackware 9.1 mounting problems (cd drive, cd writer drive, win partition (ntfs))


Hi, i recently installed slackware 9.1 and i managed to mount my cd drive ( i have two, my cdwriter is an ATAPI-CD ROM DRIVE 50 MAX SPEED, and my cd drive is a TEAC CD W54E) hdc is my cd writer and I have no idea what my other cd drive is. I would like both of them mounting and hdc as a cd writer if possible. I have used the following command

Code:
mount /dev/hdc /mnt/cdrom
and also
Code:
mount -t iso9660 /dev/hdc /mnt/cdrom
both have returned the following error, but when i try to use the command, the light on my cd writer flashes as if its trying to read.
Code:
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       or too many mounted file systems
I also need some help mounting my NTFS tab, my friend told me that he did it and is using the same version of slackware as me i have been using the following:

Code:
root@soxbox:/dev# mount -t NTFS /dev/hda /mnt/windows
mount: fs type NTFS not supported by kernel
mount: probably you meant ntfs
root@soxbox:/dev# mount -t ntfs /dev/hda /mnt/windows
mount: wrong fs type, bad option, bad superblock on /dev/hda,
       or too many mounted file systems
here is what my current Fstab looks like:


Code:
/dev/hda3        swap             swap        defaults         0   0
/dev/hda2        /                reiserfs    defaults         1   1
/dev/hdc         /mnt/cdrom       iso9660     noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
/dev/hda         /mnt/windows     NTFS       noauto,user,ro   0   0
I read somewhere about people asking for the following output, so its here, i hope it helps you to help me, i will be really grateful.

ls -il output
the output was too long to post so it can be found here:
http://giz.reloadedhosting.com/lsil.txt

thanks again everyone.

thanks to anyone whos read this and anyone who can help me, i really dont know what im doing wrong. Thanks again.
Mr.Gizm0

Last edited by mr.gizm0; 05-09-2004 at 02:45 PM.
 
Old 05-09-2004, 02:29 PM   #2
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Original Poster
Rep: Reputation: 15
if you can help me even abit, i will be very grateful.

thanks to all,
mr.gizm0

Last edited by mr.gizm0; 05-09-2004 at 02:47 PM.
 
Old 05-10-2004, 05:18 AM   #3
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
Edit your /etc/fstab at hdc line
/dev/hdc /mnt/cdrom iso9660 noauto,owner,ro 0 0
to
/dev/hdc /mnt/cdrom iso9660 noauto,user,ro 0 0

the "owner" option enable this drive to be mounted by root only

What is called your cdrom drive depends on your hardware configuration.
Assuming your cdrom is installed on 2nd IDE bus as "slave" it should be called /dev/hdd.
In case, you have first to create a /mnt/cdrom1 or whatever you like directory
and then add a line like this to your /etc/fstab
/dev/hdd /mnt/cdrom1 iso9660 noauto,user,ro 0 0

This table could help you
/dev/hda primary ide bus master
/dev/hdb primary ide bus slave
/dev/hdc secondary ide bus master
/dev/hdd secondary ide bus slave

hope this helps
PS- you don't have NTFS support from kernel.
If you want to enable mounting NTFS filesystem you need to recompile the kernel, possibly moving to the new 2.6 series

Ciao

Last edited by urka58; 05-10-2004 at 05:22 AM.
 
Old 05-10-2004, 05:23 AM   #4
snop
Member
 
Registered: Aug 2003
Location: Bcn
Distribution: Slackware
Posts: 93

Rep: Reputation: 15
Hi,

Aren't you trying to mount an audio cd, aren't you ? Check that the cd you're trying to mount is not corrupted.

Bye

SnOp
 
Old 05-10-2004, 09:01 AM   #5
giddyupman
LQ Newbie
 
Registered: Nov 2003
Posts: 16

Rep: Reputation: 0
I'm just taking a stab in the dark here; but I think maybe if you try to mount *The Evil OS* as hda1 instead of hda it should work. That's how I get mine mounted; and I've about the same partition table. Maybe.
 
Old 05-10-2004, 12:05 PM   #6
Mark Havel
Member
 
Registered: May 2004
Location: Lyon, France
Distribution: Slackware
Posts: 85

Rep: Reputation: 15
You should replace the "iso9660" by an "auto" to be able to mount any CD:ROM, R, or RW which are in UDF.
 
Old 05-11-2004, 01:09 PM   #7
mr.gizm0
LQ Newbie
 
Registered: Jan 2004
Distribution: slackware 12
Posts: 26

Original Poster
Rep: Reputation: 15
Thank you for all your help
 
Old 05-11-2004, 01:33 PM   #8
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Quote:
Originally posted by snop


Aren't you trying to mount an audio cd, aren't you ? Check that the cd you're trying to mount is not corrupted.

UH, FYI.........you don't mount audio CD's
just put it in the tray, close, and then open the audio CD
with your favorite media player............
 
Old 05-11-2004, 07:23 PM   #9
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Do a cfdisk /dev/hd-the-one-you-have-ntfs-on-it, hda, hdb, hdc or hdd.
Note the ntfs partition number.
Then add the number in the good line in your /etc/fstab, like:

/dev/hdb1 /mnt/windows ntfs noauto,user,ro 0 0 , or
/dev/hdc2 /mnt/windows ntfs noauto,user,ro 0 0
Don't forget to create the /mnt/windows folder .

Note: you can write on ntfs only if you have a 2.6.x kernel, otherwise it's tricky.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting a NTFS Drive or Partition! ubern00b Linux - Software 3 04-22-2004 05:37 AM
mounting Win XP ntfs partition on linux need help crittman Linux - Software 6 12-04-2003 11:56 PM
Mounting an NTFS drive e_cubed99 Linux - Newbie 11 11-01-2003 03:05 PM
Mounting a ntfs drive? mpooley Linux - Hardware 12 12-11-2002 01:32 AM
mounting ntfs(xp) drive elpresidente Linux - Hardware 7 07-01-2002 10:24 AM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration