LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2004, 05:35 PM   #1
entropyv
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 10 (2.6.7)
Posts: 27

Rep: Reputation: 15
Slackware 10, custom 2.6.7 kernel, lilo, loads kernel very slowly


Very Newb, doing my best not to ask questions that have already been asked, but I haven't found anything about this yet...

I'm running a 2.6.7 kernel(from kernel.org) I compiled on Slackware 10 (full install). When I select what-to-boot from lilo, slackware's kernel(bzImage) seems to load extremely slowly (5 sec or so) when compared with some other distros I have tried (Mandrake & Redhat(not custom)... about a second, max).

The part that's slow is right after lilo goes away, and its saying "Loading Slackware............................................" (during the periods part).

I'm assuming that's when its loading the kernel into memory. ...it happens with either the kernel I compiled OR the 2.4.26 bare.i. I'm guessing that means its not the kernel, but rather lilo. I've checked lilo.conf and lilo docs for some indication of what would be causing it, but I've found no evidence anyone else has even experienced a similar issue. maybe I'm just not searching with the right words? in any case, I would appreciate any advise or assistance anyone can offer. (other than this little setback, it flies)
 
Old 08-19-2004, 05:41 PM   #2
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 30
The short answer is you might try adding "compact" to your lilo.conf. Then run lilo as root to set it up.

http://www.linuxquestions.org/questi...t=lilo+compact

EDIT: Would not have found it either if I had not already known what to look for.

here is my lilo.conf as an example

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 120
compact
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda3
  label = Linux
  read-only
# Linux bootable partition config ends
image = /boot/vmlinuz.old
  root = /dev/hda3
  label = LinuxOld 
  read-only

Last edited by Mephisto; 08-19-2004 at 05:45 PM.
 
Old 08-19-2004, 05:55 PM   #3
entropyv
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware 10 (2.6.7)
Posts: 27

Original Poster
Rep: Reputation: 15
OH SUPERFLY!!!!! success, thanks!

<code>
boot = /dev/hda
compact # faster, but won't work on all systems.
prompt
timeout = 50
# VESA framebuffer console @ 1024x768x256
vga=773

install=/boot/boot-bmp.b # means you will use grafical version
bitmap=/boot/handy_128.bmp # background path
bmp-colors=38,0,53,112,38,25 # text color
bmp-table=114p,347p,2,7 # label position on the screen p=pixel
bmp-timer=470p,336p,25,0,11 # timer position on the screen p=pixel

image=/boot/bzImage
root = /dev/hda6
label = Slackware
read-only

#image = /boot/vmlinuz
# root = /dev/hda6
# label = Slack_2.4.26
# read-only # Non-UMSDOS filesystems should be mounted read-only for checking

other = /dev/hda1
label = Win2k
table = /dev/hda
</code>

btw, if you're curious, my lilo img: http://www.kde-look.org/content/show.php?content=11098
 
Old 08-19-2004, 06:06 PM   #4
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 30
Quote:
Originally posted by entropyv

btw, if you're curious, my lilo img: http://www.kde-look.org/content/show.php?content=11098
Very cool!! That actually tempts me to change from my staunch "graphics are for wussies" lilo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom kernel - lilo complains device-mapper missing donni Linux - Software 3 07-26-2010 12:47 PM
Slackware 10.1 installation with custom build kernel zWaR Slackware 5 08-09-2005 02:29 AM
Everything Loads Slowly mandymo Mandriva 5 12-12-2004 11:36 AM
emacs loads very, very slowly - why? iansworld Suse/Novell 0 12-06-2004 11:50 AM
Installing Slackware CD 9.1 using custom kernel (sata) bonecrusher Slackware - Installation 7 04-07-2004 01:34 AM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration