LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-12-2003, 07:57 AM   #1
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Rep: Reputation: 15
Slack 9.1:kernel not remembering loaded modules.


i just installed 2.6.0-test11 by using a guide i found on internet.
now the problem is that everything works fine but the sound. it is an onboard i810 which works fine with the default kernel but not with the new one.
i did compile the sound modules and i can load them by doing
Code:
modprobe snd-intel8x0
modprobe snd-pcm-oss
modprobe snd-mixer-oss
modprobe snd-seq-oss
after this sound works. i tried it by doing this
Code:
cat sound file > /dev/dsp
mpg123 somemp3
even lsmod shows all the loaded modules but the problem is that the kernel does not remember it after a reboot as when i do lsmod i get just ntfs as result.
can some one please help me and tell me as to how should i go ahead and make kernel remember these loaded modules after a reboot.
thanx for reading.
 
Old 12-12-2003, 08:15 AM   #2
samwwwblack
Member
 
Registered: Apr 2003
Location: Midlands, UK
Distribution: Lapwing-Linux 2009.1
Posts: 64

Rep: Reputation: 15
Have you added the modules to rc.modules? This is probably the problem, as modprobe is only temporary;

as root,

#cd /etc/rc.d
#mc

(Highlight the rc.modules entry and press F4)

add

/sbin/modprobe snd-intel8x0
/sbin/modprobe snd-pcm-oss
/sbin/modprobe snd-mixer-oss
/sbin/modprobe snd-seq-oss

in the sound support section

Hope this solves your problem,

Best Regards,

Sam Black
 
Old 12-12-2003, 09:34 AM   #3
abhay
Member
 
Registered: Oct 2003
Location: New Delhi, India
Distribution: Mandrake 9.1, Redhat 9.0, Slackware 9.1
Posts: 58

Original Poster
Rep: Reputation: 15
damn i m moron...
thanx a lot pal as that worked but the thing i don't understand is that when i did modprobe ntfs then it remembered the module but not the sound ones. any ideas as to why that happened?
thanx once again...cheers...
 
Old 12-12-2003, 09:43 AM   #4
samwwwblack
Member
 
Registered: Apr 2003
Location: Midlands, UK
Distribution: Lapwing-Linux 2009.1
Posts: 64

Rep: Reputation: 15


Your guess is as good as mine to that one, unless hotpluggin/other rc.d scripts picked it up - I stick to editing the files rather than rely on programs to do it for me, as it sounds a lot like another OS we're all trying to get away from.

Best Regards,

Sam Black
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I Get A List Of Modules Loaded In The Kernel ? linu_soft Programming 2 06-28-2004 06:39 AM
kernel: No module symbols loaded - kernel modules not enabled. Qucho Debian 9 05-26-2004 02:50 AM
how do I disable kernel modules from being loaded hdagelic Linux - General 1 04-09-2004 03:53 AM
Kernel 2.6.5 -> no modules loaded Spheerke Debian 4 04-07-2004 09:05 PM
kernel modules loaded at boot time gusgorman Slackware 10 04-14-2003 10:45 AM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration