LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-08-2003, 11:08 PM   #1
monkeymartin
Member
 
Registered: Mar 2003
Location: canada
Distribution: slackware 9.0 knoppix
Posts: 81

Rep: Reputation: 15
Setting Up A Burner


I want tot burn Cd's from the command line

These are the instructions that I fallowed

1) Open terminal/console
2) Enter su and enter root password
3) Enter pico /etc/fstab correct the link below

/dev/cdrom /mnt/cdrom iso9600 noauto,users,ro 0 0

4) save and exit
5) Enter ln -sf /dev/sr0 /dev/cdrom
6) enter pico /etc/lilo.conf and if not already after timeout line

append=hdc=ide-scsi

7) save and exit
8) enter /sbin/lilo if errors occur go back to step 6
9) reboot (log out of x and enter reboot)

how do i burn Cd's after all of this

i can't even mount the drive
 
Old 04-08-2003, 11:29 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
It should be iso9660, not iso9600,
but other than that it looks all right,
assuming that you actually have
/mnt/cdrom and that your SCSI-
emulation-device ends up as /dev/sr0

Mine (using Slack 8.1) is /dev/scd0 :}

As for the burning, you might want to
read the manpages for mkisofs and
cdrecord (or cdrdao).



Cheers,
Tink
 
Old 04-08-2003, 11:33 PM   #3
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
it's append="hdc=ide-scsi"

you want to copy a cdrom from
cdrom drive hdb
to cdrecorder /dev/scd0

cat /dev/hdb | cdrecord dev=0,0,0 speed=12 -
 
Old 04-09-2003, 01:08 AM   #4
monkeymartin
Member
 
Registered: Mar 2003
Location: canada
Distribution: slackware 9.0 knoppix
Posts: 81

Original Poster
Rep: Reputation: 15
when I run cdrecord -scanbus i get this messag

Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

I think I might have to compile scsi generic support into my kernel
I am running Slackware 9.0 and i installed the bare kernel if this is the problem how do I do it.

Last edited by monkeymartin; 04-09-2003 at 01:09 AM.
 
Old 04-09-2003, 07:16 AM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
The sg device support is part of the bare.i kernel. It does require a kernel module to be loaded though. (ide-scsi) If that module has loaded, use "lsmod" to determine if it is listed, then the problem is back to the lilo config. (append="hdc=ide-scsi") And the hdc device needs to be the proper device for the CDRW drive. After changing, run "lilo" and then reboot. Chekc for the module "ide-scsi" and if loaded then "cdrecord -scanbus" should report the scsi bus and the drive, probably on device 0,0,0.

The ide-scsi module should be configured to load from boot in the rc.modules.
 
Old 04-09-2003, 10:29 AM   #6
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298
Blog Entries: 21

Rep: Reputation: 30
It says you have to be root to at least use the -scanbus feature, why don't you try doing it under superuser?
 
Old 04-09-2003, 12:25 PM   #7
notAcoolNick
Member
 
Registered: Apr 2003
Location: Oxford, MA, USA
Distribution: Slackware
Posts: 89

Rep: Reputation: 15
Just a quick note.
Slack always comes (as any respected linux distribution) with a set of recent HOWTO documentation files (that I belive you have installed). Check out /usr/doc/Linux-HOWTOs/CD-Writing-HOWTO. It contains pretty extencive information on how to create iso images, burn CD's and what modules are required to do that.
 
Old 04-10-2003, 01:36 PM   #8
robtheJobNorflk
LQ Newbie
 
Registered: Apr 2003
Distribution: Slackware 10.0
Posts: 28

Rep: Reputation: 15
I am having a similar problem when running cdrecord -scanbus, with the same errors as above...

I have set the append="hdc=ide-scsi" in lilo.conf and rerun lilo, however it still seems kmod is automatically setting it before the scsi driver. (When I do dmesg I see it set to hdc, cdrom)

I have a CD/DVD writer combo driver, is this making any difference?

Many thanks
 
Old 04-10-2003, 01:47 PM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
If you are still able to mount a CD using /dev/hdc as the device drive then the append statement is not correct. Check it, change as required and run lilo again. Then reboot. The /dev/hdc should no longer work. The drive would /dev/scd0 after the module ide-scsi is loaded to support the drive. As long as the native IDE driver support is controlling the drive it prevents the ide-scsi module from functioning. Also, make sure your CDR drive is actually hdc. Use the value that is correct for your drive.
 
Old 04-10-2003, 02:04 PM   #10
robtheJobNorflk
LQ Newbie
 
Registered: Apr 2003
Distribution: Slackware 10.0
Posts: 28

Rep: Reputation: 15
Hi Excalibur,

hdc is definetly the correct drive as it was listed in dmesg before any alterations (plus it is master on second ide), so I believe that the append statement is OK. I am using the bare.i kernal, and believe that kmod is running most things at boot.

Is it better to turn of hotplugging and just uncomment things in rc.modules? Woruld this be grabbing the cdrw before ide-scsi can get it?
 
Old 04-10-2003, 02:12 PM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
ide-scsi is called from rc.modules

Attempt to mount a cd on /dev/hdc. If it still works then post your lilo.conf file.
 
Old 04-10-2003, 03:21 PM   #12
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
the append line
should be after the image=
line you are booting with
and before the next one.
 
Old 04-11-2003, 10:53 AM   #13
robtheJobNorflk
LQ Newbie
 
Registered: Apr 2003
Distribution: Slackware 10.0
Posts: 28

Rep: Reputation: 15
The following is my lilo.conf at the moment...

boot = /dev/hda5
vga = 773
image = /boot/vmlinuz
append="hdc=ide-scsi"
root = /dev/hda5
label = Linux

(I use windows XP boot loader, lilo is sitting on start of root, and only boots Slackware.)

The scsi emulation stuff must be working, I have a compact flash card reader that gets recognised as /dev/sda1 and can be mounted. But still no joy with the CD -writer...

There is this error in dmesg, but I thought this was simply because it could not find a specific scsi card...

kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
 
Old 04-11-2003, 11:39 AM   #14
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
are you making a fresh copy of the boot sector
for XP after running lilo?

mine looks like this

[boot loader]
timeout=3
default=c:\work\redhat
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00"
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [VGA mode]" /basevideo /sos
c:\bootsect.dos="MS-DOS"
c:\work\redhat="Redhat"
c:\work\deb="Debian-Demolinux"
c:\work\peanut.lnx="Peanut"
c:\work\gentoo="Gentoo"
c:\work\mand8="M8"

the partition with the boot files is mounted on /hda1

so after lilo
dd if=/dev/hda5 of=/hda1/work/redhat bs=512 count=1
 
Old 04-11-2003, 12:18 PM   #15
robtheJobNorflk
LQ Newbie
 
Registered: Apr 2003
Distribution: Slackware 10.0
Posts: 28

Rep: Reputation: 15
Ah hah! doh! As if by magic the cd-rom is recognised as a scsi device when I do a cdrecord -scanbus.

I did not realise that changing lilo.conf meant that the 512 bytes which I copy to windows xp bootloader changed too...

I am unsure how it needs to be recognised in fstab to get it mounted, I think I have to change the symbolic links and change the cdrom in fstab to scd0

Many many thanks for this, I hope you don't think I have wasted your time...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up a CD burner sleepisforwimps Slackware 7 05-30-2005 06:21 PM
setting up cd burner and using it to burn cd in mandrake 9.1 Donchima Linux - Networking 1 10-05-2004 12:12 PM
help setting up CD burner adambeazley Linux - Hardware 2 04-27-2004 12:49 AM
setting up ATAPI cd burner from scratch thebeast Linux - Hardware 13 04-24-2004 09:49 PM
Setting Up CD Burner Sergeus Linux - Software 3 02-06-2002 11:09 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration