LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2005, 01:43 PM   #1
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Rep: Reputation: 30
Resolution - all values correct


hi guys
i know this has been asked a million times, but all the replies i have looked at tell them to find the correct hsync/vsync monitor values.

well i have, and my config is

http://x-kane.com/misc/xorg-notworking.conf

and its monitor0 that wont let me go to 1280x960 @ 75hz
(usually used in windows) and i cant use it at 60hz because it gives me one hell of a headache

any ideas?

Kane

edit:: btw im not using xinerama or anything, its just both monitors, each have their own gnome taskbar etc.

Last edited by Kane2002; 01-25-2005 at 02:02 PM.
 
Old 01-25-2005, 03:48 PM   #2
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
i just used the modeline generator http://xtiming.sourceforge.net/cgi-bin/xtiming.pl

and it says i should have interlacing enabled (i guess thats why it works in windows)

and it created this modeline
Modeline "1280x960@75i" 59.39 1280 1312 1536 1568 960 981 987 1009 interlace

it says " Put the following modeline in your XF86Config in the Monitors section, and add it to your active modes in the Screen section. Use this modeline at your own risk."

so in the monitor section do i leave all the hsync and vsync values there and add this line as well? or delete them and then add this line? is there anything else i need to remove?

and whereabout do i add it in the screen section. (yes i know it says active modes) but what does this mean ?

thanks
Kane
 
Old 01-25-2005, 05:00 PM   #3
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
well i added the modeline to the monitor bit
and it kind of worked.....

well it let me choose 1280x960 @75hz ... but it was interlaced ...and so the whole screen looked like it had scan line across.

so i then just removed the interlaced word at the end of the modeline ...and it wouldnt let me have it up at 75hz again.

so is this the only way i can possibly have it?
atm i am having to resort to run my screen at 1152x864 @ 75hz. its not that bad but i would much prefer it if i could get the other resolution working

any ideas?

thanks alot
Kane
 
Old 01-25-2005, 06:16 PM   #4
eelriver
Member
 
Registered: May 2004
Location: san francisco
Distribution: Slackware 10.2 kernel 2.6.13, Gentoo amd64, Some mish-mash of programs that started with slack 9.0
Posts: 165

Rep: Reputation: 30
Try this. Instead of :HorizSync 30.0 - 72.0
VertRefresh 47.0 - 160.0

Use: HorizSync 32.0 - 72.0
VertRefresh 48.0 - 160.0

At least with Nvidia, and probably some other cards, these values work better when divisable by 8.
 
Old 01-25-2005, 07:15 PM   #5
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Now that this has been brought up...

I've been having a similar issue. I want to run 1152x864 @ 85Hz, but by default it only let me use 75. So, I added this generated modeline:

Quote:
Modeline "1152x864@85" 132.80 1152 1184 1688 1720 864 880 892 908
It loads up at 85Hz now, but it's acting weird. It's too narrow - even at widest monitor setting, it's not filling the screen. And, the top edge isn't visible at all.

Is there a way I can tweak the modeline to work better?
 
Old 01-26-2005, 05:01 AM   #6
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
eelriver: thanks for the repy

but sadly still no luck
 
Old 02-11-2005, 08:48 AM   #7
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
^^ bump

nobody any ideas?
 
Old 02-11-2005, 09:20 AM   #8
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Could you update or post your current xorg.conf?

A couple notes:

First, AFAIK nvidia's Linux drivers simply do not support interlacing. At all. I would be VERY interested in hearing if you got it to work. For me, it always bombed out of starting X saying in the text console that Interlace and Doubleline was not supported. (I used XFree86, not X.org).

Second, I have had great success with Ati Radeons and the open source drivers for interlacing. With XFree, at least, my low end Radeon 7000 and Radeon 7200 have been able to interlace perfectly using "vesa", "ati", and "radeon" as the driver. My Ati Rage128 also interlaces using "vesa" or "ati", but it suffers from the dreaded "half height overlay bug", rendering it unusable for video playback.

I can help out figuring out suitable interlaced modelines. My HTPC uses an interlaced 1280x960 display at HDTV 1080i timings--at 60hz it's too flickery for you to be interested in. My main workstation uses an interlaced 2048x1536 display at 85hz--VERY nice looking!

Since your monitor can almost handle 1152x864@85hz, it can probably handle 1024x768@85hz with no problems. That means your monitor can handle 2048x1536 interlaced at 85hz! Awesome! Now, I KNOW that your Ati Radeon can tackle 2048x1536 interlaced at 85hz. Your nVidia? You're probably out of luck, there, unless nVidia has FINALLY started supporting interlaced modes with their linux drivers.

Last edited by IsaacKuo; 02-11-2005 at 09:22 AM.
 
Old 02-14-2005, 09:41 AM   #9
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
"First, AFAIK nvidia's Linux drivers simply do not support interlacing. At all. I would be VERY interested in hearing if you got it to work. "

its not the nvidia drivers that are using interlacing, its my primary monitor (CRT 17" - which is running on a ATI Radeon 9500) that is causing the problem, the secondary monitor is working fine.


"Second, I have had great success with Ati Radeons and the open source drivers for interlacing. With XFree, at least, my low end Radeon 7000 and Radeon 7200 have been able to interlace perfectly using "vesa", "ati", and "radeon" as the driver. "

well i now have the ati drivers installed with xorg6.8.1, and the same thing seems to happen when i try to use the modelines with interlacing - ie ... i can see the screen but its kinda squashed a bit vertically and i can see the scan lines. (not good )

but im thinking it should work without interlacing, as it definatley works at 1280x960 @ 75hz in windows ... and i dont think that is interlaced (although i have no idea how i would fine out )

anyway heres my updated xorg config file
http://www.x-kane.com/misc/xorg.updated

and this starts up in 1152x864 @ 75hz ... so i have to go to desktop preferences -> screen resolution, to try to set it to 1280x960 and it just wont let me select higher than 60hz.

the modelines which are commented out are just the ones with interlacing, and also some that the ati drivers give. neither of which "work".

its really bugging me now. as this, and installing cedega (not got round to yet) are really the only things stopping me from migrating fully.

thanks alot guys
Kane
 
Old 02-14-2005, 11:04 AM   #10
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
First off, you can tell if Windows is displaying in an interlaced mode at 75hz or lower really easily--open up Internet Explorer and look at the underlines underneath links. Do they flicker like mad? If so, then it's interlaced. Otherwise, it's not. I find that at 85hz interlace flicker isn't always so easy to notice.

Second, looking at your xorg.conf, I am puzzled by the modeline names "1280x960@75i" and "1280x960@75". I don't know if it matters, but I've always used just the resolution dimensions as the modeline name. In my config files, I use "1280x960" rather than "1280x960@75" or "1280x960@75i". I use a comment line above the modeline to describe the refresh rate and such (copying the practice that Knoppix uses).

Third, I notice the driver for "ATI Graphics Adapter" is "fglrx"--the official Ati driver? I'm only familiar with the open source "ati" driver. It's possible that may the official Ati driver doesn't have as good interlace support as the open source ati driver. Maybe.



So, try uncommenting your 1280x960 interlaced modeline and removing the "@75i". Also, remove all other resolutions. You can try bumping up the HorizSync rate in "Monitor0" from 32.0 - 72.0 to 32.0 - 999.0.

In addition, you could remove everything except for "1280x960" in your "Screen0" section. If you're running KDE, then KDE will meekly accept that 1280x960 is the only resolution available. (GNOME will thickheadedly insist upon whatever resolution it's set on.)

Now, if you're ready for some REAL high resolution, you could add in this modeline:

ModeLine "2048x1536" 193.40 2048 2144 2624 2816 1536 1540 1565 1617 interlace

This modeline is 2048x1536 interlaced at 85hz. It has the same horizontal and vertical sync rates as a 1024x768@85hz display, so your monitor will be able to display it. I use this resolution and love it!
 
Old 02-14-2005, 11:32 AM   #11
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
thanks for the reply

well i guess windows isnt using interlacing anyway (didnt think it did) , so am i right in assuming it should work in linux without having to use interlacing?

and yes the fglrx drivers are the drivers you download ... and not the ones that already come with xorg.

i'll try changing the horizontal rate to 999 like you suggested, and report back

thanks alot
Kane

edit:: oh and i noticed something else earlier, when gnome starts up (or the bit just before the gnome splash screen comes on) the screen res seems to start on 1280x960 @ 60, but then flickers and switches to 1152x864 ... strange ...

and also before gnome starts the background of both screens is like a 1pixel checkerboard effect (until i get into X when the background wallpaper covers it up). - im not really bothered about this, id just like to know if you can fix it?


Last edited by Kane2002; 02-14-2005 at 11:35 AM.
 
Old 02-14-2005, 11:42 AM   #12
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
haha well i edited the xorg.conf and change the H range to 32.0 - 999.0

started X ... still started in 1152x864, so i go to dekstop preferences -> screen resolution.

and now it lets me select 1280x960 at either 85hz or 60hz (nothing inbetween), and i knew that the monitor couldnt handle the 85hz but i tried it anyway.

and the monitor warning came up: "Out of range 86Khz 85Hz"

so why is it only showing either 85hz or 60hz ..... hmmm ......

Kane
 
Old 02-14-2005, 12:49 PM   #13
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
First, the "1 pixel checkerboard effect" is actually a 4x4 repeated pattern:

Code:
#...
.#..
...#
..#.
I think that there is nothing you can do about this, as it's the default X background. Just be glad that there's SOMETHING on screen to let you know that X has started successfully, even if it happens to not get any further.

Second, I take it that what you really want is 1280x960 NONinterlaced at 75hz. Try this modeline, generated by the web page Colas XFree Modeline Generator:

ModeLine "1280x960" 129.6 1280 1336 1616 1728 960 962 974 1000 #75Hz

I still recommend at least trying out the 2048x1536 modeline. You'll have to reconfigure all of your fonts and icons to be larger, but it looks SO sharp! It is particularly stunning with serifed fonts, like the URW Pallatino clone.

Third, the reason for the mode switching is that X is opening up at the only available resolution according to the "Modes" line in the "screen0" section. However, GNOME thickheadedly insists upon switching to the mode it has been previously set at--even though this resolution isn't one of the "Modes" listed! Like I said, KDE will meekly accept that the unlisted mode is unavailable and will automatically adjust itself to the resolution which is available. Other window managers don't bother themselves with such vulgarities as a screen resolution setting, and simply settle for whatever X hands them.
 
Old 02-14-2005, 12:58 PM   #14
Kane2002
Member
 
Registered: Dec 2002
Location: UK
Distribution: Slackware, Zenwalk
Posts: 173

Original Poster
Rep: Reputation: 30
HOLY COW!!!!

it works ... i entered that modeline you gave (not the stupidly huge one ), and its working.

i also left the hsync at 32-999, and in the screen resolution setting it came up straight away with 1280x960 @ 75



thanks alot man

now im just a few short steps away from fully migrating hehe

. ... roll on cedega ....

THANKS ALOT
Kane
 
Old 02-14-2005, 03:58 PM   #15
kriton12
Member
 
Registered: Oct 2002
Posts: 81

Rep: Reputation: 16
Hmm.. as for the ATI card, have you tried using the "radeon" driver as oppopsed to the "ati" driver it looks like you're using? Also it looks like you're using the generic Nvidia driver "nv" have you tried to use the linux drivers that Nvidia makes?

That's the only thing i could suggest, using different drivers possibly ones provided by the manufacturers. ATI's is flgrx or something.

edit:

meh, didn't see the rest of the posts for some reason, glad to see you got it working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
correct resolution for wide aspect monitor crowmobe Linux - Hardware 2 03-12-2006 09:03 PM
configuring X/setting up correct monitor values etc in gentoo 1.4 bigjohn Linux - Software 8 01-12-2004 10:43 AM
XFree86 keeps deleting resolution values , can any one help me fix this??? ehdwuld Red Hat 10 11-24-2003 12:04 PM
XF86Config - Settings For Correct Resolution On Second Monitor Svha Linux - Software 3 10-03-2003 10:57 AM
Correct line for high resolution console! hijacker Slackware 0 04-24-2002 10:09 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration