LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-26-2007, 12:01 PM   #1
kr4ey
Member
 
Registered: May 2007
Location: FL
Posts: 58

Rep: Reputation: 17
Removing KDE menu items from XFCE menu


I have set up a few users on Slackware 12 that use different desktop managers.
Is there a way to remove or disable the KDE items in the XFCE menu without affecting other users?
 
Old 09-26-2007, 04:42 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I was not actually aware that FluxBox would load KDE items.

In any case, the menu is created and stored for each user individually. It can be edited for the current user by making changes to the "~/.fluxbox/menu" file. By default it needs to be edited by hand, it is not configured through any application (though they are available, just not included in Slackware).
 
Old 09-27-2007, 06:26 AM   #3
kr4ey
Member
 
Registered: May 2007
Location: FL
Posts: 58

Original Poster
Rep: Reputation: 17
Yes I know FluxBox won't show KDE items, but I'm looking for a fix to disable items in XFCE.
 
Old 09-27-2007, 04:00 PM   #4
kr4ey
Member
 
Registered: May 2007
Location: FL
Posts: 58

Original Poster
Rep: Reputation: 17
Solution:

Log in as root and go to /usr/share/applications/kde

pick the desktop file (menu item that you want to be removed)
open it in text editor, at the end of the file add

Code:
NoDisplay=true
save and exit the editor.

The item will be removed from the menu.
 
Old 03-09-2011, 04:23 PM   #5
gene_x
LQ Newbie
 
Registered: Mar 2011
Location: Sao Paulo/Brazil
Distribution: K/Xubuntu 10.10
Posts: 6

Rep: Reputation: 6
NoDisplay=true will hide the menu entry from all desktop enviroments (or at least from kde, xfce...tested)
use instead the option OnlyShowIn or NotShowIn
eg. i added OnlyShowIn=KDE to all my files under /usr/share/applications/kde4

MAKE A BACKUP OUTSIDE THE /usr/share/applications/ OF THIS DIRECTORY FIRST!
as root
cd /usr/share/applications/kde4
for i in `ls *desktop`; do echo OnlyShowIn=KDE >> $i; done

check:
http://standards.freedesktop.org/des...ec-latest.html
http://standards.freedesktop.org/men...atest/apb.html
http://ubuntu-tutorials.com/2007/07/...-icons-in-kde/

cheers
 
Old 03-09-2011, 05:39 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
You mentioned Slackware 12. You might want to read OnlyShowIn and NotShowIn Directives Do Not Work in XFCE.
 
Old 03-09-2011, 10:28 PM   #7
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,919

Rep: Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494
Quote:
Originally Posted by kr4ey View Post
Yes I know FluxBox won't show KDE items, but I'm looking for a fix to disable items in XFCE.
Just an aside.

Fluxbox may not show KDE items when you first fire it up unless they are on the default menu in /usr/, but it's easy enough to add them.

I run lots of KDE and Gnome applications from my Fluxbox menu.

In fact, in Slack 13, I think (I don't have it handy) that Konqueror was on the default Fluxbox menu from Pat.
 
Old 03-12-2011, 06:55 AM   #8
gene_x
LQ Newbie
 
Registered: Mar 2011
Location: Sao Paulo/Brazil
Distribution: K/Xubuntu 10.10
Posts: 6

Rep: Reputation: 6
Hi Woodsman.

Tks. I've read the thread and its says bug fixed at the end. The OnlyShowIn=KDE worked here for me in Xfce 4.8. Just in case, I went to /usr/share/applications/kde4 and edited amarok.desktop, commenting the line OnlyShowIn. Then Killall xfce4-panel and xfce4-panel (to reload the menu).
The amarok shortcut appeared again in the menu.

Kind Regards
 
Old 03-14-2011, 03:29 AM   #9
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Xfce has a wiki on this. Haven't tried it myself. We always use an extra panel with application icons, and personally alt+F2. Xfce's menu is a cluster though

http://wiki.xfce.org/howto/customize-menu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of Q's (KSim + Removing Menu Items) phillips321 Linux - Software 1 02-21-2005 04:07 AM
gnome 2.8 removing menu items animehair Linux - Software 2 12-05-2004 02:20 PM
KDE Menu Items AvePtah Linux - Software 1 08-09-2004 10:32 AM
Removing Items in the RH9 Main Menu GoatKing Linux - Newbie 3 01-21-2004 11:40 PM
How to add KDE menu items to Gnome menu... QtCoder Linux - General 4 10-05-2003 01:21 PM


All times are GMT -5. The time now is 09:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration