LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-24-2004, 07:17 PM   #1
d0odman
Member
 
Registered: Sep 2004
Location: CA, USA
Distribution: Slackware 10.2
Posts: 132

Rep: Reputation: 15
Question rc.wireless.conf KEY value


I have an SMC2635W wireless card in use in a Panasonic CF-37 notebook. I saw a thread here discussing how to obtain and compile the ADMtek driver for it. So far, so good.

My problem is that the WEP KEY value in rc.wireless.conf doesn't seem to be getting read out of rc.wireless.conf when rc.pcmcia is called to turn on the cardbus ports. If it do a '/etc/rc.d/rc.pcmcia restart' then immediately after, 'iwconfig eth0 key xxxx-xxxx-xx', that seems to get my card online. Otherwise, it doesn't work.

I have put in a couple entries in to rc.wireless.conf for a few different networks, and more than a few have WEP enabled. None of the configurations with WEP work when I do 'cardctl scheme <network>' and then '/etc/rc.d/rc.pcmcia restart' I have to manually enter in the key after I restart rc.pcmcia

Anyone have any ideas how to fix this? TIA
 
Old 09-24-2004, 08:02 PM   #2
coffeedrinker
Member
 
Registered: Sep 2003
Posts: 173

Rep: Reputation: 30
Set you schemes with the key in /etc/pcmcia/wireless.opts
 
Old 09-24-2004, 09:01 PM   #3
d0odman
Member
 
Registered: Sep 2004
Location: CA, USA
Distribution: Slackware 10.2
Posts: 132

Original Poster
Rep: Reputation: 15
It's not reading it there either

I just tried that now, copying rc.wireless.conf to /etc/pcmcia/wireless.opts with still no luck. It's just not reading the KEY value, it seems. When I run iwconfig after I restart rc.pcmcia, and Encryption is always turned off. Is there something else that I'm missing?
 
Old 09-25-2004, 01:42 AM   #4
coffeedrinker
Member
 
Registered: Sep 2003
Posts: 173

Rep: Reputation: 30
as root you must select your scheme:

cardctl scheme NameOfScheme

By the way I don't know if just copying the file over is a good idea. The probably follow the same format but...

In the wireless.opts file there is a lot of info on setting up various schemes.
 
Old 09-25-2004, 02:55 AM   #5
d0odman
Member
 
Registered: Sep 2004
Location: CA, USA
Distribution: Slackware 10.2
Posts: 132

Original Poster
Rep: Reputation: 15
Talking Figured it out

I was looking at the wireless.opts file and the rc.wireless.conf file, and for fun, I was checking out the rc.wireless.conf file on my linux server. It turns out, the base Slackware distribution does not support schemes, or so it seems.

Where wireless.opts parses four items (scheme,socket,interface,hwaddr), rc.wireless.confg only matches hwaddr. The big clue for me was the case statement in rc.wireless.conf (case "$HWADDR" in).

After I got rid of the three items before hwaddr, it worked like a charm. Thanks for the tips! Now, I'll have to figure out a way to switch between networks when I go from house to house (Gotta polish up those shell scripting abilities anyway...)
 
Old 09-25-2004, 11:40 AM   #6
coffeedrinker
Member
 
Registered: Sep 2003
Posts: 173

Rep: Reputation: 30
I already wrote some info on that:

http://www.linuxquestions.org/questi...hreadid=232645
 
Old 04-19-2005, 06:32 PM   #7
D_Linux
LQ Newbie
 
Registered: Mar 2005
Posts: 7

Rep: Reputation: 0
Cisco 350 wireless

Hey D0odman,

Here is what my rc.wireless.conf file looks like.... What "three items"before hwaddr are you talking about getting rid of?

UW PICO(tm) 4.9 File: rc.wireless.conf

# Extensions, so we will just call 'iwconfig' with the right parameters
# defined below.
# Of course, you need to have iwconfig installled on your system.
# To download iwconfig, or for more info on Wireless Extensions :
# http://www.hpl.hp.com/personal/Jean_...nux/Tools.html
#
# Note : you don't need to fill all parameters, leave them blank, in most
# cases the driver will initialise itself with sane defaults values or
# automatically figure out the value... And no drivers do support all
# possible settings...
#
# -- This is a modified '/etc/pcmcia/wireless.opts' script --
#

VERBOSE=1

case "$HWADDR" in
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can i enable WPA pre-shared key, wireless? spondootre Linux - Newbie 5 06-24-2005 01:12 PM
How to configure Wireless KEY automatically? enemorales Linux - Newbie 7 11-24-2004 03:30 AM
Pcmcia Wireless WEP key problem kvzrock Linux - Wireless Networking 1 09-21-2003 09:38 PM
How to enter WEP key in wireless.opts cmisip Linux - Wireless Networking 2 06-30-2003 08:56 PM
wireless encryption key shoot2kill Linux - Wireless Networking 7 10-02-2002 01:18 PM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration