LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2005, 10:08 PM   #1
Timmy_DM
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
Problems with my ATI Radeon 9600 Pro in the Slack 10.0


hello.
i read some posts about configuring ATI's drivers, tried to follow them but had some difficulties...
i use Xorg 6.8.2, then all i found is the fglrx to the 6.8.0, after i ran fglrxconfig it didn't crash my X server, it seems to work, but when i try to run that game, Enemy Territory, it becomes really s-l-o-w... dunno why, because my computer is almost new, so it must be something with my video card.

my xorg.conf looks like (just for the curious, i dunno if there is anything useful there)

# === ATI device section ===

Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
# ### generic DRI settings ###
# === disable PnP Monitor ===
#Option "NoDDC"
# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "no_dri" "no"
# === misc DRI settings ===
Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# ### FireGL DDX driver module specific settings ###
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "IgnoreEDID" "off"
Option "HSync2" "unspecified"
Option "VRefresh2" "unspecified"
Option "ScreenOverlap" "0"
# === TV-out Management ===
Option "NoTV" "yes"
Option "TVStandard" "NTSC-M"
Option "TVHSizeAdj" "0"
Option "TVVSizeAdj" "0"
Option "TVHPosAdj" "0"
Option "TVVPosAdj" "0"
Option "TVHStartAdj" "0"
Option "TVColorAdj" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"
# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Center Mode (Laptops only) ===
Option "CenterMode" "off"
# === Pseudo Color Visuals (8-bit visuals) ===
Option "PseudoColorVisuals" "off"
# === QBS Management ===
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
# === FSAA Management ===
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
# === Misc Options ===
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "yes"
Option "ForceGenericCPU" "no"
Option "KernelModuleParm" "agplock=0" # AGP locked user pages: disabled
BusID "PCI:1:0:0" # vendor=1002, device=4150
Screen 0
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24
#Option "backingstore"

Subsection "Display"
Depth 24
Modes "1024x768" "1152x864" "800x600"
ViewPort 0 0 # initial origin if mode is smaller than desktop
# Virtual 1280 1024
EndSubsection
EndSection

what is wrong up there
thanks!
 
Old 05-28-2005, 10:29 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Is there a section which reads:
Code:
Section dri
     Mode 0666
EndSection
If not, you need to add that and restart X.
If that fails to help, try this sequence of commands as root and post the output:
Code:
rmmod fglrx
modprobe fglrx
dmesg |tail
--Shade
 
Old 05-30-2005, 12:51 AM   #3
Timmy_DM
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
hi shade.
in fact, it has those lines about DRI but i just didn't paste there...

i ran those commands, the output of the first was "rmmod: module fglrx is not loaded", when i ran modprobe it loaded fglrx with some warnings about GPL license and stuff, and after the last command it detected my usb mouse, registered some things and displayed about the fgrlx:

[fglrx] Maximum main memory to use for locked dma buffers: 430 MBytes
[fglrx] module loaded - fglrx 8.12.10 [Apr 4 2005] on minor 0

then i started x and it is still s-l-o-w, (much less than 1 fps), and ran the last command, it displayed something like

[fglrx] free AGP = 21245952
[fglrx] max AGP = 21245952
[fglrx] free LFB = 120172544
[fglrx] max LFB = 120172544
[fglrx] free Inv = 0
[fglrx] max Inv = 0
[fglrx] total Inv = 0
[fglrx] total TIM = 0
[fglrx] total FB = 0
[fglrx] total AGP = 8192

i dunno what are these numbers! do i have to include on my xorg.conf my video ram? (i have 128MB)

thanks a lot!
 
Old 05-30-2005, 01:59 AM   #4
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
What's the output of:
Code:
glxinfo |grep -i direct
It worries me that fglrx wasn't loaded to begin with. That should be loaded when X starts if fglrx is defined as the driver in xorg.conf. Are you sure X is using the xorg.conf you intend it to?

--Shade
 
Old 03-16-2006, 05:20 AM   #5
Hyakutake
Member
 
Registered: Apr 2004
Location: Portugal
Distribution: Slackware
Posts: 153

Rep: Reputation: 16
Hi Timmy_DM.
Does your /etc/fstab has this line
Code:
tmpfs      /dev/shm      tmpfs      defaults     0 0
I think ATI driver needs this line to work correctly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9600 Pro - SuSe 0.2 Zoot-88 Linux - Newbie 3 05-01-2006 04:41 AM
ATI Radeon 9600 Pro jriis Debian 5 09-01-2005 05:07 AM
Overlay problems with ATI Radeon 9600 Pro Illuwatar Linux - Hardware 2 06-11-2004 12:57 PM
Ati Radeon 9600 pro driver heema Libranet 9 12-31-2003 06:59 PM
SuSE 9 ATI Radeon 9600 Pro hindenbergbaby Linux - Distributions 2 11-16-2003 09:10 PM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration