LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-08-2010, 12:09 AM   #1
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Rep: Reputation: 31
Problems running Slackware/Slackware64 13.0 in Qemu 0.12.1


This is what I get when I try to run Slackware 13.0 either x86 or x64: http://bit.ly/bwtAOQ

This is the version I'm running:
Code:
QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2), Copyright (c) 2003-2008 Fabrice Bellard
The system/setup I'm running it on:
Code:
Linux tpx200 2.6.32 #2 SMP PREEMPT Mon Dec 28 15:10:18 CST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz GenuineIntel GNU/Linux
Any ideas, folks?

Last edited by alkos333; 02-08-2010 at 12:10 AM.
 
Old 02-08-2010, 08:54 AM   #2
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
I can't duplicate the errors. What is your qemu-kvm start command?
 
Old 02-08-2010, 10:54 AM   #3
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
Code:
qemu-system-x86_64 -enable-kvm -cpu core2duo -m 512 -hda ~/testing/vm/slack-13.0.raw -cdrom slackware-13.0-install-d1.iso -boot d
That's the command I'm using. I forgot to mention that it does get to the prompt, but after I hit ENTER in, ot starts loading the kernel and then hangs with that output.
 
Old 02-08-2010, 11:59 AM   #4
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Sorry I missed your start command on the screen image link.

You don't need the "-enable-kvm" option since qemu-kvm checks if the kvm modules are loaded by default. Unless you have a reason to override the default cpu detection you don't need the "-cpu core2duo" option either.

Did you load the kvm modules first? "modprobe kvm-intel" loads both the kvm-intel and kvm modules. Are you booting with a generic or huge kernel in the VM? If the generic kernel have you setup the initrd in the VM?
 
Old 02-08-2010, 04:26 PM   #5
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
I got rid of the -enable-kvm and -cpu flag and that didn't really change anything.

I run modprobe kvm-intel prior to launching qemu. And for Slack guest, I run the huge kernel.
 
Old 02-08-2010, 04:31 PM   #6
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
I missed qemu-kvm 12.1, but did use 12.0 and 12.2, each of which run fine on various Intel and AMD systems with Kernel 2.6.24 - 2.6.32.7.

More importantly, did you ever get qemu-kvm to work properly? And what changed between then and now.
 
Old 02-09-2010, 08:50 AM   #7
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
When I still had ThinkPad T60, I ran kvm and it ran flawlessly. It booted everything fine and would even allow me to hibernate while a VM was running.

Once somebody broke my T60, I purchased a ThinkPad x200 with the following processor:
Code:
root@tpx200:~# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz
stepping	: 10
cpu MHz		: 800.000
cache size	: 3072 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida tpr_shadow vnmi flexpriority
bogomips	: 4789.53
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz
stepping	: 10
cpu MHz		: 800.000
cache size	: 3072 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm ida tpr_shadow vnmi flexpriority
bogomips	: 4789.49
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
At the same time, I also started using qemu-kvm instead of just kvm. Things have been haywire ever since. I couldn't hibernate while a VM was running and just recently I've discovered I can't run any of Slackware 13.0 whether it's 32-bit or 64-bit.

This is frustrating.
 
Old 02-10-2010, 05:54 PM   #8
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
Just tried Just updated to 0.12.2 - same problem.
 
Old 02-10-2010, 07:20 PM   #9
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Why don't you try to install the kvm-kmod slackbuild and see if that helps. It builds more recent kvm modules and leaves the release installed kvm modules alone. If that doesn't work and you choose to uninstall kvm-kmod I think you need to run "depmod -a" to reactivate the release installed kvm modules.
 
Old 02-12-2010, 12:29 PM   #10
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.3) UEFI enabled
Posts: 357

Rep: Reputation: 77
.raw file | KVM group

Since it seems you are now trying to install a new virtual machine

have you already created the .raw file?
have you created the kvm group and added your user to it?

pretty basic but it pays to check all

john
 
Old 02-17-2010, 09:24 PM   #11
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by Chuck56 View Post
Why don't you try to install the kvm-kmod slackbuild and see if that helps. It builds more recent kvm modules and leaves the release installed kvm modules alone. If that doesn't work and you choose to uninstall kvm-kmod I think you need to run "depmod -a" to reactivate the release installed kvm modules.
Tried, this didn't work.
 
Old 02-17-2010, 09:27 PM   #12
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by AlleyTrotter View Post
Since it seems you are now trying to install a new virtual machine

have you already created the .raw file?
have you created the kvm group and added your user to it?

pretty basic but it pays to check all

john
Yes, I've created an image like so:

Code:
qemu-system-x86_64 -f raw slack-13.0.raw 10G
As for the group, I have created the group and added myself to it as well.
 
Old 02-17-2010, 10:04 PM   #13
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 421

Rep: Reputation: 58
Quote:
Originally Posted by alkos333 View Post
Yes, I've created an image like so:

Code:
qemu-system-x86_64 -f raw slack-13.0.raw 10G
As for the group, I have created the group and added myself to it as well.
Huh! That's different. I create my images like this:
Code:
qemu-img create -f raw slack-13.0.raw 10G
 
Old 02-18-2010, 09:55 AM   #14
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.3) UEFI enabled
Posts: 357

Rep: Reputation: 77
[QUOTE=alkos333;3867576]Yes, I've created an image like so:

Code:
qemu-system-x86_64 -f raw slack-13.0.raw 10G
when i do "qemu-system-x86_64 --help"
there is no -f option listed
maybe try Chuck56's method to create the .raw file

john
 
Old 02-21-2010, 02:48 PM   #15
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Original Poster
Rep: Reputation: 31
[QUOTE=AlleyTrotter;3868150]
Quote:
Originally Posted by alkos333 View Post
Yes, I've created an image like so:

Code:
qemu-system-x86_64 -f raw slack-13.0.raw 10G
when i do "qemu-system-x86_64 --help"
there is no -f option listed
maybe try Chuck56's method to create the .raw file

john
Yes, well I'm using qemu-img for image creation, not qemu-system-x86_64. That's only for running the guest. Very sorry for the confusion earlier.

Last edited by alkos333; 02-21-2010 at 09:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
On qemu-kvm, qemu-ifup script not found on Slackware 13 AndrewGaven Linux - Virtualization and Cloud 14 01-29-2010 04:36 AM
[SOLVED] qemu group permission through udev rules for /dev/kqemu for slackware64 13.0 - how? btncix Slackware 1 09-28-2009 01:33 AM
QEMU/KVM GUI = AQEMU segmentation fault on slackware64 13.0! agentdcooper Slackware 3 09-16-2009 06:59 AM
anyone got winme running via qemu darkleaf Linux - Software 3 04-15-2005 04:36 AM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration