LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-20-2006, 03:04 AM   #1
rotty
Member
 
Registered: Dec 2005
Posts: 39

Rep: Reputation: 15
Pen drive problems


Slackware 11
Huge26.s kernal

I entered "/dev/sdb1 /mnt/usb vfat noauto,rw,umask=000 1 0 into the fstab file.

Now when i try to mount it with KDE's mounting app i get "mnt/usb does not exist".

Now i saw someone created the directory and it worked, how do you tweak the permissions?

And what is "Vfat" will this format work with pen drives used in windows computers?

cheers, rotty
 
Old 10-20-2006, 03:09 AM   #2
pixotec
LQ Newbie
 
Registered: Oct 2006
Location: Munich, Germany
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
vfat is used by windows. use it under linux and you can read/write under windows, too.
 
Old 10-20-2006, 03:18 AM   #3
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Oh thanks, ok well that is number 2 assured (-:

just wondering about NO 1. question now.

cheers, rotty
 
Old 10-20-2006, 03:42 AM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,210

Rep: Reputation: 55
Are you sure this should be sdb1. What does dmesg say?
 
Old 10-20-2006, 04:00 AM   #5
cmk77
Member
 
Registered: May 2006
Location: netherlands
Distribution: slackware, centos, scientificlinux
Posts: 119

Rep: Reputation: 24
what's the output of
Code:
ls -lh /mnt
In words: does the dir exist, does it have suitable permissions?

And what's the output of
Code:
dmesg | grep sdb
In words: is sdb indeed your usb stick?
 
Old 10-20-2006, 04:14 AM   #6
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
I guess if root created that folder once and gave rw perms to it for all users it should work. Why don't you just make a usb folder where you DO have rw perms and mount the pen drive there?
 
Old 10-20-2006, 04:50 AM   #7
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
The directory does not exist, i checked.

i ran fdisk -l when the USB drive is in their and it lists it as (sdb1) this is correct in other words.

cheers, rotty
 
Old 10-20-2006, 04:57 AM   #8
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,210

Rep: Reputation: 55
mkdir /mnt/usb as root
 
Old 10-20-2006, 06:42 AM   #9
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
OK i will do that, will other users be able to read/write to it?



cheers, rotty
 
Old 10-20-2006, 07:47 AM   #10
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,210

Rep: Reputation: 55
They should be able to mount to the directory and read write.
 
Old 10-20-2006, 07:15 PM   #11
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Ok i made the directory i also used:

chmod 777 /bin/mount
chmod 777 /bin/umount

to give permissions and my fstab file entry is :

/dev/sdb1 /mnt/usb vfat auto,user,rw,umask=000 1 0

i can mount as root and unmount but i get the following when trying to mount as a user:

Mount:Must be superuser to use mount

I also tried (Just remembered i did not edit sudoers (Woops), what is an entry to add?):

mount /dev/sdb1

but that gave the same message as using the KDE mount.

What can i try next i really want to get the KDE mount tool working for people that use the computer who do not know command line stuff.?


I also gave permissions for the /mnt/usb drive in KDE for read/write so their is no problem their.

cheers, rotty

Last edited by rotty; 10-20-2006 at 07:31 PM.
 
Old 10-20-2006, 08:53 PM   #12
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Remove the auto option or it will try to mount it on boot, and there it's mounted with root permissions. By using the user option the user who mounted will be able to u/mount it.
Don't put those permissions on mount/umount, it's not secure at all.
 
Old 10-20-2006, 09:16 PM   #13
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Ok i changed "auto" to "noauto".

It also seems that the user account cannot mount ANY device because it always says

"mount:mount must be superuser to mount"

This occurs if i try any method to mount: mount /usb OR mount /dev/usb OR in KDE with the program.

BTW: Everything works under the root account (SU account), so it is only with the user account.

cheers, rotty

Last edited by rotty; 10-20-2006 at 10:08 PM.
 
Old 10-21-2006, 01:26 AM   #14
rotty
Member
 
Registered: Dec 2005
Posts: 39

Original Poster
Rep: Reputation: 15
Ok i have got the pen drive working through sudoers.

But i can't write to the drive from the user acount?

What permissions should be on what folders?

should i use chmod 777 on /mnt/usb (This is the directory where the pen drive contents are located when the device is mounted.).

I FIXED IT: just for anyone searching "umask=000" is very important!! LOL
cheers, rotty

Last edited by rotty; 10-21-2006 at 02:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use pen drive in FC3 nandac Linux - Newbie 5 10-07-2006 03:55 AM
pen drive sandeepeecs Linux - Hardware 1 08-19-2006 05:06 PM
Mounting usb pen drive file permssions problems linuxmandrake Debian 1 10-10-2005 08:21 PM
Pen Drive like on XP La Dima Fedora 1 08-28-2005 06:38 AM
USB Pen Drive rlculver Linux - Hardware 1 11-08-2003 10:30 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration