LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-18-2007, 08:09 PM   #1
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Rep: Reputation: 15
Outlook Windoze XP Proper Authentication Required


Hello, I use my slack box (10.2)to authenticate to my ISP's smtp and pop servers to send and receive mail and it works fine. My other box runs windoze XP ,I configured outlook's smtp and pop setting with the ip address of my slack mail server. In outlook i can view mail which is sent but I cannot send an email to my web accounts. The first test message from outlook to my hotmail account said 550 5.7.1 <username@hotmail.com> Relaying denied. IP name lookup failed [192.168.0.101]. I added this ip address along with the windoze computername to my /etc/hosts file and got 550.5.7.1 <username@hotmail.com> Relaying denied. Proper authentication required. What do I need to add/change?

Thank You,

Raidmax
 
Old 04-18-2007, 08:27 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
I'm assuming that you're using sendmail. Have you tried adding the IP address (or subnet) to your /etc/mail/access file and re-generating the database?
Add the following to /etc/mail/access:
Code:
192.168.0.101    RELAY
Then, re-generate /etc/mail/access.db with:
Code:
makemap -v hash /etc/mail/access < /etc/mail/access
 
Old 04-18-2007, 10:42 PM   #3
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
thanks for the reply gilead...yes i'm using sendmail...added 192.168.0.101 RELAY to /etc/mail/access file and regenerated..I checked the box in outlooks advanced settings that reads My outgoing(SMTP)requires authentication and tested get the following error:



The original message was received at Wed, 18 Apr 2007 19:20:20 -0700 from windoze [192.168.0.101]

----- The following addresses had permanent fatal errors ----- <username@hotmail.com>
(reason: 550 Please configure your mail client to use authentication.)

----- Transcript of session follows -----
... while talking to smtpauth.earthlink.net.:
>>> DATA
<<< 550 Please configure your mail client to use authentication. 550 5.1.1 <username@hotmail.com>... User unknown <<< 503 valid RCPT command must precede DATA

Also i don't know if it matters but I should mentioned that my .mc file has the following added:
FEATURE(masquerade_envelope) FEATURE(genericstable, `hash -o /etc/mail/genericstable')
GENERICS_DOMAIN_FILE(`/etc/mail/genericsdomain')


$ cat /etc/mail/genericstable
myusername myusername@selfip.net
nobody myusername@selfip.net
root webmaster@selfip.net
 
Old 04-19-2007, 12:10 AM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
I haven't used the genericstable for a long time now. It could be that the info being passed to smtpauth.earthlink.net is the changed envelope info instead of the required user name - but that's just a guess.

I'd suggest running ethereal and capturing the data between your box and smtpauth.earthlink.net while you try again. Also, capture the packets from telnet'ing to smtpauth.earthlink.net (port 25) and see what is happening.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail Proper Authentication Required TomGibbons Linux - Software 3 11-05-2006 08:59 AM
required Wireless Authentication issinho Linux - Security 2 07-16-2006 04:32 PM
SQUID Authentication help required killerbrain Linux - Software 0 06-23-2006 08:13 PM
Authentication required connecting FTP eaglemc10s Linux - Newbie 2 08-04-2004 10:36 AM
authentication required on smtp on LAN only. ashfaq Linux - Software 0 02-25-2004 11:54 PM


All times are GMT -5. The time now is 07:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration