LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2003, 07:50 AM   #1
BongFish
Member
 
Registered: Jun 2003
Location: England
Distribution: Slack 9
Posts: 141

Rep: Reputation: 15
New to Slack, lots of niggly problems.


I just got Slack installed (Suprisingly simple, I found it easier than mandrake because there are less packages to install) but I'm left with plenty of little problems...

1. When loging in as root my terminal emulators look right but when I load up a terminal emulator as a normal user they just have 'bash-2.05 #' instead of the normal user then location prompt.

2. When logged in as root I can change the look and feel of KDE using control center, when loged in as a normal user it won't let me, I can load up control center but no changed I make in it have any effect either in real time or after a reboot.

3. No bsetbg or bsetroot command, I can't find where to download it either.

4. Half my programs won't compile without the kernel source, on the file list on the CD it say's it should be in [cddir]/slackware/k/kernelsource.tar however the /slackware/k directory doesn't even exist!! All the others do, such as a, d, e, f etc but no k.

5. I have my windows partitions mounted under /mnt/xp and /mnt/music but when logged in as a normal user I can't access them, what's going on?


So far I've found slack brilliant apart from these few little problems.

Any help would be much appreciated.

Last edited by BongFish; 09-20-2003 at 07:54 AM.
 
Old 09-20-2003, 08:51 AM   #2
fsbooks
Member
 
Registered: Jan 2002
Location: Missoula. Montana, USA
Distribution: fedora, slackware, suse
Posts: 447

Rep: Reputation: 31
The easy ones for me:

1) See the Bash Prompt HOWTO. If you can't figure it out from there, post again.

4) I can't tell you why it is not on your CD. However, you can easily download and install it. You probably want to. I'ld also suggest compiling your own.

5) There are multiple solutions to this. My solution (from my /etc/fstab) is as follows:
/dev/sdc1 /mnt/dos/e vfat user,umask=0000

I don't use KDE or bsetroot,bsetbg (blackbox?) so I can't help you with those.
 
Old 09-20-2003, 09:15 AM   #3
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Re: New to Slack, lots of niggly problems.

Quote:
Originally posted by BongFish
3. No bsetbg or bsetroot command, I can't find where to download it either.
Get the Blackbox slackpack from my site (see sig) and install it, you should get bsetbg and bsetroot as well because they're blackbox apps.

Btw, use pkgtool or installpkg, to install it just in case you don't know
 
Old 09-20-2003, 10:46 AM   #4
BongFish
Member
 
Registered: Jun 2003
Location: England
Distribution: Slack 9
Posts: 141

Original Poster
Rep: Reputation: 15
Okay I have number 2 resolved, some wrong file permissions.

I got bsetbg and bsetroot from the fluxbox slackpack.

I have the 2.4.22 kernel source (I have no need for a later unstable version) and am going to compile tomorrow.

Windows partitions are now accessible thanks to fsbooks.

I still can't sort out the bash prompt, I don't think that guide is quite what I'm looking for, it only seems to tell you how to add things to the 'user@host $' prompt, I don't have that at all.

The prompt I have is the single user mainance mode one, but only in some terminal emulators, some are okay. I would just use the non effected ones but I can't live without aterm.



Unfortunately I have three more things to add to the list :P!

1. How can I turn of the annoying beep every time I press something I shouldn't at the terminal, both real and emulated(ie pressing backspace when there's nothing to delete)?

2. VIM is playing up hugely when in an emulated terminal - I have my keyboard set up correctly in XF86Config and it works fine in other text editors but in vim the insert button does lots of ther things but insert text, nothing works right. I can put in : commands okay though.

3. (Big problem) When logged in as a normal user I often need to su in an xterm to edit a file in vim or launch a program with root permissions. The problem is that when su'ed a good chunk of my programs aren't available to the super user, typing konqueror as super user just comes up with an error. As soon as I exit and return to my normal user konqueror is available.

If I type in the full command path as root such as /usr/share/kde/bin/konqueror it will run. Obviously if im properly logged in as root I don't get this problem.

It seems as if my PATH varyable changes when I su into root so it doesn't search certain directories for files.

Cheers

Last edited by BongFish; 09-20-2003 at 10:53 AM.
 
Old 09-20-2003, 12:50 PM   #5
LSD
Member
 
Registered: Jan 2003
Location: Northam, W.A., Australia
Distribution: Gentoo ~x86
Posts: 321

Rep: Reputation: 30
As you've discovered, the kernel source is a fairly basic dependency when it comes to compiling stuff yet, in a situation that can only be described as insane, the stock Slackware 9.0 CD images don't include it despite there being more than enough room for it (provided you burn it onto a 700Mb 80 minute CD-R but they're as common as muck these days). You can either download the source slackpack from a Slackware mirror and install it by hand (possibly integrating it onto a new Slack CD for later installations) or do as you've done and simply download the latest stable sources from kernel.org.

Your problem with the prompt is simple: When you start a login shell (eg a console outside of X), the system profile (/etc/profile), which sets up stuff like the default appearence of the prompt and other settings is processed ("source") as a matter of course giving you your "user@hostname" prompt. On the other hand, when you start a non-login shell (eg an xterm or a root shell accessed via the su command) it isn't leading to you "bash-2.05" prompt. The fix is quite simple: create a file in your home directory called .bashrc, make sure it's executable and containing the following command:

Code:
source /etc/profile
And the next time you start a shell, login or otherwise, you should see the standard login prompt. The command can also be entered in manually to convert any open terminals without having the close them.
 
Old 09-21-2003, 04:27 AM   #6
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
Or you can just start aterm, xterm or whatever with the -ls flag (login shell). aterm -ls will give you the user@hostwd prompt you're used to.
Do you have a good .vimrc in your /home dir? If not download one from somewhere. Vim is acting stangely probabkly because its in VI mode and other things aren't set in .vimrc.

When suing to root use su - instead of the plain su. This way you'll get all of your programs in your PATH. using normal su puts only /bin and /sbin into root's PATH.

HTH
-NSKL
 
Old 09-21-2003, 06:22 AM   #7
BongFish
Member
 
Registered: Jun 2003
Location: England
Distribution: Slack 9
Posts: 141

Original Poster
Rep: Reputation: 15
Brilliant!

I'm finding out that slack does things quite differently to other distros, incliding kernel recompile it seems. I did it normaly and just (stupidly) missed out the mkinitrd step when I saw there wasn't an initrd in /boot/, needless to say I hosed my system and it wont boot.

I'm gonna resinstall later today and recompile properly, all the info you've given me'll come in handy.
 
Old 09-21-2003, 11:54 PM   #8
Kocil
Member
 
Registered: Feb 2003
Distribution: Redhat since 5.2, Slackware since 9.0, Vector since 4.0
Posts: 209

Rep: Reputation: 31
1. When loging in as root my terminal emulators look right but when I load up a terminal emulator as a normal user they just have 'bash-2.05 #' instead of the normal user then location prompt.

Edit $HOME/.bashrc and put
export PS1=
export PS2=

You may take a look at /etc/profile and copy it from there.


2. When logged in as root I can change the look and feel of KDE using control center, when loged in as a normal user it won't let me, I can load up control center but no changed I make in it have any effect either in real time or after a reboot.

Sorry, I don't use KDE. Only Fluxbox/IceWM.
Hey, try XFCE4, very cool !


3. No bsetbg or bsetroot command, I can't find where to download it either.
Solved


4. Half my programs won't compile without the kernel source, on the file list on the CD it say's it should be in [cddir]/slackware/k/kernelsource.tar however the /slackware/k directory doesn't even exist!! All the others do, such as a, d, e, f etc but no k.

Kernel header is enough for apps compilation.
If you need full kernel source you must download it (a lot of crying ask for kernel-source on CD #1, hopefully Patrick will bless it in the next version).

5. I have my windows partitions mounted under /mnt/xp and /mnt/music but when logged in as a normal user I can't access them, what's going on?

edit /etc/fstab to something like this:

/dev/hda1 /mnt/xp vfat umask=0,gid=users 0 0

I like to add shortname=mixed,quiet also for the options.


1. How can I turn of the annoying beep every time I press something I shouldn't at the terminal, both real and emulated(ie pressing backspace when there's nothing to delete)?

I want to know too

2. VIM is playing up hugely when in an emulated terminal - I have my keyboard set up correctly in XF86Config and it works fine in other text editors but in vim the insert button does lots of ther things but insert text, nothing works right. I can put in : commands okay though.

find vimrc_example (maybe at /usr/share/vim) copy it as $HOME/.vimrc


3. (Big problem) When logged in as a normal user I often need to su in an xterm to edit a file in vim or launch a program with root permissions. The problem is that when su'ed a good chunk of my programs aren't available to the super user, typing konqueror as super user just comes up with an error. As soon as I exit and return to my normal user konqueror is available.

Does not happens to me, but you can fix the root's PATH at /root/.bashrc

Cheers
 
Old 09-22-2003, 01:41 AM   #9
boudie
LQ Newbie
 
Registered: Sep 2003
Location: nova scotia, canada
Distribution: slackware 9
Posts: 27

Rep: Reputation: 15
To get rid of "annoying beep":

setterm -blength

You can set duration with this option,
No duration=no sound.
Read setterm man page for other goodies.
 
Old 09-22-2003, 08:15 AM   #10
BongFish
Member
 
Registered: Jun 2003
Location: England
Distribution: Slack 9
Posts: 141

Original Poster
Rep: Reputation: 15
Bleep is no more.

I have slack up and running with out any 'niggly problems' now, just did my first sucessful kernel recompile to.

Thanks guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lots of problems!!! tomh500 Linux - Wireless Networking 3 10-26-2005 07:39 PM
Mandrake 10.1 lots of problems alirezan1 Linux - Newbie 7 01-03-2005 01:17 PM
Lots of problems Korff Linux - General 3 05-17-2004 07:57 PM
lots of problems.. nistelrooy Mandriva 1 10-06-2003 06:48 PM
Lots of Problems MrMuffles Linux - General 1 01-28-2003 12:01 AM


All times are GMT -5. The time now is 06:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration