LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2013, 09:02 PM   #1
pvalley_67
LQ Newbie
 
Registered: Apr 2013
Location: Portland,Maine
Posts: 2

Rep: Reputation: Disabled
Networking usb tethering modem


Fairly new to slackware and have found that I cannot use my virginmobile hotspot via usb tethering any help?
 
Old 04-30-2013, 02:48 PM   #2
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 430

Rep: Reputation: 125Reputation: 125
Are you using NetworkManager ? Under KDE/XFCE/?
 
Old 04-30-2013, 02:53 PM   #3
pvalley_67
LQ Newbie
 
Registered: Apr 2013
Location: Portland,Maine
Posts: 2

Original Poster
Rep: Reputation: Disabled
yes i have the network manager running but I cant do anything with it
 
Old 04-30-2013, 09:09 PM   #4
Erik_FL
Member
 
Registered: Sep 2005
Location: Boynton Beach, FL
Distribution: Slackware
Posts: 797

Rep: Reputation: 247Reputation: 247Reputation: 247
I got the information below from various places. I haven't tested it, since I don't have the modem or the broadband service.

You might have to switch your modem into the "serial" mode of operation. It probably defaults to the "storage" mode.

Create the file "/etc/usb_modeswitch.conf" containing the following.

Code:
DefaultVendor= 0x1410
DefaultProduct= 0x5031

TargetVendor= 0x1410
TargetProduct= 0x6002

MessageContent="5553424312345678000000000000061b000000020000000000000000000000"
Use the following commands (from a "root" shell) to switch the modem into the serial mode. You will have to do this every time that you connect the modem. You might want to add the commands to the startup scripts.

Code:
usb_modeswitch
udevadm trigger
You should now have a "/dev/ttyUSB0" device. The verify that, use this command.

Code:
ls -l /dev/ttyUSB0
Now you should be able to use the network manager to set up "/dev/ttyUSB0".

Make sure that you have set the executable permission on "/etc/rc.d/rc.networkmanager" in order for it to start.

Code:
chmod +x /etc/rc.d/rc.networkmanager
/etc/rc.d/rc.networkmanager start
In the network manager you need the following settings.

Mobile Broadband
================
Phone Number: *99#
APN: VirginBroadband
Type: Any

PPP Settings
============
Authentication: Allowed Methods: PAP
Allow BSD Data Compression: Yes
Allow Deflate Data Compression: Yes
Use TCP Header Compression: Yes

IPv4 Settings
=============
Automatic PPP
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB tethering with slackware 14 g4ry Slackware 4 01-09-2013 08:18 AM
[SOLVED] 3G USB Modem Zoom 4595 and networking riganta Linux - Networking 2 04-05-2010 08:29 AM
Blackjack tethering via USB, not recognized? (debian) screennameless Linux - Hardware 3 12-30-2009 11:13 AM
Networking with Redhat and a USB cable modem? BruceLeroy Linux - Networking 0 01-10-2002 12:48 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration