LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-04-2012, 03:13 AM   #1
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 324

Rep: Reputation: 49
network trouble


I reinstalled Slackware after some self-inflicted -current misadventures.

On my new installation I can't get the network to work. I followed AlienBob's guide but must have gone wrong somewhere, as it worked perfectly when I installed Slackware a few months ago.

Any help gratefully received - it's driving me mad! Hopefully it'll be something really obvious, but if it is, it's eluding me.

ifconfig confirms that the device wlan0 is correct.

This is on a fresh installation of Slackware64 13.37.

rc.inet1.conf

Code:
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="MyEssid"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30
wpa_supplicant.conf

Code:
# See /usr/doc/wpa_supplicant-0.7.3/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="MyEssid"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=d17756690c9487520a075cdb9c5b739377553109a63393fd45a61de22205b05c
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}
/var/log/messages

Code:
06 darkstar kernel: [  594.913670] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  4 08:41:09 darkstar logger: /etc/rc.d/rc.inet1:  /sbin/iwconfig wlan0 nick darkstar
Aug  4 08:41:09 darkstar logger: /etc/rc.d/rc.inet1:  /sbin/iwconfig wlan0 essid "any"
Aug  4 08:41:09 darkstar logger: /etc/rc.d/rc.inet1:  wpa_supplicant -B -c/etc/wpa_supplicant.conf -Dwext -iwlan0
Aug  4 08:41:10 darkstar kernel: [  598.027664] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  4 08:42:10 darkstar logger: WPA authentication did not complete, try running '/etc/rc.d/rc.inet1 wlan0_start' in a few seconds.
Aug  4 08:42:13 darkstar logger: /etc/rc.d/rc.inet1:  /sbin/dhcpcd -t 10 -h BTHub3-2WCW wlan0
Aug  4 08:42:13 darkstar dhcpcd[3290]: version 5.2.11 starting
Aug  4 08:42:13 darkstar dhcpcd[3290]: wlan0: waiting for carrier
Aug  4 08:43:01 darkstar kernel: [  709.614079] rt61pci 0000:05:01.0: PCI INT A disabled
 
Old 08-04-2012, 05:21 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hi,

this line
Code:
psk=d17756690c9487520a075cdb9c5b739377553109a63393fd45a61de22205b05c
cannot be correct. It needs to be quoted
Code:
psk="d17756690c9487520a075cdb9c5b739377553109a63393fd45a61de22205b05c"
You can use wpa_supplicant on the commandline for debugging-purposes:
Code:
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant
which is valid on most systems. The command will tell you at first when there are any syntax-errors in your wpa_supplicant.conf.
When the command is running you can use iwconfig in order to check if the connection to your AP has been established.
If you want to go further manually, you can use "dhcpcd wlan0" on the commandline in order to receive an automatical IP-configuration via DHCP.

Markus
 
1 members found this post helpful.
Old 08-04-2012, 05:59 AM   #3
Bazzaah
Member
 
Registered: Mar 2007
Distribution: Slackware64-current, Slackware64 14
Posts: 324

Original Poster
Rep: Reputation: 49
Thanks Markus, I appreciate your comments.

I do have it sorted out though - I reseated the card and it worked just fine after that, for some reason.

The wpa_supplicant.conf is correct as I'd written it though - it won't parse with quote marks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
network to network vpn trouble Hewson Linux - Networking 0 07-15-2008 06:04 PM
network trouble bloodfulldesire Linux - Networking 1 07-01-2005 11:36 AM
More Network Trouble thunderweasel Mandriva 8 04-07-2005 04:43 AM
Trouble finding network-network not available General Dude Linux - Networking 2 03-06-2004 06:43 PM
Network trouble... bripage Linux - Networking 2 03-29-2002 01:46 PM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration