LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2012, 01:58 PM   #1
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Rep: Reputation: 15
Network Interface problem: Sony Vaio VPCEG2DXF Running -13.37/x86_64 (3.2.7 kernel)


When this laptop is at a wifi hot spot and wicd is run, the eth0 interface is not brought down so all packets try using that interface without a cable. I have the problem isolated and need help in fixing the issue.

To understand the problem requires comparison with a working portable, my Dell Latitude E5410. When the Dell boots with no ethernet cable attached 'route -n' shows eth0 UP but not running with the static IP address of my office network.

When I invoke 'wicd-client -n' /var/log/messages shows:
Apr 14 09:35:36 caddis dhcpcd[3096]: version 5.2.12 starting
Apr 14 09:35:36 caddis kernel: [ 1946.368876] ADDRCONF(NETDEV_CHANGE)
: wlan0: link becomes ready
Apr 14 09:35:36 caddis dhcpcd[3096]: wlan0: broadcasting for a lease
Apr 14 09:35:36 caddis dhcpcd[3096]: wlan0: offered 10.5.70.151 from
10.5.70.1
Apr 14 09:35:36 caddis dhcpcd[3096]: wlan0: acknowledged 10.5.70.151
from 10.5.70.1
Apr 14 09:35:36 caddis dhcpcd[3096]: wlan0: checking for 10.5.70.151
Apr 14 09:35:42 caddis dhcpcd[3096]: wlan0: leased 10.5.70.151 for 14
400 seconds
Apr 14 09:35:42 caddis dhcpcd[3096]: forked to background, child pid 3127
Apr 14 09:38:36 caddis ntpd[1671]: Listen normally on 5 wlan0 10.5.70.151
UDP 123
Apr 14 09:38:36 caddis ntpd[1671]: Listen normally on 6 wlan0
fe80::223:14ff:fe68:98e0 UDP 123
Apr 14 09:38:36 caddis ntpd[1671]: Deleting interface #3 eth0,
192.168.55.2#123, interface stats: received=0, sent=0, dropped=0,
active_time=2101 secs
Apr 14 09:38:36 caddis ntpd[1671]: peers refreshed

Note that dhcpcd forks to the background and ntpd listens on wlan0 before deleting eth0.

The problem with the Sony is that ntpd is not called. After dhcpcd forks to the background, nothing happens. Both the Sony and the Dell run the same Slackware and wicd versions and the .conf files are the same. Because eth0 is still in the kernel routing table packets try to go over that interface rather than the wlan0 interface that's connected to the WAP.

What might cause the process to stop on the Sony while completing on the Dell?

Rich

Last edited by rshepard; 04-14-2012 at 02:02 PM.
 
Old 04-16-2012, 02:11 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,411

Rep: Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122Reputation: 1122
I would try "ifconfig eth0 down" and see what I come up with.

But you probably did try that already, then sorry for the noise.
 
Old 04-17-2012, 11:14 AM   #3
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
Didier,

I found this to work very early in the process of fixing the problem. It's not practical because I won't give root privileges to the user; it needs to be automated somehow, if that's possible.

More important is the question of why the Sony won't invoke ntpd to bring down eth0 after dhcpcd establishes a connection to the WAP while the Dell does. They both run the same distribution version, the same wicd version, and the only difference is the kernel (default in the Dell and 3.2.7 in the Sony to provide the ethernet driver for the newer network chip.

Thanks,

Rich
 
Old 04-18-2012, 09:35 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,313
Blog Entries: 3

Rep: Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463Reputation: 1463
Member response

Hi,

Try using;
Quote:
ifplugd <- 'ifplugd is a Linux daemon which will automatically configure your Ethernet device when a cable is plugged in and automatically un-configure it if the cable is pulled. This is useful on laptops with on-board network adapters, since it will only configure the interface when a cable is really connected. ifplugd interfaces with your distribution's native network configuration utilities.'

The above link and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 05-02-2012, 01:11 AM   #5
lazardo
Member
 
Registered: Feb 2010
Location: SF Bay Area
Posts: 100

Rep: Reputation: Disabled
I use /etc/wicd/scripts/{pre,post}* scripts.

wicd passes enough information to know if its wired or wireless.

Cheers,
 
Old 05-03-2012, 10:54 AM   #6
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
onebuck: I installed ifplugd but found it worked only when the system booted with an ethernet cable attached. Then it would bring down eth0 when the cable was removed and bring up eth0 when the cable was re-inserted. If the system booted with no attached cable eth0 came up, along with wlan0. I probably need to look more closely at man ifplug and see if I missed something critical.

lazardo: I will look at /etc/wicd/scripts/ and see how to use the pre- and post- scripts to address the issue.

Thanks, both of you. I'll post what I learn from both suggestions.

Rich
 
Old 05-04-2012, 10:11 AM   #7
lazardo
Member
 
Registered: Feb 2010
Location: SF Bay Area
Posts: 100

Rep: Reputation: Disabled
Here's how my laptop is set up

$ cat /etc/wicd/scripts/postconnect/wicd_post
Code:
#!/bin/bash
#logger -st wicd_post "params: $1 $2 "

FW=yes

# check for known networks
case "$1" in
	wireless) NETDEV=wlan0
		[ "$2" = "Lot104" ] && FW=no		# home
		[ "$2" = "2WIRE962" ] && FW=no		# office
		;;

	wired) NETDEV=eth0
                # ping and verify home gateway server                
		ping -c 2 -i .33 -w 1 192.168.1.251 > /dev/null
		if arp -n 192.168.1.251 | grep -q 00:23:69:50:4b:f3; then
			FW=no
		fi
                # Intel 6200N
		logger -st wicd_post "killing wireless"
		for i in 0 1; do sudo rfkill block $i; done
		;;

	*)
		logger -st wicd_post "network FAILED, $1, $2 "
		exit 1
esac

if [ "$FW" != "yes" ]; then
	logger -st wicd_post "no firewall for $2"
else
	sudo sh /etc/rc.d/rc.firewall start $NETDEV
	logger -st wicd_post "firewall started on $NETDEV"
fi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony Vaio running Mepis has no Fn controls for volume monty_2487 Linux - Software 6 06-19-2011 03:12 PM
Network problem Installing Debian on Sony Vaio VGN.FE21M alfred00 Linux - Laptop and Netbook 4 09-08-2006 07:35 AM
Sony Vaio sz220 kernel panic problem KNx2 Linux - Laptop and Netbook 4 08-24-2006 06:01 PM
No Sound on Sony Vaio FE11S running SUSE 10.0 Riff154 Linux - Laptop and Netbook 8 05-13-2006 12:55 PM
Network problem with Suse 10.0 on Sony Vaio laptop athv_gr Linux - Networking 5 01-20-2006 04:11 PM


All times are GMT -5. The time now is 01:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration