LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-25-2005, 04:42 PM   #1
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
Mounting DVD to a CDR/DVD combo drive


Hello
I recently made the jump from Drake10.1 to Slackware10.1. Now I have solved most of the problems, networking, scroll wheel, sound. However, i was wondering if somone could help me with this problem.

As root I can mount a cdrom in /dev/cdrom/ to /mnt/cdrom/ but i cant mount a dvd it says no median found. Now its a DVD/CDwriter Combo drive. and with other distros (FC3 and Drake10.1) It read and burned dvds with no problem... I know its probably a config file somewhere but if Anyone could help me out that would be awesome thanks.

update:

Ohh and I have a USB flash drive i want to mount too.. If anyone could help me with that too.. (BTW, the reason its kinda important is i have a lab writup thats due tomorrow on it and i have to finish it tonight its on both [newer version is on the flash card])

Last edited by f34r7h1s; 04-25-2005 at 05:00 PM.
 
Old 04-25-2005, 05:34 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
For the DVD, try: mount -t udf /dev/cdrom /mnt/cdrom
For the USB Flash card, take a look at dmesg if you can spot where it's assigned when you plug it (should be /dev/sda) and then mount it.
 
Old 04-25-2005, 06:00 PM   #3
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
USB works.. (Lab not on it )
This is the output for the DVD thing...

root@foo:/home/tperry# mount -t udf /dev/cdrom /mnt/cdrom
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
root@foo:/home/tperry#


# cat /etc/fstab

/dev/hda5 swap swap defaults 0 0
/dev/hda1 / ext2 defaults 1 1
/dev/hda6 /usr ext2 defaults 1 2
/dev/hda7 /opt ext2 defaults 1 2
/dev/hda8 /home ext2 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660,udf noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



# dmesg | grep sd

Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 492544 512-byte hdwr sectors (252 MB)
sda: Write Protect is off
sda: sda1
SCSI device sda: 492544 512-byte hdwr sectors (252 MB)
sda: Write Protect is off
sda: sda1
VFS: Can't find ext3 filesystem on dev sd(8,0).
UMSDOS: msdos_read_super failed, mount aborted.



# dmesg | greb hd


bash: greb: command not found
root@foo:/mnt# dmesg | grep hd
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
SCSI device sda: 492544 512-byte hdwr sectors (252 MB)
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
SCSI device sda: 492544 512-byte hdwr sectors (252 MB)
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:
hdb: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdb: packet command error: error=0x54
ATAPI device hdb:
ATAPI device hdb:
ATAPI device hdb:



# dmesg | grep cdrom


SJCD: Sanyo CDR-H94A cdrom driver version 1.7.
cm206 cdrom driver $Revision: 1.5 $ can't find adapter!
SJCD: Sanyo CDR-H94A cdrom driver version 1.7.
cm206 cdrom driver $Revision: 1.5 $ can't find adapter!
cdrom: open failed.
cdrom: open failed.
cdrom: open failed.
cdrom: open failed.
cdrom: open failed.
cdrom: open failed.



that is the output of some of the comands i learned today
thank you again to anyone else who responds...


Last edited by f34r7h1s; 04-25-2005 at 09:26 PM.
 
Old 04-25-2005, 11:54 PM   #4
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
for the cdrom/dvd, edit the fstab line
Code:
/dev/cdrom /mnt/cdrom iso9660,udf noauto,owner,ro 0 0
from owner to user, like this...
Code:
/dev/cdrom /mnt/cdrom iso9660,udf noauto,user,ro 0 0
reboot and by doing that it will give you access as a user....

then open a terminal, su to root and create this link:

ln -sf /dev/cdrom /dev/dvd

that should get you up and accessing your dvd


Last edited by detpenguin; 04-26-2005 at 12:01 AM.
 
Old 04-26-2005, 12:12 PM   #5
Berto
Member
 
Registered: Sep 2003
Location: Stevenson, WA, USA
Distribution: Slackware
Posts: 232

Rep: Reputation: 30
Beware! When mounting a USB drive MAKE SURE to mount it with the -t vfat option or else you'll mount it as an msdos partition and fck up your files by truncating them.
 
Old 04-26-2005, 12:44 PM   #6
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
I added this to my fstab:


/dev/sda1 /home/tperry/Desktop/Flash_Drive/ auto noauto,user,rw 0 0

and it seams to mount fine.. i did take it out and put it back into a windows acomputer (havent configured cups yet to print) and the windows
computer read the file with out problem.. I guess i dont know what trunkating is, and where would i put that command? in fstab our would i have to do it every time i mounted?


as far as the dvd thing goes. Still no luck.

I did the ln -sf /dev/cdrom /dev/dvd and it seemed to work
Changed the fstab as instructed but when i mount /dev/cdrom i get the same error and when i mount /dev/dvd it says:

mount: can't find /dev/hdb in /etc/fstab or /etc/mtab


and to to further clarify im only trying to access a data dvd, (can access a data cd) havent tried movie dvd or music cd.

thank you again
 
Old 04-26-2005, 12:51 PM   #7
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
Oh and while im talking to such smart people reall quick questions: How do i shut down? Log out of x, logout as user login as root and "Shutdown -h now" is what i have been doing. is there an easier way?
 
Old 04-26-2005, 12:57 PM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
what is the output with :
ls -l /dev/cdrom

Did you try add ide-cd in kernel parameter line in lilo.conf ?
(I know it is setting for burning but in case...)
 
Old 04-26-2005, 03:03 PM   #9
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by keefaz
what is the output with :
ls -l /dev/cdrom
# ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 2005-04-25 12:29 /dev/cdrom -> /dev/hdb


this is my lilo.conf file ... where do i put that?

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 30
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
read-only
# Linux bootable partition config ends
root@foo:/home/tperry#

Last edited by f34r7h1s; 04-26-2005 at 03:05 PM.
 
Old 04-26-2005, 03:09 PM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
I don't know well lilo but you could add :
append="hdb=ide-cd"

Just after the line "read-only" but this is for 2.6 kernels (type uname -r)
if you have a 2.4 kernel, add instead :
append="hdb=ide-scsi"

run /sbin/lilo to take the change in account
 
Old 04-26-2005, 03:28 PM   #11
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
I changed Lilo to look like this
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
read-only
append="hdb=ide-cd" <<< adding that
# Linux bootable partition config ends



so ran lilo.....
# lilo
Added Linux *
#

restarted (Im getting a message when i shut down saying something like "Inturupt handler not syncing" or something like that and it kinda hangs there (after it does the shutdown sequence ) i use " Shudown -h now" to restart... donno

this is what happens if i try to mount now
using the default kernel from slackware 10.1 (pretty sure its 2.4)

Could not mount device.
The reported error was:
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


Last edited by f34r7h1s; 04-26-2005 at 04:07 PM.
 
Old 04-26-2005, 04:44 PM   #12
ProtoformX
Member
 
Registered: Feb 2004
Location: Canada
Distribution: LFS SVN
Posts: 334

Rep: Reputation: 34
Change your fstab to read /dev/cdrom /mnt/cdrom auto noauto,user,ro 0 0

This allows mount to deside what is it is, do not do this for your USB device.
 
Old 04-26-2005, 05:05 PM   #13
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
Sorry did that and same thing ... "No Medium found" I have no clue.. I can mount cds fine...

And any reason as to why not do that for the USB? device?
 
Old 04-26-2005, 07:26 PM   #14
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
Quote:
Originally posted by f34r7h1s
Oh and while im talking to such smart people reall quick questions: How do i shut down? Log out of x, logout as user login as root and "Shutdown -h now" is what i have been doing. is there an easier way?
To shutdown the machine, su to root and do an "init 0". Do an "init 6" to reboot.
 
Old 04-26-2005, 08:12 PM   #15
f34r7h1s
Member
 
Registered: Apr 2004
Distribution: Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
Ok... Well I have tried all the steps above, reported (im pretty sure at least) all of the outcomes. Still back where I started...


Again the problem is as follows:
I can read cds, but when I try to mount dvd it says "No medium found"

Donno what else to do...
Thank you all who have helped sofar and all who will respond further
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD/CDRW Combo Drive Mounting Trouble monks_point Linux - Hardware 11 08-30-2005 12:53 PM
DVD/CDRW Combo Drive Mounting Trouble monks_point Linux - Newbie 1 08-29-2005 07:55 PM
Play DVD on CDRW/DVD Combo Drive?? halo14 Linux - Laptop and Netbook 13 09-21-2004 10:21 AM
Best external Cdr Dvd combo for linux ooagentbender Linux - Hardware 3 12-05-2003 02:10 AM
2.6 Kernel, CDR/DVD combo - need help. cnmill Fedora 9 12-02-2003 05:54 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration