LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2013, 12:19 PM   #1
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Rep: Reputation: 1
mobile broadband not connecting, networkmanager in KDE


No problem setting up, very simple config that works on other systems. #99* number, APN, no user/passwd

It connected the first time as root then nothing, did not connect as user.

Have added user to dialout. Anyway if it was permissions why does it fail as root too?
Any hints, is there some post install setup I've missed?

And how do people use mobile broadband outside KDE? I installed wvdial from a package for S13.7, it did connect but browsers said no connection.
I have had all this working for years with no problems in Debian.
 
Old 03-13-2013, 07:48 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
I have had all this working for years with no problems in Slackware.

I suggest you lose wvdial, it is not necessary. NetworkManager does what you want.
Make sure that the /etc/rc.d/rc.networkmanager is executable so that the NetworkManager daemon is started at boot.

When you configure your connection in NetworkManager, make sure that you check the "Available for all users" checkbox.

Once you have connections configured, you can use nmcli outside a GUI to control NetworkManager. You will need to be root for this.
 
2 members found this post helpful.
Old 03-14-2013, 04:19 AM   #3
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Original Poster
Rep: Reputation: 1
Thanks. The file is executable and the connection is available for all users,
but it still does not work. Worked 1 time as user in xfce, now it does not appear at all.

Well it was interesting, fast, stable and simple system. But Debian has better and easier access to software, better localization, i need norwegian. Its the only distro i know of that can get a local dict installation right. Will take the lilo.conf and fstab with me to Debian Wheezy.
 
Old 03-14-2013, 05:45 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Au revoir.
You probably messed with /etc/rc.d/rc.inet1.conf which needs to be as per the default for NetworkManager to work. Installing the wvdial package was ill-informed.
This is not a Slackware problem, but rather PEBKAC.
 
Old 03-14-2013, 09:04 AM   #5
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Original Poster
Rep: Reputation: 1
No, I have not messed with any files. I installed the day before yesterday, 1st time ever Slackware. Then I installed wvdial and deps. Then deleted the installation -I had not choosen to activate Networkmanager and did not know how to fix that, and tried Absolute, had an iso saved.
Then reinstalled from Slack 14 DVD, full install. No tampering with any setup file except to set graphical runlevel and set locale, add compact to lilo.conf. I have no time for any fiddling around now. I did not touch network setup except through kdenetwork/nm-applet setup.
But I will try Slackware on another pc I use, it's just that I have no time right now. easier to just get into next debian release, RC1 is probablt stable enough.

Last edited by coyotl; 03-14-2013 at 09:06 AM.
 
Old 03-17-2013, 08:58 AM   #6
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Original Poster
Rep: Reputation: 1
ok, I'm back.
It seems the problem was due to setting up networkmanager from KDE, as user (not sure). Anyway it works after setting it up as root from nm-applet in Xfce. lets se if it continues to work. The problem cannot possibly have anything to do with wvdial which is independent of networkmanager and a very good modem tool, good to have in reserve, networkmanager not always to be trusted.
i love this distro - it gives you such a feeling of Unix/linux nostalgia. At last a distro that may be on par with the best ever: Libranet 2.8.1, around 2003-4 ..

to se these old desktops running, nice. Now I can dig out my old Windowmaker configs and themes from backup CDs -the software I use does not change much

Slack gives me a working config out of the box with my CRT monitor, I suppose the driver is nouveau. but will get nvidia, it does not give 1280x960.

loclization not quite as in debian but have to setup first and see. I have some peculiar software requirements, local dict server f.ex, see if that can be done in slack.

conclusion so far: should have used the 32 bit version, there is no way I will ever bother to make the system 32bit compatible. I could find no other way to make keyboard map stick outside KDE than setxkbmap=no in my .profile

Last edited by coyotl; 03-17-2013 at 06:14 PM.
 
Old 03-18-2013, 03:18 AM   #7
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by allend View Post
Au revoir.
You probably messed with /etc/rc.d/rc.inet1.conf which needs to be as per the default for NetworkManager to work. Installing the wvdial package was ill-informed.
This is not a Slackware problem, but rather PEBKAC.
no, it was up your arse. It arose from setting up network with provided KDE GUI tools. I would not use a distro where modifying text files was the way to set up networking.
 
Old 03-18-2013, 07:10 AM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Gently, please - this is an open forum.
Quote:
It arose from setting up network with provided KDE GUI tools.
It is well known that the KDE network GUI tool does not support Slackware. All that is required is to configure NetworkManager using the widget provided that NetworkManager was chosen as part of the original installation.
Quote:
I would not use a distro where modifying text files was the way to set up networking.
After completing the install and logging in as root, you had a message "You have mail". Had you read your mail you would have seen
Quote:
If you will be using wireless (or even a wired interface), you might
want to let NetworkManager handle your network connections. This is
a choice during the initial installation, but may also be selected
later by rerunning netconfig, or by setting the startup script
to executable (chmod 755 /etc/rc.d/rc.networkmanager). When Network
Manager is used to handle connections, a nice interface is provided
to scan for wireless access points and make changes to the network
configuration. This interface runs automatically with KDE or Xfce.
In fluxbox, the nm-applet program will need to be launched. Other
window managers lack a system tray to display nm-applet, so for those
you might want to look at wicd in /extra, which also provides a nice
GUI tool for connecting to wireless (or wired) networks. For window
managers that do not provide a tray for running programs, start
"wicd-client" to make changes. With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
All I will add to that is that a system tray can be added to WindowMaker by installing wmsystemtray from http://www.slackbuilds.org/
Then nm-applet can also be used in WindowMaker.
 
2 members found this post helpful.
Old 03-18-2013, 05:03 PM   #9
Knightron
Senior Member
 
Registered: Jan 2011
Location: Planet Earth
Distribution: Slackware.
Posts: 1,325
Blog Entries: 7

Rep: Reputation: 157Reputation: 157
Quote:
Originally Posted by allend View Post
Once you have connections configured, you can use nmcli outside a GUI to control NetworkManager. You will need to be root for this.
Just wanted to say thanks for this; i didn't know that.
 
Old 03-18-2013, 05:58 PM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
There is a problem with nmcli in that it cannot handle WPA2 wireless connections as it cannot access the secrets required. You need to use wpa_supplicant for this.
 
1 members found this post helpful.
Old 03-23-2013, 08:56 AM   #11
rabirk
Member
 
Registered: Dec 2012
Location: Maryland, US
Distribution: Debian
Posts: 83
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
It is well known that the KDE network GUI tool does not support Slackware.
This might have been well-known to you, but it's news to me.

For those of us who did muck around with rc.d/rc.inet1.conf, is there any simple way to restore the default file? I completely re-installed Slackware this past week in hopes it would fix the issue, but I haven't gotten back into it yet to know for sure. All I wanted to do was re-install the N package but couldn't figure out how to do so. I'd run netconfig several times without it addressing my connection problems.
 
Old 03-23-2013, 09:49 AM   #12
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
For those of us who did muck around with rc.d/rc.inet1.conf, is there any simple way to restore the default file?
From the third quote in post #8
Quote:
With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback.
 
Old 03-24-2013, 04:23 PM   #13
coyotl
LQ Newbie
 
Registered: Oct 2010
Posts: 12

Original Poster
Rep: Reputation: 1
Thanks. Have to try using nm-applet in Windowmaker. That would make this distro a serious candidate for my low-powered laptop (pentium 4 1.6ghz 768mb ram)

the KDE network GUI tool makes problems in more distros than Slackware.

Wvdial should not need to mess things up, in Debian it's well integrated f.ex. But in slack it connected
but the browsers did not connect.. annoying when KDE networkmanager was playing up at the same time.
 
Old 03-24-2013, 07:38 PM   #14
ihermit
LQ Newbie
 
Registered: Jan 2013
Location: under the bridge
Distribution: Slackware 14 current
Posts: 14

Rep: Reputation: Disabled
Lose wvdail, and networkmanager both. You'll end up in a white padded room before you get them to work. From your CD/DVD if you got them look inside the /extras/ folder and install wicd with the installpkg command. If no cd or dvd just get it from slackbuilds.org In slackware14 I didn't even have to config a single thing. I did have to change my encryption on my Braodband device from wpa to wpa2. But that was it.

wicd is the way to handle network connections in slackware!
 
Old 03-24-2013, 08:26 PM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,433

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
wicd is the way to handle network connections in slackware!
Obviously you do not use a USB modem or a VPN service.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NetworkManager cannot connect to mobile broadband network via ZTE USB modem haeri Slackware 2 10-13-2012 06:09 AM
mythbuntu and Virgin Mobile Mobile broadband adapter MC 760 Tom Nichol Linux - Networking 2 10-20-2011 07:44 AM
How to connect to Internet via USB mobile broadband in slack-ware KDE sanjayagayan Linux - Newbie 1 01-25-2011 07:37 AM
mobile broadband ZTE MF627 connecting mikecahill Linux - Mobile 5 10-09-2010 04:33 PM


All times are GMT -5. The time now is 12:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration