LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2003, 07:19 PM   #1
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Mint/Debian
Posts: 447

Rep: Reputation: 32
Lilo config can't boot slack


Ok i have Mandrake and Slack 9.0 right now i can boot to mandrake from lilo. And i have to use my boot disk to get into slack. Here is my lilo config for mandrake.

map=/boot/map
vga=normal
default="Mandrake9.1"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw

image=/boot/vmlinuz
label="Mandrake9.1"
root=/dev/hda2
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image=/boot/vmlinuz
label="failsafe"
root=/dev/hda2
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdc=ide-scsi acpi=off"
read-only

other=/dev/fd0
label="floppy"
unsafe

Slack is on hda6 how could i edit lilo to boot slack if you need anything else let me know. Thanx
 
Old 07-01-2003, 07:32 PM   #2
contrasutra
Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
Add:

image = /boot/vmlinuz
root = /dev/hda6
label = Slackware
read-only

And if you have a CD burner, add this after "read-only":

append="hdx=ide-scsi" , where x = your cdburner letter (c,d)

MAKE SURE YOU TYPE: "lilo" into a console after you edit the file, or the changes won't occur.
 
Old 07-01-2003, 09:02 PM   #3
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Mint/Debian
Posts: 447

Original Poster
Rep: Reputation: 32
OK tried and got XIO: Fatal IO Error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining. Here is my slack lilo if it helps

boot=/dev/hda
prompt
timeout=50
message=/boot/message
root=/dev/hda6

image=/boot/vmlinuz
________label="vmlinuz"
________root=/dev/hda6
________read-only

image=/boot/vmlinuz-ide-2.4.20
________label="2.4.20"
________root=/dev/hda6
________read-only

image=/usr/src/linux/arch/i386/boot/bzImage
________label="Linux_Compiled"
________root=/dev/hda6
________read-only
________optional

I am further than i was though i was getting kernel panics before. Anymore help with this is greatly appreciated
 
Old 07-01-2003, 11:15 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
The problem is that in contras' approach
the fact that you have TWO /boot's, and
that Slack's one is invisible for MDK's lilo,
isn't handled...

The alternative would be to make the boot
in Slack's lilo.conf look like:

boot=/dev/hda6

and in the MDK's put the Slackware
section to be like
other = /dev/hda6
label = "Slackware"

If you have time to resize/repartition you
could have both Linux' share a distinct
/boot partition which would save you the
trouble of a dual lilo installation ;)

Cheers,
Tink
 
Old 07-02-2003, 01:05 PM   #5
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Mint/Debian
Posts: 447

Original Poster
Rep: Reputation: 32
OK Tinkster so my slack lilo will just say
boot=/dev/hda6

And my mandrake lilo should look like this
boot=/dev/hda
map=/boot/map
vga=normal
default="Mandrake9.1"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw

image="/boot/vmlinuz"
label="Mandrake_9.1"
root="/dev/hda2"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image=/boot/vmlinuz
label="failsafe"
root=/dev/hda2
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdc=ide-scsi acpi=off"
read-only

other=/dev/fd0
label="floppy"
unsafe

other=/dev/hda6
label="Slackware_9.0"

Is that right?
 
Old 07-02-2003, 01:29 PM   #6
contrasutra
Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
Woops, just realized that. Sorry.

Maybe you could ditch Mandrake?
 
Old 07-02-2003, 02:18 PM   #7
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Mint/Debian
Posts: 447

Original Poster
Rep: Reputation: 32
Mandrake has alot of nice sh** though and its easier for my wife then slack. I use slack more but she just can't understand it so she stays in Mandrake. And it took me long enough to get her use to Mandrake I'm not even going to go down that road for slack.
 
Old 07-02-2003, 02:30 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,962
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Quote:
Originally posted by Mojojo
OK Tinkster so my slack lilo will just say
boot=/dev/hda6

And my mandrake lilo should look like this
boot=/dev/hda
map=/boot/map
vga=normal
default="Mandrake9.1"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw

image="/boot/vmlinuz"
label="Mandrake_9.1"
root="/dev/hda2"
initrd="/boot/initrd.img"
append="devfs=mount hdc=ide-scsi acpi=off"
read-only

image=/boot/vmlinuz
label="failsafe"
root=/dev/hda2
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdc=ide-scsi acpi=off"
read-only

other=/dev/fd0
label="floppy"
unsafe

other=/dev/hda6
label="Slackware_9.0"

Is that right?
Almost :}

As for the slack bit you just need to
CHANGE the
boot-entry, not remove everything but it.

In other words, you're installing Slacks
lilo on slacks partition, and make MDK's
lilo point to Slacks ;)

It might be more convenient for you not to
have a second menu, though, and just
make Slacks lilo boot through to the
kernel you want?


Cheers,
Tink
 
Old 07-02-2003, 02:38 PM   #9
Mojojo
Member
 
Registered: May 2003
Location: Philadelphia/PA
Distribution: Mint/Debian
Posts: 447

Original Poster
Rep: Reputation: 32
Thank tink i post back with results
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO config for Slack 10.0 and XP Permaximus Linux - General 15 08-20-2005 10:10 PM
LILO Boot config to start up Fedora besttech01 Fedora 13 03-31-2005 07:14 PM
How to config lilo to boot from two Hard Drives. mlsbraves Linux - General 4 09-13-2004 08:16 PM
What happens if the first image in my lilo.config doesn't boot? netstv Linux - General 2 06-02-2004 02:10 AM
boot FEDORA 2 with my Slack lilo mehargags Fedora - Installation 1 04-08-2004 03:47 PM


All times are GMT -5. The time now is 06:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration