LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-13-2005, 08:10 PM   #1
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
LILO config for Slack 10.0 and XP


After searching, reading, and experimenting for a few hours this is my last hope. I have two hard drives, one with several partitions including an NTFS which has my XP install on it and another disk with my Slack install. My Linux drive is set to master and the other to slave. This is the output of fdisk -l:

Code:
bash-2.05b# fidks -l

Disk /dev/hdc: 10.1 GB, 10151286400 bytes
255 heads, 63 sectors/track, 233 cylinders
Units = cylinders of 16065 * 512 = 8225280 byes

   Device    Boot         Start                End          Blocks      Id     System
/dev/hdc1      *                1                  13        104391     83    Linux
/dev/hdc2                      14              1200      9534577+   83    Linux
/dev/hdc3                   1201             1232        257040     82    Linux Swap
 
Disk /dev/hdd: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 byes

   Device    Boot         Start                End          Blocks      Id     System
/dev/hdd1      *                1            11473    92156841      7     HPFS/NTFS
/dev/hdd2                11486          104422+     104422+   83    Linux
/dev/hdd3                19392       63504945    63504945     83    Linux 
/dev/hdd4                19393             19457       522112+     f     Linux
/dev/hdd5                 19393            19457       522112+     82  Linux Swap
So I did this little guy:
Code:
bash-2.05b#su
bash-2.05b#gedit /etc/lilo.conf
This is what my lilo.conf looks like:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hdc
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdc2
label = Linux
read-only
# Linux bootable partition config ends
#
#
## WinXP bootable partition config begins
other = /dev/hdd1
label = XP
table = /dev/hdd
# WinXP bootable partition config ends


Then I ran
Code:
bash-2.05b# /sbin/lilo
Added Linux *
Added XP
This is where I am stuck. When I select XP when lilo boots it won't do anything, it just hangs after it says, "booting XP" or whatever it says.

I greatly appreciate your help and am glad to provide anymore information if needed. Thanks again.

Last edited by Permaximus; 08-13-2005 at 08:36 PM.
 
Old 08-14-2005, 01:33 AM   #2
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Quote:
Device Boot Start End Blocks Id System
/dev/hdd4 19393 19457 522112+ f Linux
/dev/hdd5 19393 19457 522112+ 82 Linux Swap
I find it interesting that hdd4 and hdd5 appear to occupy the same physical space.
 
Old 08-14-2005, 02:18 AM   #3
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,275

Rep: Reputation: 61
Both /dev/hdc1 and /dev/hdd1 are set as boot partitions, i think that might be your problem, you canonly have one boot partition. Did you install windows first before installing linux?
 
Old 08-14-2005, 08:34 AM   #4
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Charred
I find it interesting that hdd4 and hdd5 appear to occupy the same physical space.

What's interesting about that is that that isn't a typo, that is the actual print out from fdisk -l.

Quote:
Originally posted by fotoguy
Both /dev/hdc1 and /dev/hdd1 are set as boot partitions, i think that might be your problem, you canonly have one boot partition. Did you install windows first before installing linux?
They are on different hard drives, they dont have the same MBR. I wouldn't think that would matter. Doesn't LILO just select which disk to boot, then it would load up the NT loader?

Thanks for the quick replies.
 
Old 08-14-2005, 09:16 AM   #5
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Slack 10.2, Slack 12, Suse 10.0, DSL 2.2, Xubuntu 7.04
Posts: 920

Rep: Reputation: 30
No - he means that the boot partition is what the system looks at when it's looking for a bootloader. Set the boot partition to be the one that lilo -your bootloader- is on, and don't worry about having the windows partition be bootable. It doesn't need to be (as lilo tells windows "boot now plskthx!").
 
Old 08-14-2005, 01:25 PM   #6
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
I guess I don't understand. It is booting LILO. LILO comes up fine, it will boot Slack fine, and it gives me the option to boot XP but won't do it. So all I need to do is erase whatever is on the boot partition of my windows drive?
 
Old 08-14-2005, 02:02 PM   #7
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Toggle the "Bootable" option of your Windoze partition to "OFF"
 
Old 08-14-2005, 02:12 PM   #8
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Charred
Toggle the "Bootable" option of your Windoze partition to "OFF"
How?
 
Old 08-14-2005, 05:27 PM   #9
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,275

Rep: Reputation: 61
Quote:
Originally posted by Permaximus
What's interesting about that is that that isn't a typo, that is the actual print out from fdisk -l.



They are on different hard drives, they dont have the same MBR. I wouldn't think that would matter. Doesn't LILO just select which disk to boot, then it would load up the NT loader?

Thanks for the quick replies.
Maybe it doesn't make a difference, I have only dual-booted a single drive never 2 drives so I'm problably wrong. It may just be a corrupted MBR on the windows drive, just repair the bootloader for windows.

Insert your windows cd, boot up to the screen it will ask if you would like to install windows or repair an installation, just press the 'r' key and then it will take you to a command prompt, you may also need to enter the administrators password. Theres 2 commands you can use:

fixboot
fixmbr

It has been a while since I have done these so I not sure which one will work, hope this will help.
 
Old 08-14-2005, 06:04 PM   #10
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
The boot option is irrelevant if you have a BIOS that you can change the boot options. If you set your BIOS to start from the Primary Master HD then that is the boot partition it will find. Conversely if you set the BIOS to Secondary Master, then that is the boot partition. I have had 4 HD's all with boot partitions running Xp, FreeBSD and various Linux distro's.

Although I use Slackware, and it's default boot loader is LILO, I admit I don't use it and never have. I use GRUB, and here is my setup

Code:
root@slacker:~# fdisk -l

Disk /dev/hda: 41.1 GB, 41110142976 bytes
16 heads, 63 sectors/track, 79656 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         194       97744+  83  Linux
/dev/hda2             195       23468    11730096    5  Extended
/dev/hda3           23469       42844     9765504   83  Linux
/dev/hda4           42845       79656    18553248   83  Linux
/dev/hda5             195        1186      499936+  83  Linux
/dev/hda6            1187        3124      976720+  83  Linux
/dev/hda7            3125        4116      499936+  83  Linux
/dev/hda8            4117       11866     3905968+  83  Linux
/dev/hda9           11867       23468     5847376+  83  Linux

Disk /dev/hdb: 40.0 GB, 40020664320 bytes
16 heads, 63 sectors/track, 77545 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1         192       96358+  83  Linux
/dev/hdb2             192       20544    10257502+   5  Extended
/dev/hdb3           20544       39924     9767520   83  Linux
/dev/hdb4           39924       77545    18961267+  a5  FreeBSD
/dev/hdb5             192        1164      489951   83  Linux
/dev/hdb6            1164        2136      489951   82  Linux swap
/dev/hdb7            2136        3108      489951   83  Linux
/dev/hdb8            3108        8925     2931831   83  Linux
/dev/hdb9            8926       20544     5855661   83  Linux

Disk /dev/hdd: 80.0 GB, 80026361856 bytes
16 heads, 63 sectors/track, 155061 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdd1   *           1       30218    15229588+   7  HPFS/NTFS
/dev/hdd2           30231      155061    62914824   83  Linux
In order to boot the Xp partition you need to map it. It kind of fools windows into believing it is installed on the first hard drive. I think Windows has some sort of complex about not being first. If it is not first then it is a loser.......... however I digress.


Here is my GRUB menu.1st entry
Code:
# (0) Slackware 10.1
title Slackware Current 
root	(hd0,0)
kernel	(hd0,0)/vmlinuz vga=0x317 root=/dev/hda5 devfs=nomount ro splash=verbose
initrd	(hd0,0)/initrd-dolphin

# (1) Slackware 10.1
title Slackware Current old
root	(hd0,0)
kernel	(hd0,0)/vmlinuz-2.6.12-2-ev4 vga=0x317 root=/dev/hda5 devfs=nomount ro splash=verbose
initrd	(hd0,0)/initrd-dolphin

# (2) PC-BSD
title PCBSD 0.7.8 (BETA)
root (hd1,3,a)
kernel /boot/loader
boot 

# (5) Vector Linux
title	Vector Linux
root	(hd1,0)
kernel	(hd1,0)/vmlinuz-2.6.12-2-ev1 root=/dev/hdb5 ro devfs=nomount vga=0x317 splash=silent
initrd	(hd1,0)/initrd


# (6) Microsoft Windows(TM) 
title  Win XP 
root (hd2,0)
map (hd0) (hd2)
map (hd2) (hd0) 
makeactive
chainloader +1
This may somehow apply to LILO - Hope it helps!
 
Old 08-15-2005, 10:35 AM   #11
lunarcloud_88
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 74

Rep: Reputation: 15
anyone know how to do this in lilo?
 
Old 08-15-2005, 09:38 PM   #12
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by fotoguy
Maybe it doesn't make a difference, I have only dual-booted a single drive never 2 drives so I'm problably wrong. It may just be a corrupted MBR on the windows drive, just repair the bootloader for windows.

Insert your windows cd, boot up to the screen it will ask if you would like to install windows or repair an installation, just press the 'r' key and then it will take you to a command prompt, you may also need to enter the administrators password. Theres 2 commands you can use:

fixboot
fixmbr

It has been a while since I have done these so I not sure which one will work, hope this will help.
Windows boots fine though, so I doubt that it is the Windows bootloader.

Thanks aikidoist72, I used to use Grub back in my Red Hatting days. I might just have to switch if I cannot get this figured out. Dang Windows, gives me trouble even when it is working perfectly.

Last edited by Permaximus; 08-20-2005 at 09:44 AM.
 
Old 08-15-2005, 10:03 PM   #13
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
Hi Permaximus,

No problemo! Based on your fdisk -l output you will probably need to enter this
Code:
# (6) Microsoft Windows(TM) 
title  Win XP 
root (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0) 
makeactive
chainloader +1
Also, as it may have been a while
Code:
grub> root (hd0,1)
grub> setup (hd0)
grub> quit
And if your into a nice splash screen for grub - quit how-to

http://ruslug.rutgers.edu/~mcgrof/grub-images/

Cheers
 
Old 08-19-2005, 08:22 PM   #14
Permaximus
Member
 
Registered: Sep 2004
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
I am not using grub
 
Old 08-20-2005, 08:31 PM   #15
lunarcloud_88
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 74

Rep: Reputation: 15
nor am i.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO Config tdking19 Linux - General 1 05-27-2005 09:42 PM
Lilo config can't boot slack Mojojo Slackware 8 07-02-2003 02:38 PM
LILO / lilo.conf - can't change the config clearh20 Linux - Newbie 14 06-05-2003 09:20 PM
RH 7.2 - Lilo Config wyvis Linux - Distributions 3 05-01-2002 08:24 AM
lilo config doodah Linux - Software 3 05-05-2001 12:43 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration