LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2005, 04:05 PM   #1
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Rep: Reputation: 15
KHz VS. Hz


I'm installing my ATI drivers, but on startx nothing happends, normally when this happends it means i set the h-sync and v-sync wrong, but on this page it has the vertical and horizontle sync info.

But i norticed that one says KHz and the other says Hz. In my xorg.conf how can i make x distiguish that one is ?KHz and the oither is Hz?

Thanks
 
Old 05-25-2005, 04:14 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
The computer distinguishes this by itself Pretty neat.
 
Old 05-25-2005, 04:28 PM   #3
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
then why isnt it working on any resolution?
 
Old 05-25-2005, 04:50 PM   #4
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
Re: KHz VS. Hz

Quote:
Originally posted by c_olin3404
I'm installing my ATI drivers, but on startx nothing happends, normally when this happends it means i set the h-sync and v-sync wrong,

Thanks
i guess you already have the ATI drivers installed and it doesn't work.
first thing to do would be a forum search on this forum.
( a lot of threads & a few howtos )

search for " ATI 9600 " ( if you've got a 9600 for instance ).
i bet there's a lot of usefull info....

btw: what ATI card have you got... ?

egag
 
Old 05-25-2005, 05:15 PM   #5
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
9600... lol

But the drivers worked perfectly on my last Slackware install :\
 
Old 05-25-2005, 05:31 PM   #6
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
do you use/still have your old xorg.conf file ?
would be handy.

i don't use the ati drivers. ( i tried with no luck, but it's an old card )
but i don't remember it giving a black screen.

maybe take a look at your logfile ( /var/lag/Xorg.0.log ), to see what's going on.

egag
 
Old 05-26-2005, 12:02 AM   #7
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
Code:
Fatal Server Error:
failed to intialize core devices

in Xorg.0.log.... what does that mean? how can i fix it?
 
Old 05-26-2005, 11:33 AM   #8
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
I'll try to post the ful log when i get home, because was i read it i find some other strange warnings...
 
Old 05-26-2005, 01:14 PM   #9
BenneJezzerette
Member
 
Registered: Mar 2005
Location: In a Box where Slackware Rocks
Distribution: Slackware 11 -current
Posts: 274

Rep: Reputation: 30
Quote:
Originally posted by c_olin3404
I'll try to post the ful log when i get home, because was i read it i find some other strange warnings...
wanders in and sees ....... ouch!! hey who turned out the lights!!???

try this.....xorgsetup and let it auto configure the Video, then try using your display cards drivers. One thing I did for my nVidia card, I tested several of the settings, and one is Hardware Rendering, it crashes the Xwindow and will not let it load. check your xorg.conf and see if that is also enabled,

will look something like this

Option "something" #[<boolean>]
#Option "Anotehrsomething #[<i>]
#Option "her to go" #[<Boolean>]

this is only the format of how it will look, after you use xorgsetup.

the # before the Option disables it. The 3rd column is the actual settings.

Boolean - True or False on or Off yes or now.
i = Integer or a number from 0 to F, yes HEX format 0xF and so on

Once you have tweaked your xorg.conf be sure that you understand it. use man xorg.conf and read it.

Then you should have your XDesktop
 
Old 05-26-2005, 09:00 PM   #10
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Original Poster
Rep: Reputation: 15
i read the log carefully and i found that i had to change /dev/input/mice to /dev/mouse... i guess the mouse is a "Core pointer" I'll remember that... lol

Thanks for then help
 
Old 05-27-2005, 02:14 AM   #11
BenneJezzerette
Member
 
Registered: Mar 2005
Location: In a Box where Slackware Rocks
Distribution: Slackware 11 -current
Posts: 274

Rep: Reputation: 30
Quote:
Originally posted by c_olin3404
i read the log carefully and i found that i had to change /dev/input/mice to /dev/mouse... i guess the mouse is a "Core pointer" I'll remember that... lol

Thanks for then help
so you looked at man xorg.conf and found your problem, good for you, now you can get to your desktop and wenjoy all the benefits of Linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC97 Khz lock Raziel Linux - Newbie 0 07-25-2003 10:24 PM


All times are GMT -5. The time now is 10:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration