LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2013, 01:59 PM   #1
captkrill
Member
 
Registered: Mar 2009
Location: Texas
Distribution: Slack64 14.1 + Win7 x64
Posts: 62

Rep: Reputation: 18
Kernel panics on boot


Hello again...

I am not having much luck getting Slack64 installed on this rig.

Previous issues of dual booting Win7 x64 + Slack64 14.0 on two SSD's was resolved after preventing M$ from creating the "System Reserved" partition installing W7.

Now I am getting Kernel Panics when trying to boot into Slack.

Code:
Kernel Panic - not syncing: No init found
Pid: 1, comm: swapper/0 Not tainted 3.2.29 #2\
Call Trace:
[<ffffffff81b1b1da>] panic+0x91/0x189 [<ffffffff81b19960>] init_post+0xc0/0xc0 [<ffffffff82103ccb>] kernel_init+0x150/0x150 [<ffffffff81b310b4>] kernel_thread_helper+0x4/0x10 [<ffffffff82103b7b>] ? start_kernel+0x390/0x390 [<ffffffff81b310b0>] ? gs_change+0xb/0xb
My system specs are in my signature. The motherboard I have is not a new board perse. It is a couple years old. Any suggestions?

I have tried reinstalling Slack64 in hopes that it was possibly a bad install. No dice.
 
Old 02-15-2013, 02:20 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,412

Rep: Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123
It would certainly help to know a little more about your disks' layout and lilo's configuration file.

So please use your installation media to boot into Linux as told in the greeting screen, then provide output of following commands:
Code:
uname -a
cat /etc/fstab
cat /etc/lilo.conf
(for the latter, you could append it to your next post as well).

Also, if you use a generic kernel, did you make an initrd and edited lilo.conf accordingly before (re)running lilo?

Last edited by Didier Spaier; 02-15-2013 at 02:24 PM.
 
Old 02-15-2013, 06:06 PM   #3
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,048

Rep: Reputation: 170Reputation: 170
I've found that recent kernels identify hdd's, external hdd's, usb's, sdd's (and whatever else you may have "plugged-in") differently with each boot.

Hence, when you first installed Slackware64, your boot hdd may have been /dev/sdb, yet on a reboot, it's /dev/sdc, or /sdf...basically, one can't be sure what /dev/sdx your boot partition may be (this also affects your fstab.)

To expound somewhat on what Didier has suggested, the solution is to use /dev/disk/by-(label/uuid) in both your lilo.conf and fstab, in conjunction with an initrd.

Bear in mind that I'm no expert, so my experience may be anecdotal....

cheers,

Last edited by mrclisdue; 02-15-2013 at 06:08 PM.
 
Old 02-15-2013, 07:11 PM   #4
captkrill
Member
 
Registered: Mar 2009
Location: Texas
Distribution: Slack64 14.1 + Win7 x64
Posts: 62

Original Poster
Rep: Reputation: 18
Didier, I will try and provide as much information as requested.

Code:
root@Slack64:~# uname -a
Linux Slack64 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT x86_64 Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz GenuineIntel GNU/Linux
root@Slack64:~# cat /etc/fstab
/dev/sde2     swap         swap      defaults       0   0
/dev/sde1     /            jfs       defaults       1   1
#/dev/cdrom   /mnt/cdrom   auto      noauto,owner,ro,comment=xgvfs-show 0   0
/dev/fd0      /mnt/floppy  auto      noauto,owner   0   0
devpts        /dev/pts     devpts    gid=5,mode=620 0   0
proc          /proc        proc      defaults       0   0
tmpfs         /dev/shm     tmpfs     defaults       0   0
Below is cliffnotes Lilo.conf

Code:
#LILO configuration file
#
append=" vt.default_utf8=0"
boot=/dev/sda
#
bitmap = /boot/slack.bmp
#
bmp-colors = 255,0,255,0,255,0
#
bmp-table = 60,6,1,16
#
bmp-timer = 65,27,0,255
#
prompt
#
timeout=1200
#
change-rules
reset
#
vga = normal
#
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# End
# Linux bootable partition config beings
image = /boot/vmlinuz
root = /dev/sde1
label = Linux
read-only
# End
Also, I did not make an initrd, & did not see any reason to edit lilo. This is my first dual boot of Slack coming from Debian "lenny". So I am in layman's terms a noob.

Last edited by captkrill; 02-15-2013 at 07:15 PM.
 
1 members found this post helpful.
Old 02-15-2013, 10:37 PM   #5
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Your vmlinuz might be pointing to the generic kernel.

Edit your lilo.conf file as follows just to be sure:
image = /boot/vmlinuz-huge-3.2.29
 
Old 02-16-2013, 12:54 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,412

Rep: Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123
I really don't know why you prevented Windows 7 to create a system partition, this doesn't hurt. For instance, in /etc/lilo.conf I have
Code:
/dev/sda2        /windows         ntfs-3g     fmask=133,dmask=022 1   0
so that I can see Windows from Linux, but in lilo.conf I have :
Code:
# Windows bootable partition config begins
other = /dev/sda1
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends
So I can boot Windows from its system partition.

In any case I would boot Linux from the Linux root partition, not from the MBR. To do that, just replace in your /etc/lilo.conf
Code:
boot=/dev/sda
with
Code:
boot=/dev/sde1
and make /dev/sde1 bootable with fdisk or cfdisk. Then run 'lilo -t -v' and if all goes well 'lilo'.

Or, run 'liloconfig' as root in the 'expert' mode. Of course then do not choose the 'Recycle' option, but 'Begin' then 'Linux' then 'Windows' then 'Install' and, when asked, choose to put LILO in your Linux root partition. Still, you will have to make that partition bootable with fdisk or cfdisk.

Also please, provide output of
Code:
ls -l /boot/vmlinuz
to make sure which kernel you are trying to boot.
 
Old 02-16-2013, 01:21 AM   #7
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by Didier Spaier View Post
I really don't know why you prevented Windows 7 to create a system partition, this doesn't hurt.
I also prevented windows (XP) to create a system partition. I don't trust window$ to play nice when it has been violated by linux. If I ever need to access the windows partition from linux I can always mount it (ro) myself.
 
1 members found this post helpful.
Old 02-16-2013, 01:53 AM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,412

Rep: Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123
In my understanding, this has nothing to do with that. You can let Windows have its own system partition and never access it from Linux (or only read only, choosing or not to put a line in /etc/fstab for that. If it detects a Windows partition, Slackware's installer asks what you want to do with that. You will answer 'nothing' for the system partition and either 'nothing' or 'I want to be able to access it from Linux' for the other. In the latter case the installer asks you how it should set the permissions in /etc/fstab.)

Besides that, would I think Windows be that dangerous for Linux, I would simply wipe it out completely.

Anyhow I realize that we are not addressing captkrill's question with that discussion, so let's go back to the topic.

Last edited by Didier Spaier; 02-16-2013 at 01:57 AM.
 
Old 02-16-2013, 02:36 AM   #9
nick_th_fury
Member
 
Registered: Jun 2003
Location: Texas
Distribution: Slackware, NetBSD
Posts: 151

Rep: Reputation: 23
Seems to me the windows is a non issue at this point. Considering lilo is functioning correctly and he can pick either windows or Slack. Windows boots but the Slack kernel panics. His motherboard is listed as MB: ASUS P8Z68-V Pro.

Does anyone know if vmlinuz-huge-3.2.29 has full support for this board? Or perhaps he needs to build a newer kernel?
 
Old 02-16-2013, 03:09 AM   #10
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
It might be difficult to build a new kernel if captkrill can't boot into linux (and a bit ambitious to boot). Assuming that captkrill is correctly loading the huge kernel and getting nowhere, an alternative might be to download the 3.7.1 kernel from Slackware Current and try that instead.
 
1 members found this post helpful.
Old 02-16-2013, 04:29 AM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,412

Rep: Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123Reputation: 1123
Quote:
Originally Posted by psionl0 View Post
Assuming that captkrill is correctly loading the huge kernel and getting nowhere, an alternative might be to download the 3.7.1 kernel from Slackware Current and try that instead.
I agree. Googling "ASUS P8Z68-V Pro linux kernel" returns a bunch of bad experiences, but some say that a bug was fixed using a recent kernel.

EDIT. No, don't reuse the kernel from Slackware-current as is. If you want to try that kernel, you will have to compile it yourself, see post #13.

Last edited by Didier Spaier; 02-16-2013 at 03:50 PM. Reason: EDIT added
 
Old 02-16-2013, 01:25 PM   #12
comet.berkeley
Member
 
Registered: Dec 2009
Location: California
Distribution: Slackware current
Posts: 152

Rep: Reputation: Disabled
The first error message is key and it looks like the kernel cannot find the root file system.

It cannot find the init file.

Quote:
Originally Posted by captkrill View Post
Kernel Panic - not syncing: No init found]
Since you are using the jfs filesystem, there is probably no support for it in the stripped down generic kernel.

I agree with psionl0 in using the huge kernel:

Quote:
Originally Posted by psionl0 View Post
Your vmlinuz might be pointing to the generic kernel.

Edit your lilo.conf file as follows just to be sure:
image = /boot/vmlinuz-huge-3.2.29
 
1 members found this post helpful.
Old 02-16-2013, 03:17 PM   #13
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.0
Posts: 584
Blog Entries: 2

Rep: Reputation: 76
Quote:
Originally Posted by psionl0 View Post
. . . . an alternative might be to download the 3.7.1 kernel from Slackware Current and try that instead.
Scratch that piece of advice.

Alien Bob has explained why that is a bad idea in another thread. You can download the source by all means but you will need to compile it yourself.
 
1 members found this post helpful.
Old 02-16-2013, 03:32 PM   #14
captkrill
Member
 
Registered: Mar 2009
Location: Texas
Distribution: Slack64 14.1 + Win7 x64
Posts: 62

Original Poster
Rep: Reputation: 18
Ok I will try and change booting to the huge kernel.

In the meantime, as I am away from my home PC. Is there anywhere I can download a stable slack-current ISO just to have that as a possible fix if changing the boot does not work?

Also, would building a slack64 ISO with kernel 3.7.8 be a possible solution as well?

PS.

Just to give some insight on my installation method.

The reason that I prevented Windows from creating the system reserved partition is because it was the only way that my current set up dual boot with dual drives would boot lilo, a non working slack and windows. Without doing so, no matter the install method, Lilo would not load and thus not be able to get into windows or a non-working Slack.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panics on boot with Ubuntu 11.04 and 11.10 on HP Touchsmart TX2 Ian_Hawdon Linux - Laptop and Netbook 8 01-03-2012 01:43 PM
Fedora 9, PAE kernel panics on boot NX-01 Fedora 1 09-13-2008 01:29 AM
Can't boot!! Kernel Panics!! Two machines, several versions!!! WHAT AM I DOING WRONG? Czar420 Linux - Newbie 11 05-18-2007 01:03 PM
RHEL4 kernel 2.6.9-42.0.3.EL panics on boot jcliburn Red Hat 1 11-17-2006 10:28 AM
Boot problems: repairing file systems and kernel panics BWebb Linux - General 6 09-30-2004 11:45 AM


All times are GMT -5. The time now is 05:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration