LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-19-2010, 05:23 AM   #1
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Rep: Reputation: 34
KDE takes longer and longer to load


I experience this since kde 4, but it never really was that bad because once in a while on updating kde I also deleted the .kde folder in my home-folder and everything was fast again.

But I haven't done this for a while now and kde take really long to load.
Is there any folder to clean up there without deleting the whole .kde-folder and loosing all my settings again?

Thanks in advance and best regards
 
Old 09-19-2010, 08:05 AM   #2
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Try disabling Strigi and Nepomuk in sytemsettings. Or at least check to see how much of your hard drive you are trying to index.
 
Old 09-20-2010, 05:54 AM   #3
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 34
It is only indexing my /home-folder.
Anyway,it is enabled from the beginning when I set up my profile, so I don't think it should be the reason why kde takes longer the older it is?

It is a kind of windows-like behaviour which kde 3.x didn't show....
 
Old 09-20-2010, 04:48 PM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,634

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
the indexing process took so many CPU resources. That's why your system becomes slower and slower
 
Old 09-20-2010, 07:48 PM   #5
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by vbisis View Post
It is only indexing my /home-folder.
Anyway,it is enabled from the beginning when I set up my profile, so I don't think it should be the reason why kde takes longer the older it is?

It is a kind of windows-like behaviour which kde 3.x didn't show....
No, it shouldn't be indexing in this case. Try checking your .xsession-errors to see if it is getting filled up. Also you could have problems if your /home or /tmp partitions fill up.
 
Old 09-21-2010, 02:23 AM   #6
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by willysr View Post
the indexing process took so many CPU resources. That's why your system becomes slower and slower
Can't be that, PC is a real desktop computer and is rebootet at least once a day. Anyway problem occurs on startup ( the kde-splash screen with the 5 icons - they all appear and then it just takes awful long )


Quote:
Originally Posted by brixtoncalling
No, it shouldn't be indexing in this case. Try checking your .xsession-errors to see if it is getting filled up. Also you could have problems if your /home or /tmp partitions fill up.
I tried cleaning up both ( well /tmp was quite full, but it were actuelly some sbopkg-builds just forgotten there ) and tried again, unfortunately it didn't help.
 
Old 09-21-2010, 02:56 AM   #7
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Hmmm really not sure. Perhaps it is an X problem. Does Xfce also load in a reasonable time? You could look in /var/log/Xorg.0.log or another log.
 
Old 09-21-2010, 09:54 AM   #8
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,634

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
Quote:
Originally Posted by vbisis View Post
Can't be that, PC is a real desktop computer and is rebootet at least once a day. Anyway problem occurs on startup ( the kde-splash screen with the 5 icons - they all appear and then it just takes awful long )
Probably because it wasn't finished when you restarted or turned off your computer, so the process will be resumed again. The initial indexing does take some time to complete depending on your disk space
 
Old 09-21-2010, 10:36 AM   #9
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by willysr View Post
Probably because it wasn't finished when you restarted or turned off your computer, so the process will be resumed again. The initial indexing does take some time to complete depending on your disk space
I don't think it is indexing because the slowdown occurs before he gets to the KDE desktop (after the 5 icons appear). Strigi starts after the desktop is running.
 
Old 09-22-2010, 05:46 AM   #10
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 34
The problem just gets worse. when I delete my .kde-folder and start with a completely new KDE-desktop everything is fine, kde starts fast within maybe a second or so.
By now, my desktop is setup for about 2 months in takes about half a minute to start kde.
Well deleting my profile and setting up my desktop from the start is a solution just not a good one

I ran into this problem on two different pcs by now, so I just thought it might be a kind of common problem.
 
Old 09-22-2010, 07:12 AM   #11
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
When you log in, try going to a terminal and run top to see what is slowing you down. Also check your .xsession-errors to see if something is there.
 
Old 09-28-2010, 09:53 AM   #12
cosminadrianpopescu
LQ Newbie
 
Registered: Sep 2010
Posts: 8

Rep: Reputation: 0
The problem is in the ~/.kde/share/config/plasma-desktop-appletsrc file. This file is loading at the KDE start automatically (it contains all the widgets from the desktop). The problem with it is that it also contains all the history of what you did on your desktop and it gets bigger and bigger. But unfortunately it contains what you have now on the desktop. So you cannot just delete it. You have to edit it and remove all the garbage (the previous widgets, that you don't have on your desktop anymore).

Cosmin.
 
Old 09-30-2010, 07:44 AM   #13
vbisis
Member
 
Registered: Dec 2005
Distribution: Slackware
Posts: 250

Original Poster
Rep: Reputation: 34
@brisxtoncalling: there is nothing special in .xsession-errors and the file isn't really big.

@cosmin: Didn't really do the trick, but I think the trouble is in this folder. Maybe it is relevant to say, that I start with a "previous saved session".

Finally I deleted the whole .kde-folder and reconfigured my desktop. Now I have backed up the folder to restore this point when kde is loading slow again and maybe have a closer look at the files and how they have change since configuring the desktop.
Thanks a lot you all!
 
Old 09-30-2010, 10:44 AM   #14
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
I don't really use many widgets (just the normal ones on the taskbar) so perhaps this is why I've not experienced this problem. Good luck -- and let us know if you find a solution.
 
Old 10-01-2010, 05:10 AM   #15
cosminadrianpopescu
LQ Newbie
 
Registered: Sep 2010
Posts: 8

Rep: Reputation: 0
It's not a question of how many widgets. That file keeps the history of all the widgets. Meaning that if you took one widget from one place to another place on the desktop, that file grows bigger. Or if you modify a text on a widget, that file grows bigger. Or if just added an widget, didn't liked it and then deleted it, that file grows bigger. And so on. Anything you do on your desktop, that file grows bigger.

From my point of view, this is a major bug in KDE desktop.

Try the following and you will see that I am right: rename your .kde folder (let's say into .kde.old), log out, log in again. You will notice that your kde starts again very fast. Then copy the ~/.kde.old/share/config/plasma-desktop-appletsrc into ~/.kde/share/config/plasma-desktop-appletsrc. Now log out, and log in again. You will notice that again your kde will take forever to start.

That file is your problem.

Cosmin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS SVN takes a lot longer then it should David2010 Linux From Scratch 1 08-18-2009 03:46 PM
Benchmarking a tape drive, time to copy takes forever, time to append takes longer? jeriryan Linux - Hardware 2 06-15-2008 01:15 AM
LXer: Firefox Buggier, But IE Takes 9 Times Longer to Patch LXer Syndicated Linux News 0 09-26-2006 10:21 PM
what takes longer? system() or connect() (C/C++) Thinking Programming 6 03-03-2006 10:54 PM
java applet takes longer 2 download? Troubled Linux - Newbie 1 04-29-2005 11:07 AM


All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration