LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-23-2009, 07:16 PM   #1
Allamgir
Member
 
Registered: Aug 2009
Posts: 50

Rep: Reputation: 17
Question Is there any way to get conky to only output to console (no X window)?


I installed the conky package with sbopkg, but I would not like to have its own window. I am trying to figure out a way to get the ~/.conkyrc to command conky to only output as a one-liner to the console so I can pipe that information to my dwm status bar. I've done this before on Arch Linux, but I was using conky-cli. It was a long time ago, so I don't have any of my configuration files backed up for reference. These options in my conkyrc don't work:

Code:
background no
no_buffers yes
out_to_console yes
update_interval 1
uppercase no
use_spacer none
total_run_times 0

TEXT
${time %a %b %d %I:%M%P}
I still get a small window on my desktop showing the time. How can I prevent this so I only get the output in my terminal window when I run conky?
 
Old 12-23-2009, 07:37 PM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Try:
Quote:
double_buffer yes
own_window yes
own_window_type override
own_window_transparent yes
 
Old 12-24-2009, 08:36 AM   #3
Allamgir
Member
 
Registered: Aug 2009
Posts: 50

Original Poster
Rep: Reputation: 17
I haven't been on my Slack box yet, but don't those lines just make the window transparent instead of preventing it from appearing? I guess I'm OK with that since it doesn't really make any visual difference. Hopefully I'll still be able to pipe that to a text status bar.
 
Old 12-24-2009, 09:04 AM   #4
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
I must have misunderstood your requirement as I only read:
Quote:
I still get a small window on my desktop showing the time. How can I prevent this
hmm well there is an out_to_console and out_to_x

Quote:
out_to_x
When set to no, there will be no output in X (useful when you also use things like out_to_console). If you set it to no, make sure that it's placed before all other X-related setting (take the first line of your configfile to be sure). Default value is yes
 
Old 12-24-2009, 10:20 AM   #5
Allamgir
Member
 
Registered: Aug 2009
Posts: 50

Original Poster
Rep: Reputation: 17
Well this is what I've got in my .conkyrc so far:

Code:
  1 out_to_x no   
  2 background no 
  3 no_buffers yes
  4 out_to_console yes
  5 double_buffer yes
  6 own_window yes                                                                             
  7 own_window_type override
  8 own_window_transparent yes
  9 update_interval 1 
 10 uppercase no  
 11 use_spacer none
 12 total_run_times 0
 13               
 14 TEXT          
 15 ${time %a %b %d %I:%M%P}
(The line numbers are just a result of my vim settings)

and I still get this little window near the bottom right of my screen displaying the date. It does appear in the terminal window, though. Here is the message that's displayed when I run conky in the terminal:

Code:
Conky: /home/agi/.conkyrc: 1: no such configuration: 'out_to_x'
Conky: desktop window (11b) is root window
Conky: drawing to desktop window
Conky: drawing to double buffer
I've been playing with some of these settings, like setting out_to_x to no and own_window to no, but nothing was changed.

I don't know why it's not recognizing 'out_to_x' (see the first line of the output), but that seems to be the command I need.

Last edited by Allamgir; 12-24-2009 at 12:07 PM.
 
Old 12-24-2009, 12:19 PM   #6
Allamgir
Member
 
Registered: Aug 2009
Posts: 50

Original Poster
Rep: Reputation: 17
Yes!!! I got it! All I had to do was go into sbopkg and edit the slackbuild to disable all the X-related options (I think you can just pass options with sbopkg too)

Anyway, edit the slackbuild or pass the following options:

Code:
--disable-x11
--disable-xdamage
--disable-own-window
--disable-xft
Then remove all X-related options from your conkyrc (conky will let you know which ones are not found if you run it from the console) and enjoy your text-only conky!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Conky: problems displaying output from certain scripts or commands zymos Linux - Software 1 09-10-2009 05:59 PM
Conky Script-Output Problem ganimo Linux - General 2 05-10-2009 07:15 AM
conky not showing all output wilsid Linux - Software 0 06-05-2008 03:54 PM
Make conky window movable jrtayloriv Linux - Desktop 4 12-24-2006 03:25 AM
Conky on Suse 10.0 - *** buffer overflow detected *** conky terminated Slidex Linux - Software 1 03-17-2006 11:50 AM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration