LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-23-2005, 08:40 PM   #1
digimafia
LQ Newbie
 
Registered: Aug 2005
Posts: 17

Rep: Reputation: 0
Intel AC'97 Audio Controller Not Working :-(


here is my lspci output:

Quote:
# lspci
00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
01:05.0 Network controller: RaLink: Unknown device 0201 (rev 01)
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
after a fresh install of slackware 10.1 which comes with alsa installed i did the following:

# alsaconf

1. alsaconf builds database
2. alsaconf shows 'intel8x0 Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
3. then it configures snd-intel8x0
4. and writes everything off to /etc/modules.conf
5. alsaconf then says it will run alsasound init script then use amixer to raise volume

after all this i run alsamixer to make sure all master and pcm is un-muted and then i run 'alsactl store' which leads to slackware running 'alsactl restore' at each boot time.

even after all this slackware 10.1 will not emit any sound from it's speakers!

i'm taking a wild guess here but maybe it has something to do with alsasound? a search for alsasound in my linux box results in nothing .. right after this post i will download alsasound and install it maybe that will do the trick?

anyone else here have the same problem or was successful in getting the sound to with in slackware with the same soundcard??

thanks a million - btw i know this same problem has been posted before but as i already mentioned alsaconf, alsactl store, alsamixer DID NOT do the trick.
 
Old 08-23-2005, 10:02 PM   #2
LiNuCe
Member
 
Registered: Apr 2004
Location: France
Distribution: Slackware Linux 10.2
Posts: 119

Rep: Reputation: 15
Re: Intel AC'97 Audio Controller Not Working :-(

Quote:
digimafia: i'm taking a wild guess here but maybe it has something to do with alsasound? a search for alsasound in my linux box results in nothing .. right after this post i will download alsasound and install it maybe that will do the trick?
There is no alsasound command with Slackware Linux 10.1. alsasound is an init script provided with alsa-driver for (un)loading ALSA modules but it is not provided with Slackware Linux which uses its own rc.alsa init script instead :

Code:
$ su - root
# sh /etc/rc.d/rc.alsa start
The rc.alsa script runs when a Slackware system boots if it has execute permission :

Code:
$ su - root
# chmod 744 /etc/rc.d/rc.alsa
-- LiNuCe
 
Old 08-23-2005, 10:39 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
digimafia, check with lsmod to see if snd-intel8x0m is loaded, if it is, it's known to conflict with snd-intel8x0 module, so add snd-intel8x0m to /etc/hotplug/blacklist
 
Old 08-24-2005, 12:54 AM   #4
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Rep: Reputation: 30
Just checking when you compiled the krnel you did select alsa modules under sound , if not it may not be enabled in kernel still using OSS form 2.4 kernel config.

Just an idea hope it helps
 
Old 08-24-2005, 02:11 PM   #5
digimafia
LQ Newbie
 
Registered: Aug 2005
Posts: 17

Original Poster
Rep: Reputation: 0
alteast it works in VMware :|

i've been installing virtual guest operating system's all day today on VMware Workstation. good news is that i have managed to get sound working in the Slackware 10.1 guest operating system everything worked without a problem after blacklisting snd-intel8x0, rebooting and doing the whole alsaconfig, alsactl, alamixer bit. i tested out a mp3 file with mpg321. at first it didn't work - no sound then i realized all the volume channels were muted back into alsamixer... unmute and voila! got the sound working!

since i have half of my hard drive disk space available about 40g i'm going to install Slackware on that and try to get the sound working and i have a feeling it will workout this time around. and if the sound does work which is the straw that breaks the camel's (windows) back then i have no reason to keep windows xp around anymore i can finally use the xp cd's for beer coasters! i will dedicate all of my 80G to Slackware Linux the one and only.

funny thing the other day i intentionally rather accidently overflowed my buffer. (1) i added the snd-intel8x0 to /etc/hotplug/blacklist (2) changed the executable bit on /etc/rc.d/rc.hotplug (3) restarted the hotplug via '/etc/rc.d/rc.hotplug restart' doing so resulted in a buffer overflow which also led to my monitor changing it's screen resolution to a higher setting which didn't stop even after a reboot - but alteast the buffer overflows were gone.

today i will re-install slackware and enable hotplug during the installion 'echo snd-intel8x0 > /etc/hotplug/blacklist' , 'modprobe snd-intel8x0' and everything else should fall in to it's place - i hope!

PS downloaded an unofficial OpenBSD iso today the installation is harder then expected somewhat similar to FreeBSD installation but I would love to get the system up and running since i've heard so much good things about it.

Last edited by digimafia; 08-24-2005 at 02:24 PM.
 
Old 08-29-2005, 11:04 AM   #6
umina
LQ Newbie
 
Registered: Feb 2005
Posts: 10

Rep: Reputation: 0
Wink Try enabling amplifier

I had trouble with the AC97 driver on my Toshiba M55, and ultimately found the 'problem' was not that complex. It turned out to be the amplifier was not enabled.

Applications/Sound and Video/Volume Control/Edit Preferences. Check the External Amplifier Box. When debugging I suggest you check everything and play a bit, as sometimes bits aren't where they used to be. I've had situations where driver options that should not have existed turned on audio.

Good luck.
Len
WT6G
 
Old 08-31-2005, 09:46 PM   #7
digimafia
LQ Newbie
 
Registered: Aug 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Cool Finally !!!

finally got the sound working!

/etc/rc.alsa was non existent even after running 'alsactl store' so i created my own rc.alsa file and the sound works at boot every single time!

Code:
#!/bin/sh
/etc/rc.d/rc.alsa start
plain and simple i know originally the script is much longer then this but hey this one line works for me so i really don't care that much for a longer script.

i did try using the rc.alsa file from a slax boot up but doing so led to my sound card not working again! so i re-installed all the alsa drivers and libraries and created my own rc.alsa to get things to work.

for one thing i have to learn some more about scripting .. there seems to be so much you can do with scripts it's crazy!

Last edited by digimafia; 09-02-2005 at 01:09 AM.
 
Old 09-12-2005, 04:58 AM   #8
shogun1234
Member
 
Registered: May 2004
Posts: 165

Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
digimafia, check with lsmod to see if snd-intel8x0m is loaded, if it is, it's known to conflict with snd-intel8x0 module, so add snd-intel8x0m to /etc/hotplug/blacklist
the problem i encounter is that when loggin into gnome (x window system),
i can see the sound icon appeared on the panel.
but its sound (volume) is in the min. i can't adjust it to louder.

so i type command "lspic | grep snd" to see weather the module bee installed or not.
then, i get
Code:
snd_intel8x0           34752  0
snd_ac97_codec         83064  1 snd_intel8x0
snd_pcm                95432  2 snd_intel8x0,snd_ac97_codec
snd_timer              26372  1 snd_pcm
snd                    51512  4 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore              10848  1 snd
snd_page_alloc         10372  2 snd_intel8x0,snd_pcm
it looks like i don't have snd-intel8x0m installed as modules,
but i still can't hear sound when using gnome.
the env i use is debian sarge stable 3.1 r0a
with kernel manually built - 2.6.12.4 version.

what else i can check in order to get the sound worked??
i appreciate it, sincerely.

Last edited by shogun1234; 09-12-2005 at 05:03 AM.
 
Old 09-14-2005, 03:09 PM   #9
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Re: Finally !!!

Quote:
Originally posted by digimafia
finally got the sound working!

/etc/rc.alsa was non existent even after running 'alsactl store' so i created my own rc.alsa file and the sound works at boot every single time!

Code:
#!/bin/sh
/etc/rc.d/rc.alsa start
plain and simple i know originally the script is much longer then this but hey this one line works for me so i really don't care that much for a longer script.

i did try using the rc.alsa file from a slax boot up but doing so led to my sound card not working again! so i re-installed all the alsa drivers and libraries and created my own rc.alsa to get things to work.

for one thing i have to learn some more about scripting .. there seems to be so much you can do with scripts it's crazy!
There is a updated package on the 2nd slack CD under testing you should install. I believe its made for 2.6 kernel setups. Where as the default alsa package install is for 2.4 installs. You should of had a rc.alsa in your rc.d scripts.
 
Old 10-04-2005, 03:12 PM   #10
Spoony Bard
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Thanks for this info guys (found it through Google). I've always set Linux servers up in the past, never worrying about the soundcard, but getting my laptop over to Linux was beginng to get tedious.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02) firedance Linux - Hardware 16 07-14-2006 03:06 AM
AC'97 Audio Controller problem on zd8156EA al.basili Linux - Laptop and Netbook 11 11-15-2005 02:01 AM
Gentoo audio not working --intel AC'97 card Brnzwngs Linux - Hardware 6 10-29-2005 06:31 AM
Sound problems with RH8 + Intel 82801DB AC'97 Audio jaakjr Linux - Hardware 8 11-04-2002 11:28 PM
Via Ac'97 Audio Controller (wdm) wonderpun Linux - Hardware 4 10-14-2002 06:53 AM


All times are GMT -5. The time now is 03:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration