Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 06-04-2013, 04:47 PM   #1
LQ Newbie
Registered: Jan 2011
Posts: 14

Rep: Reputation: 0
Icons of some installed programs using sbopkg is missing in KDE/XFCE; Slackware64

I've installed some programs using sbopkg, some have icons like "Skype" or "gpodder" but some don't, like "lyx" or "anki". Whenever I search for them in KDE's application launcher, I just see "Run anki" or lyx (which successfully starts the program) , but no Icon itself. So I can't for example search for them manually through menus (of KDE or XFCE) or put them in the Desktop or whatever. Why is that?

Old 06-05-2013, 09:56 AM   #2
Senior Member
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,934

Rep: Reputation: 609Reputation: 609Reputation: 609Reputation: 609Reputation: 609Reputation: 609
it depends on the upstream source code itself. Sometimes, they do not provide icons, so manual addition must be performed
Old 06-05-2013, 09:12 PM   #3
Senior Member
Registered: Sep 2004
Distribution: slackware
Posts: 1,839

Rep: Reputation: 276Reputation: 276Reputation: 276
I'm not in front of my Slackware machine right now, but I *think* the application launchers are kept in /usr/share/applications/.

If you copy one of the files in that directory, rename and tweak it for your new application, you will get an icon in your menu. You may need to log out of KDE and back in again, but I think it 'watches' that directory for new applications.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Win7 Installed, Slackware64 13.0 Installed BOOTMGR is missing tronayne Slackware 8 11-17-2012 01:38 PM
[SOLVED] Missing Icons in XFCE rkfb Slackware 11 10-22-2012 04:44 PM
[SOLVED] Missing xfce4-power-manager icons in Xfce 4.8 CTM Slackware 5 06-26-2011 03:28 PM
[SOLVED] slackware64-current + xfce; icons and terminal issues lazardo Slackware 4 02-26-2011 02:06 AM
Icons not showing up in certain programs (Debian, XFCE) Rehumanize Linux - Software 0 01-10-2009 06:34 PM

All times are GMT -5. The time now is 04:11 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration