LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-16-2009, 01:48 PM   #1
nirox
LQ Newbie
 
Registered: Sep 2009
Location: Norway
Distribution: Slackware current
Posts: 5

Rep: Reputation: 1
Httpd: "Invalid argument: alloc_listener: failed to get a socket for (null)"


EDIT: Post is rewritten to give info about the problem using 13/current "httpd apr apr-util" and older kernel (in my situation: 2.6.24)

Symptoms:

Code:
# apachectl start
[Wed Sep 16 20:37:56 2009] [crit] (22)Invalid argument: alloc_listener: failed to get a socket for (null)
Syntax error on line 40 of /etc/httpd/httpd.conf:
Listen setup failed
Line 40 of /etc/httpd/httpd.conf:
Quote:
Listen 80
Problem can tempory be solved by downgrading your apr to ftp://ftp.slackware.com/pub/slackwar..._slack12.2.tgz
but its recomended that you upgrade your kernel.

Last edited by nirox; 09-18-2009 at 08:45 AM.
 
Old 09-16-2009, 02:08 PM   #2
tux_dude
Member
 
Registered: Dec 2008
Distribution: Slackware64 Current
Posts: 226

Rep: Reputation: 33
No problem here on slackware64-current. Trying removing the ':' from your config.
 
Old 09-16-2009, 11:50 PM   #3
nirox
LQ Newbie
 
Registered: Sep 2009
Location: Norway
Distribution: Slackware current
Posts: 5

Original Poster
Rep: Reputation: 1
Uh, that was a typo.
It is "Listen 80", but tried with ":80" and "*:80"

I got same error on two different machines using the same versions
 
Old 09-17-2009, 12:32 AM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by nirox View Post
After installing "httpd apr apr-util" using 13/current im getting this:

Code:
# apachectl start
[Wed Sep 16 20:37:56 2009] [crit] (22)Invalid argument: alloc_listener: failed to get a socket for (null)
Syntax error on line 40 of /etc/httpd/httpd.conf:
Listen setup failed
What happens if you start apache with
sh /etc/rc.d/rc.httpd start

Are you actually root when using apachectl?

Both apachectl and rc.httpd work on my end with Slackware64-13.0 and and 32bit 13.0 with the same application versions you have.

What are you editing the config file with? Perhaps it placed some junk on the line. Try blowing out line 40 and retyping Listen 80. Not sure which editors do or do not leave junk behind, I do know nano works.
 
Old 09-17-2009, 01:15 AM   #5
nirox
LQ Newbie
 
Registered: Sep 2009
Location: Norway
Distribution: Slackware current
Posts: 5

Original Poster
Rep: Reputation: 1
Quote:
sh /etc/rc.d/rc.httpd start
Is just a script that execute "apachectl -k start", so its give the same error.
And ofc doing it as root.

Im using "pico" for editing, but shouldnt be the problem as a fresh install without editing any config files gives the same error.
Just to confirm, i commented "Listen 80" and wrote it again on line 41 getting same error with the line referance 41.

EDIT 1: Found this info while googling:
http://rackerhacker.com/2009/08/14/f...cket-for-null/

Quote:
The issue is related to three kernel calls that are used in apr-1.3.8-1: accept4(), dup3() and epoll_create1(). Without these calls, apache is unable to start.
EDIT 2: And the above is solving the problem. Downloaded "slackware-12.2/slackware/l/apr-1.3.3-i486-1.tgz", installed it and the problem is gone, httpd is working
So the problem must be in "apr-1.3.8"?

EDIT 2: replacing apr-1.3.8 with apr-1.3.3-i486-1 solves the problem on both my servers...

EDIT 3: As im getting this problem on 3 different machines, there must be others having same problem?

EDIT 4:
slackware-12.2/patches/packages/apr-1.3.8-i486-1_slack12.2.tgz
Works OK

slackware-current/slackware/l/apr-1.3.8-i486-1.txz
Fails

Last edited by nirox; 09-17-2009 at 04:07 AM.
 
1 members found this post helpful.
Old 09-17-2009, 01:40 PM   #6
El Nigromante
Member
 
Registered: Aug 2008
Distribution: Slackware 12.2, Slackware 13.0
Posts: 40

Rep: Reputation: 17
Hello,

Executing:

Code:
# sh /etc/rc.d/rc.httpd start 
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Works just right for me in Slackware 13.0 (32 bits). Here is the log:

Code:
[Thu Sep 17 20:30:57 2009] [notice] Digest: generating secret for digest authentication ...
[Thu Sep 17 20:30:57 2009] [notice] Digest: done
[Thu Sep 17 20:30:58 2009] [notice] Apache/2.2.13 (Unix) DAV/2 configured -- resuming normal operations
[Thu Sep 17 20:31:07 2009] [error] [client 127.0.0.1] File does not exist: /srv/httpd/htdocs/favicon.ico
[Thu Sep 17 20:31:10 2009] [error] [client 127.0.0.1] File does not exist: /srv/httpd/htdocs/favicon.ico

Note: I did a fresh new installation of Slackware 13.0 (32 bits)
 
Old 09-17-2009, 01:58 PM   #7
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 507

Rep: Reputation: Disabled
I'm thinking it could be related to kernel versions. Which kernel version are you running? Are you using the official kernel from Slackware 13.0/current? Can you verify that?
 
Old 09-17-2009, 04:18 PM   #8
nirox
LQ Newbie
 
Registered: Sep 2009
Location: Norway
Distribution: Slackware current
Posts: 5

Original Poster
Rep: Reputation: 1
Tbh i feel abit shamed for not remember last time i upgraded my kernels.
But they where official huge-smp/smp kernels from -current at the time they arrived

Linux Alpha 2.6.24.4-smp #2 SMP
Linux Bravo 2.6.24.5-smp #2 SMP
Linux Charlie 2.6.23.16-smp #2 SMP

Will do a restart with up2date kernel when i got time to go onsite to be sure they get back-up after reboot.

Last edited by nirox; 09-17-2009 at 04:19 PM.
 
Old 09-18-2009, 08:37 AM   #9
nirox
LQ Newbie
 
Registered: Sep 2009
Location: Norway
Distribution: Slackware current
Posts: 5

Original Poster
Rep: Reputation: 1
Okey, did a kernel upgrade and it seems to be the reason for the problem.

Will cleanup start post so ppl with same problem easy can get hand on what it can be...
 
Old 04-10-2010, 08:26 PM   #10
zulsolar
LQ Newbie
 
Registered: Mar 2005
Location: Buenos Aires, Argentina
Distribution: Slackware, Solaris 10, Ubuntu
Posts: 9

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by nirox View Post

EDIT 2: And the above is solving the problem. Downloaded "slackware-12.2/slackware/l/apr-1.3.3-i486-1.tgz", installed it and the problem is gone, httpd is working
So the problem must be in "apr-1.3.8"?

EDIT 2: replacing apr-1.3.8 with apr-1.3.3-i486-1 solves the problem on both my servers...

EDIT 3: As im getting this problem on 3 different machines, there must be others having same problem?
Same issue here. Thanks nirox!! I replaced apr-1.3.8-i486-1.txz with apr-1.3.8-i486-1_slack12.2.tgz and issue resolved. It works now!!

Thanks again dude!!
 
Old 07-22-2012, 03:13 PM   #11
daidoji
LQ Newbie
 
Registered: Nov 2005
Location: Oakland, CA
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Ummm, I'm a little confused. Does anyone know why this works? Is it a kernel issue or a package issue? I seem to be getting the same thing with httpd-2.2.22, apr-1.4.5, and apr-util-1.4.1. If its a kernel issue should I just use a lower version of apache as my VPS provider is being a bit dense on getting a 3.0 kernel installed (current kernel 2.6.26). Any help would be greatly appreciated as it doesn't seem to be located in the apache docs as far as I can tell.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "WARNING: Re-reading the partition table failed with error 22: Invalid argument." ytd Linux - Newbie 6 01-26-2010 10:06 AM
Invalid argument: alloc_listener: failed to get a socket for (null) chandramani_yadav Linux - Server 10 08-15-2009 02:10 AM
alsa mixer sayin "function snd_mixer_load failed:invalid argument" callmeleroi Fedora 0 03-11-2007 09:05 AM
"cp -p" fails with "cp: setting permissions for `/home/svbld/t': Invalid argument" mkhesin Red Hat 1 02-28-2007 12:57 AM
Quagga "Can't bind socket: Invalid argument" JJX Linux - Networking 0 04-29-2004 10:21 AM


All times are GMT -5. The time now is 05:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration