LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-31-2009, 05:45 PM   #1
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Rep: Reputation: 16
HP notebook and Slackware-current: temperature seems a bit high [SOLVED]


Hi all,

As of late I've been "feeling" my HP Dv6663's temperature quite high. Slackware's installed from stock (no kernel recompiling) and I've upgraded to -current.
Code:
root@predator:~# uname -a
Linux predator 2.6.27.7-smp #2 SMP Thu Nov 20 22:32:43 CST 2008 i686 Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz GenuineIntel GNU/Linux
I know these processors dissipate a lot of heat, here's cpuinfo:
Code:
root@predator:~# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
stepping        : 11
cpu MHz         : 2194.705
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm ida
bogomips        : 4389.41
clflush size    : 64
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
stepping        : 11
cpu MHz         : 2194.705
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm ida
bogomips        : 4389.42
clflush size    : 64
power management:
Also there seems to be nothing installed under:
Code:
root@predator:~# ls /proc/acpi/thermal_zone/
root@predator:~#
A while ago, when I first started messing around with Slackware, next of performing a full installation, I would recompile kernel to strip it of any unnecessary module. Then I read somewhere it doesn't make much of a difference and just gave up compiling kernel. Now I seem to be in need of it again... or not?

Any ideas and help will be greatly appreciated!

Thanks in advance!

Last edited by gtludwig; 02-05-2009 at 07:55 AM. Reason: problem solved =)
 
Old 02-02-2009, 05:51 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
Hi

since no-one has replied let me start the ball rolling

You appear to have a portable

I suggest you install lm-sensors...you can also INSTALL the front end gkrellm
run
Code:
sensors-detect
with root powers to check what chips you have on your motherboard.

2) try

Code:
cat /proc/acpi/thermal_zone/THRM/temperature
3) as its a lappy I suggest you move off an hog like KDE gnome and move to a minimal wm like LXDE fluxbox openbox etc

you could also check if you could use smaller apps in liew of Open office? etc
 
Old 02-02-2009, 10:38 AM   #3
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
aus9,

Thanks for the reply! I have followed your lead and installed lm_sensors-3.0.3 and Gkrellm.

As root I typed sensors-detect and it detected a Intel Core family thermal sensor (driver 'coretemp') and it said I should add the following lines to /etc/rc.d/rc.local:
Code:
# Chip drivers
modprobe coretemp
/usr/bin/sensors -s
After
Code:
# /etc/rc.d/rc.local restart
I restarted gkrellm, went configurations and ... voilá! there where options to monitor both CPUs temperatures. CPU core temps have mantained at 55 ~ 56 degrees Celsius.

Now I'm off looking for some extra plugins.

I still haven't found anything under /proc/acpi/thermal_zone, as you may see here, or below, on the attached thumbnails.

My system is, indeed a laptop, and I couldn't get used to "lighter" WM like XFCE, mainly because I think it is too similar to Gnome - which I really tried (more than once!) and did not liked. Also since I didn't like KDE 4.x, I still run KDE 3.5.x. But I think I'll give LXDE a try.

Again I thank your help!

Gustavo
Attached Images
File Type: png acpi.png (19.3 KB, 21 views)

Last edited by gtludwig; 02-03-2009 at 05:42 AM.
 
Old 02-02-2009, 11:34 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
hi

can't see the first image but can see your attachment.

ok try

Code:
su
/etc/init.d/acpid restart
2) you may need to check your motherboard manual and cpu.

not all boards have sensors
some have sensors for fans but not temps

Your bios is the best place to look first...if you can see temps and fan speeds you should get there.

Last edited by aus9; 09-25-2013 at 07:43 PM.
 
Old 02-03-2009, 11:58 AM   #5
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
aus9,

I checked BIOS and have not found temps or fan speeds. Also I can only make gkrellm list core temps after I restart (as root) /etc/rc.d/rc.local. This file does not loads on boot depite being on /etc/rc.d and is executable (chmod +x), but this is another issue.

So I restart rc.local and on gkrellm I go Configurations > Builtins > Sensors > Temperatures and check coretemp@0/temp1 and coretemp@1/temp1, see attached image.

Then gkrellm shows CPU's core temps, but still no fan speed. Going through the notebook's manual I found that there is a fan mounted on the processor.

Finally something that's bugging me is that there is nothing under /proc/acpi/thermal_zone.

Gustavo
Attached Images
File Type: png gkrellmConf.png (41.3 KB, 8 views)
 
Old 02-03-2009, 04:58 PM   #6
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
Check with lsmod if module thermal is loaded. If not, load it with modprobe.

Also, are you using cpu frequency scaling? It is quite important for laptops. Load acpi-cpufreq and cpufreq-ondemand modules (you should uncomment those in /etc/rc.d/rc.modules). Then install cpufrequtils or add next lines to /etc/rc.d/rc.local :

Code:
echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo "ondemand" > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
You have some other governors like performance, powersave etc. I am using laptop(s) as my only system for last 2 and half years, and ondemand governor is probably the best choice. Personally, I think that temperature variations between 45 and 60 C are quite normal for the most time, even higher (arround 70 C) when it is loaded.

Last edited by kukibl; 02-03-2009 at 05:04 PM.
 
Old 02-03-2009, 05:33 PM   #7
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
kukibl,

Thanks for your insights too!

I had already edited /etc/rc.d/rc.modules and uncommented the lines to enable thermal, acpi-cpufreq and cpufreq-ondemand.

Now I installed cpufrequtils I downloaded from SlackBuild.org, and it offered two news commands: cpufreq-info and cpufreq-set. I checked and cpufreq-info gave me this:
Code:
root@predator:~# cpufreq-info
cpufrequtils 005: cpufreq-info (C) Dominik Brodowski 2004-2006
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which need to switch frequency at the same time: 0 1
  hardware limits: 800 MHz - 2.20 GHz
  available frequency steps: 2.20 GHz, 2.20 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: ondemand, userspace
  current policy: frequency should be within 800 MHz and 2.20 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz (asserted by call to hardware).
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which need to switch frequency at the same time: 0 1
  hardware limits: 800 MHz - 2.20 GHz
  available frequency steps: 2.20 GHz, 2.20 GHz, 1.60 GHz, 1.20 GHz, 800 MHz
  available cpufreq governors: ondemand, userspace
  current policy: frequency should be within 800 MHz and 2.20 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz (asserted by call to hardware).
root@predator:~#
I imagined what cpufreq-set might do, so I tried # cpufreq-set --help, which returned what I expected and decided not to play with it!

So I figure all is good here! At the moment, gkrellm is showing both CPUs to be under 45 C, as you can see on the attached image.

I guess now I need a plugin for gkrellm monitor my processor fan.

Off digging one!

Thanks so far,

Gustavo
Attached Images
File Type: png gkrellm.png (40.7 KB, 5 views)
 
Old 02-03-2009, 05:59 PM   #8
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
In general, I don't use cpufrequtils, I prefer manual way (I gave you an example in my previous post).

Anyway, for general use, cpufreq-set is quite easy:

Code:
#cpufreq-set -c[core number] -g[name of the governor]
In your case, you would do like this:

Code:
#cpufreq-set -c 0 -g ondemand
#cpufreq-set -c 1 -g ondemand
For advanced use (min. and max. freqs) consult man and help pages.
 
Old 02-03-2009, 07:18 PM   #9
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
kukibl,

I just added the lines to /etc/rc.d/rc.local:
Code:
echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo "ondemand" > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
I'm just a little worried that rc.local do not seems to be loaded at startup. So I may have to use cpufrequtils, that seems to be a more permanent solution, right?

Thanks so far,

Gustavo
 
Old 02-04-2009, 05:48 AM   #10
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware64
Posts: 68

Rep: Reputation: 20
I am not sure if cpufrequtils are more permanent solution. As I wrote, I don't use them. You should check if there is rc.cpufreq in /etc/rc.d (since you installed cpufrequtils from SlackBuilds) and make it executable.

I saw you started new thread concerning rc.local problem. It should work, unless you did some modifications to /etc/rc.d/rc.M file or permissions. Check ones again if rc.local has executable permission and is everything all right in rc.M file (find line that is concerning rc.local). Also, maybe you should write command with full path. For example: /sbin/cp some-file some-other-file.
 
Old 02-04-2009, 06:33 AM   #11
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
hi
In addition
I forgot to mention there is a tweak file called /etc/sensors.conf

Also when running sensors-detect with root powers .....hopefully you get to a line or 2 to put in
/etc/modules
and I think you need to type yes (in full rather than y)?
 
Old 02-05-2009, 07:53 AM   #12
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
kukibl,

I'm not using cpufreq-set, but from time to time I check CPUs frequency with cpufreq-info. When idle CPU frequencies are 800MHz and core temps vary 35 ~ 45 C. When compiling (a big package, say wine) CPU frequencies jump to 2.20GHz and core temps escalate to 50 ~ 60 C. And I'm pretty satisfied with this! However, I found no /etc/rc.d/rc.cpufreq.

I managed to solve the /etc/rc.d/rc.local issue as well, writing the command with full path name, replacing the "." for "/bin/sh" when starting some services and calling rc.local at /etc/rc.d/rc.M.

aus9,

After running
Code:
# sensors-detect
I got the following two lines to put in /etc/rc.d/rc.local
Code:
modprobe coretemp
/usr/bin/sensors -s
Again thanks for taking the time to help me out!

Cheers,
Gustavo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Thinkpad temperature is very high in Slackware markluocanada Slackware 13 07-12-2008 08:17 AM
Compaq laptop w/FC6 does emergency shutdown on boot up because of high temperature. st2000 Linux - Laptop and Netbook 1 04-07-2007 01:10 AM
Deactivating forced shutdown because of high temperature? Thora Linux - Kernel 8 05-20-2006 09:05 AM
CPU temperature too high Mr_Zet Linux - Laptop and Netbook 9 11-17-2004 11:55 AM
High CPU temperature Inexactitude Linux - Hardware 6 04-28-2004 03:45 AM


All times are GMT -5. The time now is 06:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration