LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-25-2005, 12:33 AM   #1
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Rep: Reputation: 30
how to play audio cd in slackware 10.1?


In my slackware box I can play mp3 using xmms and it is working fine but no sound if i enter an audio cd.

if i put an audio cd there is no error message, simply i cannot hear anything from my speaker.

regards
anindya
 
Old 06-25-2005, 03:49 AM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
After inserting your audio CD, run the "KsCD" program (in the multimedia section) and press the play button.

If you still hear nothing or nearly, go into a konsole and change to user root ("su -"). Run "alsamixer" and set the "CD" level to +/- its maximum. Press the ESC key and save the settings using "alsactl store".
 
Old 06-25-2005, 05:43 AM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Maybe you don't have the audio cable connected from your cd reader to your soundcard. So analog sound won't be posible, in XMMS select the audio cd plugin and configure it to extract audio digitally.
 
Old 06-25-2005, 07:35 AM   #4
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by gbonvehi
Maybe you don't have the audio cable connected from your cd reader to your soundcard. So analog sound won't be posible, in XMMS select the audio cd plugin and configure it to extract audio digitally.
Noted your point carefully but there is no chance of that error, as I am sure that the audio cable is connected from my CDROM drive to my sound card. I can play CD using that particular CDROM deive from Fedora Core 3.

Regards
anindyanuri
 
Old 06-25-2005, 08:13 AM   #5
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
Did you try what I suggested in my previous post?
 
Old 06-25-2005, 09:31 AM   #6
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
http://xmms.org/docs/readme.php

About half way down it discusses playing cds.
 
Old 06-25-2005, 12:27 PM   #7
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
This is how it works for me in XMMS:
Goto Options->Preferences (or press Ctrl-P)
Select the Audio I/O Plugins tab
Choose input plugin "CD Audio Player" and press Configure
Make sure the device & path are correct (cf /etc/fstab) and choose "Digital Audio extraction"
Press OK and make sure your output plugin is correct (e.g. aRts if you use KDE)
Press OK
Now choose Play Directory (or Shift-L) and chose your CD mount point.
Press the Play button.
 
Old 06-25-2005, 10:43 PM   #8
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by uselpa
After inserting your audio CD, run the "KsCD" program (in the multimedia section) and press the play button.

If you still hear nothing or nearly, go into a konsole and change to user root ("su -"). Run "alsamixer" and set the "CD" level to +/- its maximum. Press the ESC key and save the settings using "alsactl store".
I tried this alsamixer and the scrren which were shown there, I found that volume control of CD is set to zero level. In the top left, I found a message that "CD off". I could able to increase the volume control of the CD with the help of up arrow key but it could not help as I could not make the CD on. How do I turn on the CD's volume control in alsa mixer?

Regards
anindyanuri
 
Old 06-25-2005, 10:55 PM   #9
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Now I could able to turn on the "CD volume control" with m switch of my keyboard and did not forget to save the settings with alsactl store. Still I am not able to hear any music from CD.

Regards
 
Old 06-25-2005, 11:35 PM   #10
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
The problem is solved. Thank you uselpa and other too. Actually the problem generated from another place. Telling you that,

1. During my installation of Slackware 10.1 the OS detected my CD writer drive as /dev/cdrom and CDROM drive was not detected.

2. I made two directories /dev/hdd and /dev/hdc and linked CDROM to /dev/hdd and CDWriter to /dev/hdc.

3. The KsCD-->Extras-->Configure KsCD and the CDDrive option was set to /dev/cdrom. Now I have changed this drive to /dev/hdd and it starts working.

4. However as I already have changed alsamixer as stated in my previous post as per the direction of uselpa (increased the volume of CD Volume control), I made the previous part complete to get sound output and I get the sound output at once.

Thank you all for helping me. I acknowledge all your effort. My best regards to all of you.

Still I have a question to ask :

When my CDWriter was detected first as CDROM (during installation of Slackware 10.1) the permission set to that /dev/cdrom is as follows,
LRWXRWXRWS (giving all in caps to recognize 'L' )

Now the permission set to /dev/hdd and /dev/hdc are as...
BRWXRWXRWX (for both /dev/hdd and /dev/hdc)

Now the question is that, may I get another new problem with the first letter (which is now B) of my drives? Please guide me in this regard.

Regards
anindyanuri
 
Old 06-25-2005, 11:38 PM   #11
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
A more basic problem is if you have permission to access the cdrom drive. I can't tell from your first post if the drive is accessed or not. A quick check is to see if you can play the cd as root.
The default Slackware install does not give permissions for users to access the cdrom.
One way to fix is to "chmod 644 /dev/cdrom". Fedora default install gives permissions to the cdrom but Slackware users learn about device permissions

My post was too slow, it looks like he fixed it.

Last edited by shepper; 06-25-2005 at 11:40 PM.
 
Old 06-25-2005, 11:39 PM   #12
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Usually those "all (read,write,execute) to all" permissions are given to symlinks.
First check it's not a symlink with: ls -l /dev/cdrom
It's expected to see /dev/cdrom to be a symlink to /dev/hdc or whereever you had your CDrom when you installed Slackware.
Usually permissions for harddisk and cdroms are brw-rw---- with root as owner and disk as group in harddisk and cdrom as group on cdroms. So adding your user to the cdrom group (or disk if you want your user to be able to access the harddisk directly) will give you read-write permissions to the raw device.

Last edited by gbonvehi; 06-25-2005 at 11:42 PM.
 
Old 06-25-2005, 11:55 PM   #13
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
In case of file permission what does it mean by those b and l(L)?

regards
anindyanuri
 
Old 06-26-2005, 12:06 AM   #14
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
It indicates the kind of file it's. It's b (or c) for device files, l for links, d for directories, etc.

Last edited by gbonvehi; 06-26-2005 at 12:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
why i can't play my CD audio mamasmoe DamnSmallLinux 1 08-12-2004 07:31 PM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 10:44 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 04:23 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM
play audio cd bfkeats Linux - General 4 02-06-2002 12:19 AM


All times are GMT -5. The time now is 11:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration